View Full Version : 8800 Caller ID not working??

03-06-2007, 02:16 AM
Can anyone help me..

I have all my contacts (via sync from Outlook) on my 8800 and since I travel overseas abit I have added the + and country code in front of all my contacts phone numbers so while in other countries I dont have to do this manually.

Now when one of these people call me their phone number shows on the BB (so caller ID is working) but it doesnt show the persons name as it should do.

If I remove the + country code from the BB number for a contact and then have them call me it then shows their name..

Am I doing something wrong? Why does adding the + country code stop the caller ID showing the name.



03-19-2007, 10:01 AM
This is a common problem since the 8100.

To fix it, press the green call button to get to the phone app.

Hit the blackberry button to the left of the peral and scroll to options.

Now go to smartdialling.

the first option there is for country code. Just select your country code and save.

Voila, your caller id will now work.

Hope this helps.