View Full Version : HELP Blackberry 8700 SOS

03-23-2007, 08:56 AM
I had purchased a Blackberry 8700v from Ebay (the seller had a high number of real feedbacks). Offcourse now the seller won't even respond to me and I had given him a positive feedback as soon as I had popped in the sim and saw my network name (I know I should have waited - stupid me).

The 8700v initially turned on fine, showing my provider's name (Etisalat - Dubai, UAE) and GSM with full signal strength. BUT it would NOT make or receive any calls.

After about 30 minutes, it does not show the provider name instead it just says "SOS" where the signal bars are supposed to show. Sometimes it will show me the network name and signal bars for a few minutes (during which again no calls can be made or received) or it would say "searching for network" or SOS. There is even a constant flashing arrow icon on the top right corner.

I have looked all over the net. I have tried hard resets, blackberry wipeouts, clean firmware installations, upgrades. Still the same problem. My provider even told me that there's nothing wrong with the sim (it works on any other phone including another BB 8700v that I have)

I have also tried about 3 different active sim cards from the same provider. Still no change.

What can I do to get this bb working??? This is getting really frustrating.

I hope there is no hardware problem. I was thinking it could be the sim card holder pins...but I don't know since clearly it is able to read my sim contacts and smss and show the network name sometimes.

PLEASEEEEE, someone help!!!

03-23-2007, 09:17 AM
After some more searching, I read that I have to use Javaloader to properly wipe my blackberry.

Doesn't the Blackberry Desktop Manager format the phone before loading up the new firmware???

The other thing is, I have a 8700v (Vodafone) so I have the Vodafone theme. Now I'm not supposed to be seeing that theme if I had upgraded to the latest cingular firmware right? I still see it. hmm Maybe the DM does not do a clean format.

Can someone please advise me on this. I will try using Javaloader.

03-23-2007, 09:30 AM
DM does not do a full wipe. Use Javaloader to wipe the device then reload the OS.

Is the device locked to Vodafone or is it an unlocked device? If it's locked another carriers sim will not work in the device.

If it's locked wiping the device will do nothing as wiping will not unlock a device.

03-23-2007, 09:47 AM
Sounds to me like it is locked.

Another one of the problems of buying on ebay!

03-23-2007, 10:02 AM
Hey thanks for the quick replies.

Ok I did use jl_cmder to do a clean wipe and then installed the firmware using DM. Still no difference.

And no I purchashed it unlocked, I had mentioned that it DID show the network provider name. It wouldn't do that if the phone were locked (it would show "Invalid SIM" instead). Also when typing "mepd" under Settings >Advanced options > Sim Card, everything shows as disabled.

Any suggestions? Thanks again.

03-23-2007, 01:27 PM
I've attached some screenshots just to give you an idea of whats happening. Observe the times and see how the signal just changes to SOS. It makes no sense.

Even when there is a signal, I cannot make or receive calls.

04-18-2007, 08:33 PM
I will buy this from you if you are inerested in selling.

08-20-2007, 05:18 PM
I have a 8700C from cingular (now the new at&t (cue oasis music) and I am moving to uae.

So I came here to see if I can find the answer to these questions.
1. Will I be able to use my 8700g in UAE with local provider(s) Ethisat/Du?
2. Do I need to update/change firmware/java in order to use a UAE issued sim card?

Thanka to all

08-20-2007, 05:19 PM
I have a 8700C from cingular (now the new at&t (cue oasis music) and I am moving to uae.

So I came here to see if I can find the answer to these questions.
1. Will I be able to use my 8700g in UAE with local provider(s) Ethisat/Du?
2. Do I need to update/change firmware/java in order to use a UAE issued sim card?

Thanks to all

08-26-2007, 02:25 PM
I'm having the same problem as the original poster blackstrawberry. I got my used 8700 (SunCom branded) of ebay. When I popped in my SIM, intially my network T-Mobile's name showed up & signal strength was good. But when I tried to make a call it would say 'call failed'. Now the signal only shows 'SOS'I have tried a fifferent ATT SIM with the same results. I have wiped the device with JL_Commander and reinstalled OS & the phone shows Network lock disabled. Under Options-Security-General Settings no reference shows any IT Policy (under Services is says "***no services***". Anyone any tips? Thanks

08-26-2007, 06:11 PM
Ripped from PinStack:

Troubleshooting the device status on BlackBerry (GSM) - PinStack.com - Blackberry Forums (http://blackberryforums.pinstack.com/4468-troubleshooting_device_status_blackberry_gsm.html)

Hope this helps!

John Clark
08-26-2007, 06:57 PM
First post is a link to Pinstack....thanks for the info.

I would suspect one of two things. Either the phone has a hardware problem (defective) or it has an IT policy on it (even though it doesn't say so.)

Try the instructions in this thread and see if it helps:


08-26-2007, 10:10 PM
Thanks guys, I'll try it.
Is that possible John, a device having an IT Policy eventhough it does not say so? My device does mentions that in the 'Message Background Colours' option 'Entreprise Messages' option is set to 'none'. I have attached a screen shot of the Options-Security-General Settings menu of my 8700...

John Clark
08-26-2007, 10:17 PM
yes, it is possible. It's called a blank policy. When using the Remove IT policy info I've posted in another thread, it actually places a blank policy on the device. A policy is still there it just doesn't show up.

Try the instructions above and see what happens.

08-26-2007, 11:56 PM
John, I have unistalled & reinstalled BB Desktop Manager Software & followed all the IT policy removal instructions from your link (I almost couldn't find the "HKEY_Current_Users\Software\Research In Motion\BlackBerry\PolicyManager
' because "...\Blackberry\PolicyManager" didn't exist until I actually opened DM once). Once the verification process was complete (without a SIM inserted) the General Settings screen did not show any "Services" section, once I inserted the SIM, the "***no services***" shows up again & only "SOS" show up at the signal symbol. I can't make/receive any calls or send/receive any sms. Does this mean that I'm out of luck because it's a hardware problem? I read in some other thread that this could be possible due to the phone being a stolen phone? Again, since I purchased this older phone off ebay, anything is possible right? In anycase, thanks for the helpful tips everyone!

John Clark
08-27-2007, 12:15 AM
Stolen is possible. Defective is possible. Does the sim work in other BB's on TMo? I've never run into your problem. You might be able to contact SunCom to see if it's stolen, not sure though. You may be out of luck....sorry.

08-27-2007, 02:41 PM
Just as a follow up for others....I have verified that my TMo SIM works fine in my other 8700G. My Cingular SIM is also recognized, eventhough the 8700G is network locked. Right after I tested my TMo SIM in the working 8700G, I re-inserted that SIM into my non-working SunCom 8700 and now I do not get the 'SOS' anymore. T-Mobile is also shown as the active network with decent signal strenght, but I still cannot make any call or send sms. I then double checked the 'message center' settings, and the SunCom message Ctr number was entered there. So I simply changed it to the TMo Message Ctr number & figured everything would be ok now. But no luck, after failing to send/receive sms again, I also noticed that the message ctr number also automatically changed back to the SunCom number!
My last resource was to the wipe the phone once more with JL_cmdr (which worked fine), but when I tried to reinstall the OS, DM said that 'no applications for this device are available?? So I went back to start from scratch & uninstalled DM, reinstalled DM (blank policy.bin) & installed the old Handheld OS (vendor.xml removed). Now the phone is back to the old 'no calls' state (PDA works, but SOS calls only) again. I have also tried to email SunCom to check if the phone has been reported stollen, but I don't expect to get much of a response...
I'm out of luck....If I find anything new, I'll post it here...