PDA

View Full Version : 8703e internet... Very disappointed/ defective?


Stockmoose16
06-03-2007, 03:53 PM
Hi,

I'm new to BB, and just purchased the 8703e from Verizon. After reading many reviews, I came to conclusion that Verizon had a blazing fast EVDO network--though it probably only averages around 300kb/s.

Anyhow, I want to visit some simple sites, like Myspace, Gizmodo, Amazon, etc. and it's unbelievably slow. The front page of my space must take 3 min+ to load. I'm in the Los Angeles area, and my phone says "1xEV" in the corner, so I'm definitely on the high speed network. I'm so disappointed in this device, am I doing something wrong?

Also, on about 1/3 of the web pages, normal hyperlinks are greyed out, blocking me from accessing the information I want. Sometimes there's even a message at the top saying something about "page edited for browser"...

Somebody please help. There's no way 300kb is this slow, i've seen dial up that's faster than this.

Dubdub
06-03-2007, 04:09 PM
Well, I don't think dial up is faster than about 53.6 kbps. On average, EV-DO should be somewhere between 400-800 kbps with a max of 1.2 mbps or 3.1 mbps on Rev A. Since you didn't say how good your connection was, I would assume with 300 kbps, you have a decent connection.

That being said, your speed is a factor of several variables, such as the connection itself, device processor, available memory, distance to the tower and the congestion and number of users hitting the tower. Keep in mind that voice has the priority over data. And being in the LA area, I assume there are quite a few users hitting the towers for both voice and data.

Also, those sites you mention are not "simple", they are very graphics intensive and probably not optimized for mobile viewers. There is no way that you will get as fast as on a PC using EVDO, cable or DSL. You just don't have the real estate or horsepower to do so.

Stockmoose16
06-03-2007, 04:27 PM
Even on grpahic intensive pages, it shouldn't take 3+ minutes to load the same material that takes 2 seconds or less on my desktop. Please explain why my 2mb desktop connection can load myspace in 2 seconds, but my 300kb/s+ on my BB takes 3+ MINUTES... something is wrong here, no?

JSanders
06-03-2007, 04:34 PM
Wirelessly posted (8700g: BlackBerry8800/4.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/102)

Dub is only trying to help you (at least to understand), so there is no reason to appear so argumentative. The 8703 might not be the device you need (or that you expect it to be). Good luck.

Stockmoose16
06-03-2007, 05:31 PM
Wirelessly posted (8700g: BlackBerry8800/4.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/102)

Dub is only trying to help you (at least to understand), so there is no reason to appear so argumentative. The 8703 might not be the device you need (or that you expect it to be). Good luck.

I'm not being argumentative, I'm just stating my point... something at 300kb/s shouldn't take 3+ min to load, it should be a matter of seconds. I just loaded Opera Mini onto the device and the same pages which loaded in minutes on the BB browser loaded in seconds. Pretty disappointing that a third party application is needed to get acceptable browsing speeds. I'm really surprised that Blackberry is talked up so much, seems like the built-in browser is dated.

tony158828
06-03-2007, 05:48 PM
Me being in New York City, another heavy metropolitan area, I must say my pages load up rather fast, although I am on a diffrent network, I am currently using Sprint. I dont belive it is the blackberry at all, I've run myspace and such and loaded rather quickly. I dont use a 3rd party browser, I use good ole BB Internet Browser, not the best but good enough for "simple websites"

pronerd
06-03-2007, 05:55 PM
I just loaded Opera Mini onto the device and the same pages which loaded in minutes on the BB browser loaded in seconds.

It the Opera browser loading the images? Do simple pages like Google.com also take a long time to render in the BB browser?

I am guessing that the problem was not the connection speed, but the rendering of the pages. All the flash, JavaScript, plugin crap etc. that the BB has to cleanse to be able to render the page.

Bottom line, I have yet to see any phone that can provide desktop like internet access. The phones just can not keep up with the complexity needed for contemparary web pages. Between on the new JavaScript suport needed and all the plugins I think the best phones are really going to be good for is email and SMS.

Then there is the question of real need for portable internet access. There really isn't that much, if anything, I need to do on the internet that will not wait until I get to my office, or home.

dkf747
06-04-2007, 11:52 AM
My 8700g with EDGE loads pages faster than my wife's 8703e with 1xEV. I don't know why, but it does. I noticed that pages load fast on both after the initial "requesting" phase the browser seems to go through. It seems my 8700g handles that phase faster, but the 8703e loads faster after that phase.

takeshi
06-04-2007, 12:44 PM
I'm not being argumentative, I'm just stating my point... something at 300kb/s shouldn't take 3+ min to load, it should be a matter of seconds. I just loaded Opera Mini onto the device and the same pages which loaded in minutes on the BB browser loaded in seconds. Pretty disappointing that a third party application is needed to get acceptable browsing speeds. I'm really surprised that Blackberry is talked up so much, seems like the built-in browser is dated.
I've never had to wait 3 minutes for a web page and I'm also on EDGE (at&t). Something's off in your situation so it's definitely not an accurate representation of a typical BB user's experience.

Dawg
06-04-2007, 02:27 PM
Hi,

I'm new to BB, and just purchased the 8703e from Verizon. After reading many reviews, I came to conclusion that Verizon had a blazing fast EVDO network--though it probably only averages around 300kb/s.

Anyhow, I want to visit some simple sites, like Myspace, Gizmodo, Amazon, etc. and it's unbelievably slow. The front page of my space must take 3 min+ to load. I'm in the Los Angeles area, and my phone says "1xEV" in the corner, so I'm definitely on the high speed network. I'm so disappointed in this device, am I doing something wrong?

Also, on about 1/3 of the web pages, normal hyperlinks are greyed out, blocking me from accessing the information I want. Sometimes there's even a message at the top saying something about "page edited for browser"...

Somebody please help. There's no way 300kb is this slow, i've seen dial up that's faster than this.

Myspace is graphic intensive so thats some of the slowness hell it takes my top of the line PC a few minutes sometimes.

But I just pulled up myspace on my 7130e with BB browser took 45 seconds to load the page 100% in BB emulation mode.

Maybe you have some of your browser settings wrong

jgb@etree
06-04-2007, 02:57 PM
I'll echo what a few have already said.... My guess is that it's a browser issue rendering the images.

OVERKILL
06-04-2007, 10:26 PM
22 seconds from when I start opening the browser to MySpace being completely rendered on my 8700R with 4.2 running on Rogers with Edge......... That is using the BB browser.

Sounds like something is awry.............