View Full Version : 7100t - won't boot, swi exception

05-28-2005, 11:31 PM
Hello all,

My 7100t worked just fine this afternoon until it went into one of it's long reboots...

So far I've seen various low-level looking errors, including the entire white boot screen flashing/blinkng, a vertcally striped randomly colored frozen boot screen, frequent "SWI exceptions", etc.

The low level usb driver fnctons well enough to be IDed by Windows,but the desktop manager doesn't see the unit.

Pressing and holding Red triggers an hourglass, but the screen goes black after a few minutes.

Naturally, I do not have a recent backup of the data I need.. Well, now.

Is there a debug or recovery mode that will allow dumping the database?

Is there docmentation on OS4 key combos, etc?


06-21-2005, 01:49 PM
I have a user's 7280 that is also coming up with a SWI Exception error. It seems like the BB will work fine for awhile, but then after an hour or so the unit will lock up and present this screen.

The user stated that there might be a correlation between the unit getting warm and the lock-up.

06-21-2005, 05:16 PM
Have you tried reflashing it?