BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-26-2007, 01:07 PM   #1 (permalink)
New Member
 
Join Date: Oct 2007
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES 4.1 install problems

Please Login to Remove!

I'm trying to install BES 4.1 on a W2k Server. We have another W2K Server with Exchange 2000. Both servers have all the latest MS updates.

At the moment I get to the SRP settings step during the install and then get the following Error Messages:

"Unable to find Exchange Server MAPI component"

after clicking ok I get:

"The MAPI subsystem cannot be correctly initialized and used. Please make sure MAPI is installed adn configured properly."


I have a different copy of MAPI32.dll on each server. The exhange server copy is dated 2002-06-18. The BES server is dated 2002-07-24. The BES server doesn't have a copy of cdo.dll but does have cdosys.dll. From what I've read, you can't just change and register mapi32.dll files on the BES server.

Any suggestions?
Offline  
Old 10-26-2007, 01:28 PM   #2 (permalink)
BlackBerry Extraordinaire
 
CanuckBB's Avatar
 
Join Date: Feb 2006
Location: YYZ
Model: 9900
Carrier: Rogers
Posts: 1,183
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default

Install the Exchange management tools on the BES, and keep them at the same patch level as your Exchange server.

Make sure that Outlook is NOT installed on the BES.
Offline  
Old 10-26-2007, 01:33 PM   #3 (permalink)
New Member
 
Join Date: Oct 2007
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by CanuckBB View Post
Install the Exchange management tools on the BES, and keep them at the same patch level as your Exchange server.

Make sure that Outlook is NOT installed on the BES.

Thanks, I'll look into installing the management tools. Any advice on that?

Outlook is not on the BES. Outlook Express is by default but has never been setup or used.
Offline  
Old 10-26-2007, 04:08 PM   #4 (permalink)
New Member
 
Join Date: Oct 2007
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by CanuckBB View Post
Install the Exchange management tools on the BES, and keep them at the same patch level as your Exchange server.

Make sure that Outlook is NOT installed on the BES.
I now have the Exchange Management tools installed and the BES installation completed successfully. I have some new problems with the database but I've run out of time today. I'll be back Monday.
Offline  
Old 10-27-2007, 11:12 PM   #5 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2005
Location: Kitchener, ON
Model: 8120
Carrier: Rogers
Posts: 93
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Don't forget to install the lastest Service Pack (and hotfixes) for Exchange on the BES as well to update the Exchange Management Tools.
Offline  
Old 10-29-2007, 12:15 PM   #6 (permalink)
New Member
 
Join Date: Oct 2007
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by DJChew View Post
Don't forget to install the lastest Service Pack (and hotfixes) for Exchange on the BES as well to update the Exchange Management Tools.
Thanks. The latest service pack and hotfixes are installed as far as MS update is concerned. I haven't found any updates for the Exchange Management Tools and they are the version from the Exchange 2000 CD.
Offline  
Old 10-29-2007, 05:55 PM   #7 (permalink)
CrackBerry Addict
 
bertiebassett's Avatar
 
Join Date: Aug 2005
Location: London, UK
Model: 9700
Carrier: O2
Posts: 961
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Bill Phillip View Post
Thanks. The latest service pack and hotfixes are installed as far as MS update is concerned. I haven't found any updates for the Exchange Management Tools and they are the version from the Exchange 2000 CD.
I've not had to update mine but mine were from exchange 2003 cd-rom
__________________
LOTS of answers here: Main Page - BlackBerryFAQ
Offline  
Old 11-06-2007, 04:30 PM   #8 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2005
Location: Kitchener, ON
Model: 8120
Carrier: Rogers
Posts: 93
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The ones on the Exchange 2000 CD are very old. They don't even work correctly with Outlook 2003.

Updating the Excahgne System Manager is the same as updating an Exchagne server. Apply the latest Service Pack for that version of Exchange, and then apply the latest MAPI and/or CDO hotfix.
Offline  
Old 11-06-2007, 04:38 PM   #9 (permalink)
New Member
 
Join Date: Oct 2007
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by DJChew View Post
The ones on the Exchange 2000 CD are very old. They don't even work correctly with Outlook 2003.

Updating the Excahgne System Manager is the same as updating an Exchagne server. Apply the latest Service Pack for that version of Exchange, and then apply the latest MAPI and/or CDO hotfix.
Thanks, I have everything running now.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.