BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-01-2007, 02:37 AM   #1 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8100
PIN: N/A
Carrier: Optus
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Could not Update Folder State. TagId=xxxxx

Please Login to Remove!

Hi everyone

We are getting severak hundred alert messages every hour from our BES with the following content:

<N/A> | BlackBerry Messaging Agent APEBES02 Agent 2 (Application Event Log on APEBES02) | 11/01/2007 14:55:08 (AFFF4FE4) -> {Dougal.Holmes@watsonwyatt.com.au} Could not Update Folder State. TagId=368140

The BES is running 4.1.4 talking to an Exchange 2003 back end. The tag number usually increments slowly, or will sometimes be 0 (zero)

We have tried wiping the handheld, deleting and re-creating the BES account for the user, resetting the folders in Outlook and have had no change to the alerts.

The user also reports that the BB handheld is using it batteries much faster than usual, and that when first turned on each morning any outstanding messages take 10-15 minutes to arrive (instead of the usual 20-30 seconds)

Help......
Offline  
Old 11-01-2007, 06:58 AM   #2 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Welcome to the forums! I see you've decided to make your first post a good one

Can you also post the Event ID from the Application log?
Does this happen with other users?
Is this person above any quota limit you have set?
Are there other messages similiar to this error but not exactly the same? Usually a series of messages in a row will be generated for a single problem.

Can you move this user to another mailbox store and then back to the original store?
Offline  
Old 11-01-2007, 06:42 PM   #3 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8100
PIN: N/A
Carrier: Optus
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The event ID in the Application log is 20452, with the event source being "Blackberry Messaging Agent"

We have intermittantly seen this with other users, but usually it dies out all by itself, usually within a couple of hours. In this case it's been generating the alerts for over 2 weeks

We are also seeing event ID 20421 "{Dougal.Holmes@watsonwyatt.com.au} - GetAndCreateFolderInfo OpenFolder failed (0x8004010f). FolderID=0" - these come in bursts at random periods.

The user is well below their quota

I'll try moving the mailbox to another mailstore and see what happens.
Offline  
Old 11-01-2007, 08:04 PM   #4 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8100
PIN: N/A
Carrier: Optus
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Moving the mailbox to another message store seems to have slowed down the problem.

However, the move did not work the first (or second) time, and failed with the following error:

<summary isWarning="false" errorCode="0xc1054005">
The MAPI call failed. MAPI or an unspecified service provider. ID no: 80004005-0000-00000000
- <details>

I went looking in Microsoft Technet and found the following article which appeared relevant:

XADM: You Cannot Move a Mailbox, and Error Messages That Contain Error Code 0xfffff9bf Are Logged in the Application Event Log.

However as our Exchange Server logging was set to "none" for all diagnostics, the event log messages indicating which folder was causing the error in moving the mailbox was not there. So I set Mailbox Move Diagnostics to "minimum" and tried moving the mailbox again. And lo and behold, this time the mailbox moved without any errors, and once the BES had reconnected to the moved mailbox, normal Blackberry/BES service resumed, and the 20452 errors stopped - for about an hour or so.....

I cannot explain why the mailbox would not move with logging set to "none", or why the mailbox moved and cleared up the potentially corrupted hidden folder when logging was set to "minimum".

The problem is still there, however the rate has dropped dramatically. Now we are getting the 20452 errors at around 1 every minute or so (before they were coming in every 2-3 seconds)

I do wish the original event was a bit more helpful in indicating what folder it is having trouble with, instead of just giving a meaningless 6 digit number.

Last edited by ausholmesdb : 11-01-2007 at 08:20 PM.
Offline  
Old 11-01-2007, 10:33 PM   #5 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8100
PIN: N/A
Carrier: Optus
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

After a few more hours we are back to the same rate errors (20452) in the event log - around one every 2-3 seconds
Offline  
Old 01-28-2008, 10:37 AM   #6 (permalink)
Kul
Talking BlackBerry Encyclopedia
 
Kul's Avatar
 
Join Date: May 2005
Location: London, England.
Model: 9300
Carrier: Vodafone (UK)
Posts: 439
Post Thanks: 18
Thanked 2 Times in 2 Posts
Default

did you get this resolved ? i am addressing the same issue now.
Offline  
Old 01-28-2008, 11:48 AM   #7 (permalink)
BlackBerry Extraordinaire
 
gibson_hg's Avatar
 
Join Date: Dec 2007
Model: NA
PIN: 80081ES
Carrier: NA
Posts: 1,006
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

If this is the only user affected it could be the mailbox. Sounds like the BES is having trouble reading info from the mailbox. The mailserver could also be busy causing MAPI issues. Check to see if the Exchange server is performing out of normal range, you could setup perfmon and add some counters to check perfomance.

I'm not familiar with using perfmon but it's a great tool for checking Exchange performance.
Offline  
Old 01-29-2008, 04:02 AM   #8 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8100
PIN: N/A
Carrier: Optus
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Not, it has not been resolved

We deleted the Blackberry user, deleted the Blackberry Manager profile on the PC, moved the mailbox to another server, re-created the mailbox, and wiped the handheld device (and various combinations of the above). In all cases within 24 hours the event log messages returned.....

We did find that NewsGator (an RSS feed that links directly to Exchange) was creating folders that the BES server did not seem to like, however whilst removing the NewsGator folders reduced the Event log messages, they did not completely stop.

I've given up and am just living with the Event log messages.......
Offline  
Old 01-29-2008, 05:19 AM   #9 (permalink)
BBF War Game Mod
 
Jadey's Avatar
 
Join Date: Oct 2006
Location: Denver CO
Model: Z10
OS: 10010614
PIN: SEEKRIT innit
Carrier: AT&T
Posts: 4,294
Post Thanks: 9
Thanked 29 Times in 23 Posts
Default

Just a friendly tip - you might want to edit your logs/data before posting (it appears that you included real email addresses).

Real email address and/or server names probably ought not be published in a forum. We're a friendly bunch, but as anyone/any automated process can scan these board, proprietary info really ought to be hidden before posting.
__________________
Jadey : Groupware Infrastructure Architect, Denver CO
If I'm not here, I'm playing World's End on FaceBook. Mob/Mafia Wars are SOO last year
Offline  
Old 02-05-2008, 05:14 PM   #10 (permalink)
Talking BlackBerry Encyclopedia
 
Xaneth's Avatar
 
Join Date: Aug 2006
Model: 9000
Carrier: AT&T
Posts: 228
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I saw this as a solution, but my BES is on the Exchange server, so it doesn't apply to me:

Look if the CDO.dll and the MAPI32.dll versions on your BES are the same as on your Exchange server. If not, copy the CDO.dll and MAPI32.dll from your Exchange to your BES (make a backup of the dll's on your BES first).

Then reboot the BES.
Offline  
Old 01-27-2009, 02:22 PM   #11 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,681
Post Thanks: 270
Thanked 282 Times in 267 Posts
Default

I am getting 100 of this for one user also. running 4.1.6 MR2 with SQL 2005 back end.

{luser@domain.com} Could not Update Folder State. TagId=730403

Found out that the user is archiving all of his old mail.
Guess his mail box is busy, LOL.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10

Last edited by knottyrope : 01-27-2009 at 02:45 PM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.