BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-15-2005, 07:15 AM   #1 (permalink)
New Member
 
Join Date: Jun 2005
Model: 7230
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question BES 4, user problems

Please Login to Remove!

Hi,

We have BES 4 and exchange 2000 server.

Recently one of our blackberries has stopped syncing with the server.
When trying to check the settings in BES I got the following error
Quote:
"Unable to access the users mail account, permission denied"
I contacted our supplier and asked them for support.
I was advised to remove the user from BES then run "handheldcleanup.exe -u" then add the user back into BES. (This is where it all went wrong.)

When I try and add a user from the global address list I get the following error.

Quote:
"Failed to add user Linda to the blackberry server. Unable to open mailbox for this user. The userís mailbox may have been deleted."
The userís mail account is working fine.

I called the support team again to get the response.
Quote:
"We have this and the only way to get around it is to create a new user in active directory. OR restore the users mail account from before the problem started and reinstall BES with a new database and import the users."
Has any one else had this problem with BES 4?

Iím hoping to find a solution as both of these routes seem very messy.

Thanks in advance.
Offline  
Old 06-20-2005, 02:24 AM   #2 (permalink)
Thumbs Must Hurt
 
Rancor's Avatar
 
Join Date: Jun 2005
Location: Dathomir
Model: 7730
Carrier: Zefr
Posts: 171
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

"handheldcleanup.exe -u" should be run while the user is still on the BES, it helps the BES find any users mailboxes that have been moved, the BES then needs to be restarted.
Removing the User then running "handheldcleanup.exe -u" will do nothing for the user in question.

Check that the Besadmin account the BES uses has the correct permissions to access Exchange, exactly as outlined in the pre-installation tasks section in your installation manual.

If the permissions are correct;
Remove user from BES once again.
get hold of a copy of DBclean.exe from your Service provider or R.I.M.
run DBclean from command prompt on Users desktop
[Never use DBclean while the user is on the BES]
when you get the message "nothing to delete" re-add the user to the BES and generate a new encryption key.
__________________
!
Offline  
Old 06-20-2005, 09:04 AM   #3 (permalink)
BlackBerry God
 
jibi's Avatar
 
Join Date: Oct 2004
Location: Jibi's Secret Place
Model: 8900
OS: 4.6.1.174
Carrier: AT&T
Posts: 11,310
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

If you haven't already, reboot the BES. Your issue could have to do with a locked thread that has booted itself out of the account. Some people have complained about this. You may want to check your Exchange logs and make sure they aren't filling up, either.
__________________
In the beginning the Universe was created. This has made a lot of people very angry and is widely regarded as a bad move.
Offline  
Old 06-20-2005, 09:15 AM   #4 (permalink)
New Member
 
Join Date: Jun 2005
Model: 7230
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you all for your help.

Before I go ahead and make and changes is there a utility I can use to backup the server incase every thing goes wrong?

Thanks.
Offline  
Old 06-20-2005, 09:58 AM   #5 (permalink)
Talking BlackBerry Encyclopedia
 
udontknowjack's Avatar
 
Join Date: Aug 2004
Location: State of Confusion
Model: 9000
Carrier: T-Mobile
Posts: 483
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

There is a utility on the BES server called Blackberrybackup.exe. You can use that. Personally sound like a permissions issue. If the BB worked and then quit working, has the mailbox been moved to another store or server where the BES admin ID doesn't have the proper permissions?
Offline  
Old 06-20-2005, 10:08 AM   #6 (permalink)
New Member
 
Join Date: Jun 2005
Model: 7230
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

the mailbox is in the same place as it was before and the user is working fine for email.

I have looked at th permissions and they look fine. All the other users are working ok on the same server and exchange server.

I will try rebooting the server tonight

I also ran the DBcleanup.exe and on first run it says "nothing to delete"

tried to add the user back to the system with no luck.

Last edited by BES4Admin : 06-20-2005 at 10:12 AM.
Offline  
Old 06-20-2005, 10:45 AM   #7 (permalink)
New Member
 
Join Date: Jun 2005
Model: 7230
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Rebooted the server and tried to add the user account back onto BES4.

I am still getting the same error.
Quote:
Failed to add user Linda to the blackberry server. Unable to open mailbox for this user. The userís mailbox may have been deleted.
Offline  
Old 06-27-2005, 12:52 AM   #8 (permalink)
Thumbs Must Hurt
 
Rancor's Avatar
 
Join Date: Jun 2005
Location: Dathomir
Model: 7730
Carrier: Zefr
Posts: 171
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

download and install the Hotfix 2 for BES 4. it contains a fix for this issue
__________________
!
Offline  
Old 06-27-2005, 10:49 AM   #9 (permalink)
Thumbs Must Hurt
 
jrbes's Avatar
 
Join Date: Jun 2005
Location: Here
Model: 8700
Carrier: Cingular
Posts: 161
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you try the IEMStest from the server to the users account - make sure that you can get that to work as well (just to make sure the BES can talk to the users mailbox).
Offline  
Old 07-18-2005, 05:46 PM   #10 (permalink)
New Member
 
Join Date: Jul 2005
Model: 7100R
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same issue. After making sure permissions weren't the case, I did the following:

1. Remove user from the Blackberry Enterprise Server.
2. Close user's Outlook (keep it closed).
3. Export user's mailbox to PST.
4. Delete user's mailbox (not domain account).
5. Create new mailbox.
6. Add user to the Blackberry Enterprise Server.
7. Import user's mailbox from PST.
8. Remove Blackberry profile folders from user's computer.
9. Connect Blackberry & sync.

All working fine now.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.