BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-04-2007, 04:25 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2007
Location: Stuttgart, Germany
Model: 8700
PIN: N/A
Carrier: T-Mobile
Posts: 36
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Help...Database Issue

Please Login to Remove!

A couple of yeras ago I built a BES 4.1 SP HF1 server without MDS components with an SQL 2000 DB. Last night one of our Junior Admins decided to patch the Server up to SP3. However, while applying the patch he choose to patch it with MDS components, in which it built 2 new databases (MDS & a MIDS). After rebooting the server all of the mailagents stopped working. This is a high visability server since all the people that are real people use this and they also sign paychecks. Once the problem was identified and the Admin could not get it to work he restored teh Blackberry server to a pre-patch environment. The mail agents are working again, however when you bring up the BES Manager there is a new entry for HTTPS (it has a few subdirectories). And the new databases are still on the SQL server. When we attempt to apply the patch again it assumes we have MDS and never gives us a choice to patch with out the MDS components.

I am assuming the new databases are causing the problem when attempting to apply the patch. How can I get back to Fridays configuration (Pre-Patch BES and SQL)? What happens if I delete the 2 new databases? Do I need to modify the original DB? Should I go ahead and delete the new DB's and restore the original to the pre-patch environment?
Offline  
Old 11-05-2007, 11:56 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2007
Location: Stuttgart, Germany
Model: 8700
PIN: N/A
Carrier: T-Mobile
Posts: 36
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

No takers on this??? My CIO is breathing down my back on this but he won't buy a support contract!!!???
Offline  
Old 11-06-2007, 12:10 AM   #3 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The new DBs won't impact mail flow ... they're purely for MDS Services. You could remove the databases ... and then go into the BESMgmt database and remove references to the MDS Services components. I wouldn't recommend doing this without RIM on the phone as you can break more than you'll fix if you do it wrong.

If there is a problem with mail then it is a different component having problems.

That said, tell your CIO that you don't know how to fix this and get on the phone with RIM. Pay the ~$200 or so it costs for a call and get the problem fixed properly.

Being able to say you don't know something is admittedly one of the hardest things to do ever ... especially to your boss. If you don't know, and you're not confident, I can't see any reason why he wouldn't pony up the money to get this fixed properly.
Offline  
Old 11-06-2007, 12:32 AM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2007
Location: Stuttgart, Germany
Model: 8700
PIN: N/A
Carrier: T-Mobile
Posts: 36
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

They are a bit tight on the cash side. BES was thrust on me 2+ years ago and I ever since they have been saying that they were gonna shut it down due to cost.

In the last 6-9 months new boss man with a new philosophy, Blackberry is now a critical component (were still paying for training, learn it own your own time) we must have High availability...You know the old song and dance. I spoke with our lead engineer, I have been directed to get a guote with SA training included (so they can shoot it down). This still does not answer my problems now.

When you say going into the Dbase how exactly would I do that. I specialize in Storage & Backup systems...Not Blackberry or SQL yet!

I had my SQL guy detach the 2 DB's from our SQL 2000 server rebooted and I still have " https://<server>.<domain name>:7443/mds" on my Blackberry Manager screen. I have no idea how go in and remove the MDS links in my DB. What would happen If I restored my DB from prior to SP3, and restored my BES server to the same?
Offline  
Old 11-06-2007, 12:53 AM   #5 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
When you say going into the Dbase how exactly would I do that. I specialize in Storage & Backup systems...Not Blackberry or SQL yet!
You'd need a database client ... perhaps one that was included with the sql installation, or something else. But either way you'd need to go into the db.

Quote:
I had my SQL guy detach the 2 DB's from our SQL 2000 server rebooted and I still have " https://<server>.<domain name>:7443/mds" on my Blackberry Manager screen.
Right, you're going to continue to get that whether the db's are detached or not if its not setup.

Quote:
I have no idea how go in and remove the MDS links in my DB.
Which is why you should call RIM.

Quote:
What would happen If I restored my DB from prior to SP3, and restored my BES server to the same?
You'll end up with the server in that state ... any new users added won't be on the BES, any changes made will be lost and email will be a bit messy as the devices will already have mail on them and the BES will send the messages as it doesn't know they're already there with the restored database. In the end, probably more trouble than its worth.
Offline  
Old 11-06-2007, 06:47 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2007
Location: Stuttgart, Germany
Model: 8700
PIN: N/A
Carrier: T-Mobile
Posts: 36
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

We just got a quote in for Level 4 support from RIM and my Managers have lost their mind. 47000 Euros....
Offline  
Old 11-06-2007, 04:21 PM   #7 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Why would you need Level 4 TSupport? Perhaps Level 1 or Level 2 might be a bit more appropriate for your organization ... considering you have none now.
Offline  
Old 11-06-2007, 04:46 PM   #8 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2005
Location: Kitchener, ON
Model: 8120
Carrier: Rogers
Posts: 93
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This KB may be useful:
How to remove BlackBerry MDS Services, BlackBerry MDS Connection Service or instant messaging service
KB12429 - BlackBerry Search Results


The best way to correctly remove the BlackBerry MDS Services is to reinstall the BES without the MDS Services option.

Note: MDS Services has been renamed to MDS-IS (Integration Service).
Note2: MDS Connection Service (MDS-CS) is what allows your BlackBerry users to browse the internet from their device using the "BlackBerry Browser". This is not to be confused with the Internet Browser.
Offline  
Old 11-07-2007, 06:17 AM   #9 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Default

Hello paynet2128, I see that your junior admin restored the backup BESMgmt prior to the upgrade and deleted MDSS and MDSS_DIS database. That HTTPS link is the link for MDSS and it is displayed because the record still exists in the "MDSAGConfig" table. Just ask any of your SQL guy and have the only record remove and after you reload the Blackberry Manager, you should not see it anymore.

I think your junior admin has mistaken "MDS Services" as the MDS in 4.0 that is the one for web browsing, you can't blame him on that. The installer (rather RIM) should be blamed as I know many people have mistaken it for MDS in 4.0. And they are at it again, DJChew just mentioned the name change again MDS-IS (Integration Service) - I believe the change will be the next major release and it is going to cause another round of confusion.
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Old 11-07-2007, 06:34 AM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2007
Location: Stuttgart, Germany
Model: 8700
PIN: N/A
Carrier: T-Mobile
Posts: 36
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

DJChew thanks for the link to the KB article, it was right on the spot. Blackberry is working gret again. The birds are singing...

It also fix my users GAL lookup problems....
Offline  
Old 11-19-2007, 01:29 AM   #11 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2007
Location: Stuttgart, Germany
Model: 8700
PIN: N/A
Carrier: T-Mobile
Posts: 36
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, it appears the KB article only fixed my GAL lookup problem. Over the weekend I went to apply SP3 again. When I started to apply it it never gave me a choice of with MDS or without, it carried on as if I had MDS loaded. It looks like that the DB was update when the SP was first applied and now it assumes the MDS is loaded an in use.

I'm look for options on how to proceed from here, I have no support at present. Do I build a new server and manually move the users over or is there a way to transfer accounts from one BES DB to another?
Offline  
Old 11-19-2007, 09:24 AM   #12 (permalink)
New Member
 
IT-Slave's Avatar
 
Join Date: Mar 2006
Location: Cleveland, OH
Model: none
Carrier: Verizon
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Another thing to look at

I just had this problem come up this weekend. The cause was an automated restart of the BES/Exchange server. This reboot occurred at or near the same time as the Domain Controller/SQL server instance. This causes and issue with being able to communicate with SQL and AD properly. If you're a BES admin and this happens restart the services for BES and that will clear up the problem. Something similar probably happened to the server you guys connect to.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.