BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   BES 4 Calendar wireless sync not working (http://www.blackberryforums.com/bes-admin-corner/10566-bes-4-calendar-wireless-sync-not-working.html)

labberton 06-20-2005 10:38 AM

BES 4 Calendar wireless sync not working
 
We have BES 4.0.18 and Exchange 2003 sp1, since we went to BES version 4 we cannot sync from blackberry to Outlook in the calendar. We can sync from Outlook to Blackberry but not the other way.

I have re-registered cdo.dll, I have rebooted the server, ai have alsogone through a number of steps, re setting up the mail client, new mapi,Blackberry articel KB-03650.

I have logged a call with Vodafone but they have not got back to me, can someone help please?

We have sp1 on the BES Server and all 3 hotfixes applied.

We just need to get the bi-directional wireless calendar working, wireless setting is set on the Blackberry in the calendar and the bi-directional settings are set on the BES.

Please help

mick2404 06-21-2005 07:20 AM

i've got exactly the same problem on vodafone... (n)


makes you wonder if it's a network issue.....

BaronVonBB 06-21-2005 08:19 AM

Here's what is really weird in my environment which consists of BES 4 and Exchange 2000.....some of my users are able to properly do wireless calendar synch, and others aren't?!

Does the desktop version of Outlook (i.e. Outlook 2000 vs Outlook 2003, etc) factor into this equation at all?

jibi 06-21-2005 08:53 AM

labberton, is the cdo.dll the same version on the BES server as it is the Exchange server(s)?

labberton 06-21-2005 10:50 AM

yea same version on both servers.

I have triedeverything, new policy, with enable wireless reconciliation, checked all settings.

I have removed me as a user and reinstalled myself, and it still does not work.

It works for contacts from blackberry to outlook, but not the calendar.

It has sumpted me.

I need some help please?

MedicalEdge 06-21-2005 02:56 PM

If you look in the forums, both here and other sites, you will see that a lot of admin's are having issues with this right now. I spent hours on the phones with RIM and they have been diging through our log files. There are some comon error mssgs that we are finding when someone tries to send a invite or a calendar event from the handheld. I think they need to look at this as a major issue and the tech's and dev people have said that there are quite a few common issues that can cause this....but more and more people are seeing this and the "known fixes" are not working.

cchatagnier 06-21-2005 10:07 PM

Quote:

Originally Posted by MedicalEdge
If you look in the forums, both here and other sites, you will see that a lot of admin's are having issues with this right now. I spent hours on the phones with RIM and they have been diging through our log files. There are some comon error mssgs that we are finding when someone tries to send a invite or a calendar event from the handheld. I think they need to look at this as a major issue and the tech's and dev people have said that there are quite a few common issues that can cause this....but more and more people are seeing this and the "known fixes" are not working.


We have re-assigned the permissions according to RIM's specifications. Still not luck. We are experiencing the same issues as everyone else. Our next step is to completely delete the BESAdmin account from Active Directory and the Exchange and re-create it from scratch.

I completely agree with you that RIM should take this as a major issue and issue a specific bulletin with what needs to be done to correct this critical component. I have received tons of complaints from my user base.

Drork 06-22-2005 04:20 AM

Sync Problem and Time
 
Hi
Had the same problem and in the end found out that this is connected to time zone.
You can see in the event log of the BES a message that will tell you there was a sync problem.

If so make sure that the Handheld and the BES are on the SAME time zone.

if the handheld time zone is different (GMT+X) the meetings created on the device are not synced and you will see a warning in the BES event log at the time the meeting was created.

Hope this will help.

cytexone 06-22-2005 05:46 AM

Sync
 
I'm having the Exact same problem. I was thinking about uninstalling BES and reinstalling it. That was the only Idea I had.

Dan
CYTEXONE

:bb:

bodaggot 06-22-2005 09:35 AM

Sync Hell!!!
 
I am having the same issues, and I mute the phone and scream when I hear the words Calendar and Sync from my users. It has had nothing to do with time zone for me, because when you adjust your BB to the correct zone the change updates the Calendar entry (way it should work). But that still does not fix the sync issues in my world. I have users who tell me they have been working fine - BB to laptop and laptop to BB, and then one day BB to laptop does not work. We have done everything from wiping the handheld and deleting and re-creating the user on the BES, to re-booting and tinkering with mail accounts and BES services. Nothing works! Are there any work arounds or tweaks at all for this problem?

Lost in BB Space

kennyschiff 06-23-2005 11:48 AM

I am not sure if this applies to any of you but we are having the same problem and here is what I have found. We are having an issue where outlook syncs to the BB unit but the BB unit will not sync to Outlook for calendar appointments. We have found that this is because the BES Admin account does not have rights to the Global Address List that the user is a member of. If you you give the BES Admin account rights to the GAL (keeping in mind that the BES Admin account will only see 1 GAL so if you have multiple GALS you're screwed unless you make a GAL that consists of ALL users in your enterprise and then give the BES Admin rights to that GAL exclusively) for that user in Exchange then the BB to Outlook calendar sync works again. Hope this helps some of you....

corey@12mile 06-23-2005 02:09 PM

In the calendar, if you click the wheel, wireless sync is turned on right? As well, delete the Desktop [SYNC] and Desktop [CICAL] service books and then click the wheel and undelete. It will grab a new copy from your BES server, then do a slow sync and maybe keep working after that.

cd.

MedicalEdge 06-23-2005 05:13 PM

Corey --

No luck with that ....in fact we even removed all the service books and reprovisioned. If I dont get a good response from RIM soon we will just have to take the server down and reinstall the app then reattach it to the DB....

MedicalEdge 06-23-2005 05:15 PM

Quote:

Originally Posted by kennyschiff
I am not sure if this applies to any of you but we are having the same problem and here is what I have found. We are having an issue where outlook syncs to the BB unit but the BB unit will not sync to Outlook for calendar appointments. We have found that this is because the BES Admin account does not have rights to the Global Address List


I have verified that the rights for our access account is setup correctly and RIM has also verified this.

corey@12mile 06-24-2005 08:52 AM

Wow... You are sure that BESAdmin is not a member of any type of group that would have deny permissions? (Domain Admins maybe?)

Do you have any errors in your logs from BES getting rejected?

Can you maybe try selecting unidirection sync for a test user and checking to see if you can get a one way sync from the handheld to outlook? Maybe you can get a different error in the logs or something that would help work this out.

Maybe do a high and low search extra copies of cdo.dll on either of the servers that may be errantly registered as well.

Other than that, without seeing it, I am not sure I can be of any help.

cd.

pomc 06-27-2005 01:21 PM

I'm working on this problem now. The calendar syncing was working fine on our BES 4.0 SP1, HF 3 server with over 700 users. But just got a call from a user that said the BB calendar was not wirelessly syncing to Outlook. Tested on my BB and have the same problem.

Will post any results I find.

MedicalEdge 06-27-2005 02:11 PM

A new twist .....
 
We have found something very interesting, our older 7510 units are not having the issue, we are going to try a few things on our end...ie firmware versions etc...I also have RIM T support scheduled to call me this afternoon....I will let you guys know what we find.

pomc 06-27-2005 02:39 PM

Well, like I mentioned, we have had no problems with the BB to Outlook wireless calendar sync. Just today someone contacted me and I noticed the problem also. I had the mail team send me the cdo.dll they were using and I registered it on the BES. Wireless entries from the BB to Outlook are now working again. (y)

So far I haven't seen the duplicate calendar entries appear either. Those would happen sporadically on BB entries.

Update - well, now the BB entries aren't syncing to Outlook again! Still no duplicate entries though.

MedicalEdge 06-27-2005 08:57 PM

:smile:

Whoohoo my users are all better now......

Here is just a rundown of what we did, if you have any questions about what RIM walked me through please let me know and I can go a bit deeper than what I am about to list off. Also please keep in mind that what worked for us may not work for you.


First off - Our BES service account was verified to have proper rights and CDO was not an issue either, if you are having this issue please read the entire thread to see what we had done before the steps I am about to list off. The BES had no other issues other than not being able to

1. We created a new BES Service account.
2. Set up all of its permissions in exchange.
3. Added new BES Service account as local admin on the server.
4. While still logged in as the old service account we then exported HKEY_USERS->Software->RIM to C:\
4. After logging in as that new service account we then stopped all the BES services and set their permissions to utilize the service account.
5. Imported the REG keys that we exported from the other account.
5. Setup the MAPI profile using the MAPI profile tool then a quick reboot.
6. Verified all services and opened BES Mgr to check the status of the server --- All Green at this point.
7. Verified that the calendar is now running just as it did prior to the outage.

The Senior RIM tech stated that they have seen some versions of CDO corrupt the service account mailbox. He stated that if you were to look at the account from an exchange perspective it would look fine, with the correct permissions and that the exchange box would act just like an exchange box should.....but its CDO calls to exchange were corrupt and it could not talk with the BES correctly. Our Nextel BB Rep also stated that what ever really happened about a week prior to the RIM outtages we saw nationwide, that this issue has become a larger problem. He also stated that there were multiple RIM outtages over the past two weeks, not just the big one that hit everyone.

pomc 06-28-2005 10:12 AM

Glad to hear you have everything working. Tonight is our maintenance night and the mail team is installing the cdo.dll patch on the rest of the mail servers. Several of the servers were using the older 5.5.2653.12 version of cdo.dll.

So they'll update the servers and then all the servers including BES get a reboot. So I'll see what happens after that. Everything was working fine, but I can't pinpoint when the calendar problems began.

Another symptom of the calendar issue is when creating an appt on the BB and adding an invitee. When you send it, the invite will return with a red X.

I just rechecked all account permissions and they are all correct. Just want to have everything lined up and accounted for if I have to contact RIM tomorrow.

Thanks for the update.


All times are GMT -5. The time now is 05:26 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.