BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-22-2005, 08:17 PM   #1 (permalink)
BlackBerry God
 
jibi's Avatar
 
Join Date: Oct 2004
Location: Jibi's Secret Place
Model: 8900
OS: 4.6.1.174
Carrier: AT&T
Posts: 11,310
Post Thanks: 0
Thanked 1 Time in 1 Post
Default BES 4.0 SP1 HF3 (Exchange) - removed from downloads?

Please Login to Remove!

Anyone know why RIM removed this from the Service Pack Downloads page? I had downloaded when it was released and installed within our Test environment, but now its removed. Odd...
__________________
In the beginning the Universe was created. This has made a lot of people very angry and is widely regarded as a bad move.
Offline  
Old 06-23-2005, 12:47 AM   #2 (permalink)
Thumbs Must Hurt
 
loonews's Avatar
 
Join Date: Feb 2005
Location: Memphis, TN
Model: 7280, 7290, 7250, 7100
Posts: 98
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (BlackBerry7250/4.0.0 Profile/MIDP-2.0 Configuration/CLDC-1.1)

I know, spent 10 days figuring what tore my bes up, that's why its gone. Any that have it, OTA activate probably will fail.
__________________
------------------------------------------------
Sent from my Blackberry Handheld - The next best thing to No Vacation!
Offline  
Old 06-23-2005, 12:51 AM   #3 (permalink)
BlackBerry God
 
jibi's Avatar
 
Join Date: Oct 2004
Location: Jibi's Secret Place
Model: 8900
OS: 4.6.1.174
Carrier: AT&T
Posts: 11,310
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

I haven't really seen any issues in our Test environment, to be honest. I even went through a database migration during that time. Not a lot of users tho, but I'm definitely glad that I didn't install it to Production
__________________
In the beginning the Universe was created. This has made a lot of people very angry and is widely regarded as a bad move.
Offline  
Old 06-23-2005, 12:51 AM   #4 (permalink)
Thumbs Must Hurt
 
loonews's Avatar
 
Join Date: Feb 2005
Location: Memphis, TN
Model: 7280, 7290, 7250, 7100
Posts: 98
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well I'm not sure exactly when RIM figured out it was a problem. After 8 days giving them a chance to figure it out, I decided to start over with 4.0 to rebuild the database as some of the errors I saw reflected the fact that the database was not functioning correctly.

The problem would only be seen with new users or if you removed a user, readded them, then tried a wireless activation, the activation would hang every time with no less than Handheld Agent, Memos, Tasks, and Address book still initializing.

Once I worked my way up to 4.0 HF3 I stopped, it's rocking now and having little or no issues at this time.

Be very glad you didn't install it, was a ***** to figure out, especially when even they didn't know.
__________________
------------------------------------------------
Sent from my Blackberry Handheld - The next best thing to No Vacation!

Last edited by loonews : 06-23-2005 at 04:29 AM.
Offline  
Old 06-23-2005, 05:42 PM   #5 (permalink)
JRV
Thumbs Must Hurt
 
Join Date: Apr 2005
Location: Houston, TX USA
Model: 7130e
Carrier: Verizon
Posts: 144
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just found this...

http://www.blackberry.com/knowledgec...74325&vernum=0

My symptoms are different...same symptoms we've had since we installed BES 4/Exchange, but much, much worse since HF3. Unfortunately, HF3 was when we also doubled the number of users (to 35), so I don't know if it's the HF or the new load.

Our symptoms: BES server is also a file server. Pretty stout machine; 2x P4 3GHz, 4GB RAM, WS2003. Was a dedicated file server; machine ran flawlessly until BES installed.

File server performance degrades noticeably over a period of (originally) a few weeks and now, a few days, characterized by very slow IO and errors citing "inadequate system resources" when copying/moving/deleting large numbers of files. Has to be restarted to get performance back.

Just before it's about to get really bad, app log fills with 1000s of BES events...different each time. Last time it was

Event Type: Error
Event Source: BlackBerry Synchronization Service
Event Category: None
Event ID: 10000
Date: 6/17/2005
Time: 11:40:57 AM
User: N/A
Computer: SERVER1
Description:
[Microsoft][ODBC SQL Server Driver][SQL Server]Cannot insert duplicate key row in object 'SyncRequest' with unique index 'idx_SyncRequest2'.[SqlState 23000][ODBCRecord::DoSetValue]DATA: Locked[2] UserConfigID[16] Locked[2] Operation[1] Operation[3].

This time it was

Event Type: Warning
Event Source: BlackBerry Messaging Agent SERVER1 Agent 1
Event Category: None
Event ID: 20539
Date: 6/23/2005
Time: 3:21:59 PM
User: N/A
Computer: SERVER1
Description:
text [email address]email address removed} RescanPIMItems(3) failed: ERR_NETWORK_PROBLEM

I can stop the errors by restarting the BES services, but I have to restart the computer before its performance returns to normal.

Something is REALLY wrong with this software.

Last edited by JRV : 06-23-2005 at 05:56 PM.
Offline  
Old 06-28-2005, 07:08 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2005
Model: 8703e
Carrier: Verizon
Posts: 33
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does anyone have instructions on removing HotFix 3?
Offline  
Old 06-28-2005, 09:28 AM   #7 (permalink)
JRV
Thumbs Must Hurt
 
Join Date: Apr 2005
Location: Houston, TX USA
Model: 7130e
Carrier: Verizon
Posts: 144
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

As per the article, we have to call our provider. When I e-mailed ours, this was his reply:
I can schedule time with you to go through this uninstall process which will include the two of us conferencing with Nextel's tier three tech support who will be able to patch us into RIM's Tech Support.


Normally calling into RIM's Tech support is a billable call unless the customer has purchased T-Support and that is why Nextel has to do (at least) mild troubleshooting before connecting to RIM.

I wish they'd just document the removal in the KB. I haven't gone through it yet...I will not have an opportunity until at least late this week, and will have to keep restarting this server every day or two until I do.


I'll see how involved it is; I imagine there are more steps than I could record for documentation purposes and perform at the same time with a degree of confidence that I'd want others relying upon my instructions. This was a 15MB patch, remember! And there may be different removal scenarios depending on configuration, so it's probably best to do it RIM's way.
Offline  
Old 06-28-2005, 09:32 AM   #8 (permalink)
Thumbs Must Hurt
 
loonews's Avatar
 
Join Date: Feb 2005
Location: Memphis, TN
Model: 7280, 7290, 7250, 7100
Posts: 98
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'll tell you what I did, whether you want to or not is up to you.

I reinstalled BES 4.0
Reinstalled BES 4.0 SP1
Reinstalled BES 4.0 SP1 HF1
Reinstalled BES 4.0 SP1 HF2

Worked great.
__________________
------------------------------------------------
Sent from my Blackberry Handheld - The next best thing to No Vacation!
Offline  
Old 06-28-2005, 09:46 AM   #9 (permalink)
JRV
Thumbs Must Hurt
 
Join Date: Apr 2005
Location: Houston, TX USA
Model: 7130e
Carrier: Verizon
Posts: 144
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Who knows; that may be what RIM will tell me! But I'm hoping for a surgical hotfix-ectomy, though. As much of a headache as it was to get BES working in the first place, I'm not anxious to do it again.

If I end up reinstalling, I'll probably put it on a dedicated server or a VM where it can't screw anything up but itself.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.