BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-15-2008, 10:50 PM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Dec 2005
Model: 9630
Carrier: Verizon
Posts: 80
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Activating S/MIME on existing user ... problems

Please Login to Remove!

Hi forum,

I've recently purchased an S/MIME CAL to test out a S/MIME email encryption deployment. I'm having a few problems, and was hoping that others here might have been through this already and be able to help. My problems are:

1) I can't seem to install the S/MIME Support Package on the handheld. This is a 7130e running 4.1.0.344. When I run the application loader, I select the "Blackberry S/MIME Support Package", and start the install, and I get a popup saying:

The application "Blackberry S/MIME Support Package" cannot be loaded, because it requires the following applications that are not available:

net.rim.blackberry.secureemail.smime


I found this in the Rim (KB10558):

BlackBerry Search Results

I've checked that my Device Manager Software is up to date. I've tried this with both the latest v4.3 and also did a fresh install of v4.2_sp1 on another PC, and both give the same error. Has anyone else seen / resolved this problem? Is the missing "application" something that should be on the handheld, or on the PC?

2. I've enabled S/MIME settings on the BES (4.1.4 MR4 / Exchange) at the Server level, but am not able to enable S/MIME for individual users. Under individual user properties, when I try to change "Enable S/MIME Message Processing" to TRUE, it doesn't stick. I can set it, but when I go back into the user, it reverts back to FALSE.

Now I also found this RIM KB13894:

BlackBerry Search Results

This seems like exactly the problem. But I'm not sure I understand the workaround:

The following actions can be implemented as a workaround for this issue:

The BlackBerry smartphone user can install the S/MIME Support Package for BlackBerry smartphones on the BlackBerry smartphone.
The BlackBerry Enterprise Server administrator can activate the BlackBerry smartphone on the BlackBerry Enterprise Server to turn on this option.


But my previous problem is preventing me from installing the S/MIME Support Package on the handheld. Should I try to wipe the handheld, and then install the S/MIME Support Package on the handheld before adding to the BES?

Thanks in advance.....

Last edited by chinatti : 01-15-2008 at 10:52 PM. Reason: added BES version
Offline  
Old 01-16-2008, 11:36 AM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Dec 2005
Model: 9630
Carrier: Verizon
Posts: 80
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Fixed my problem. This post helped:

S/MIME Error

I was able to install the S/MIME Support Package on the handheld after installing the Device O/S Software on the PC running Desktop Manager. After that the Error #1 went away. Then, once S/MIME was installed on the handheld, the "Enable S/MIME Message Processing" setting on BES for the user automatically went to TRUE.

So I think I'm all set now, hopefully this will help anyone down the road if they have this problem........
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.