BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-23-2008, 06:20 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2006
Model: 8800v
Carrier: Vodafone
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy HTTP error 500... new BES Exch2003... any ideas? Please help!

Please Login to Remove!

Hi guys,

Have spent a while looking into this and feel as though I'm getting nowhere fast. Just thought I'd ask in case anyone has seen this happen before, please. We have a new BES 4.1.4 MR4 in a fresh AD2003/Exch2003 environment, running on Win Server 2003 R2. We are trying to configure the MDS service to use our internal proxy server, but browsing attempts from BBs on the BES just do not work. The error we're getting on the device is "HTTP 500: Internal Server Error". Here's what we're getting in the logs (with HTTP logging = Verbose) when we type the user name and password on the device to authenticate:

<2008-01-23 12:02:00.162 GMT>:[1104]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HTTP Thread: ImageJobRunner-12 stopping>
<2008-01-23 12:02:00.162 GMT>:[1105]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HTTP Thread: ImageJobRunner-12 stopped>
<2008-01-23 12:02:00.162 GMT>:[1106]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HANDLER = HTTP, DEVICEPIN = ub, URL = BBC - bbc.co.uk homepage - Home of the BBC on the Internet : SKIPPED IMGS 0 total size 0.0K, SENT IMGS 0, UPDATED IMGS 0, SKIPPED JS 0 total size 0.0K, SENT JS 0, UPDATED JS 0, SKIPPED CSS 0 total size 0.0K, SENT CSS 0, UPDATED CSS 0>
<2008-01-23 12:02:00.162 GMT>:[1107]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HANDLER = HTTP, TRANSCODER = vnd.rim.html, EVENT = Stopped, DEVICEPIN = xxxxxxxx, USERID = ub, CONNECTIONID = 19254259>
<2008-01-23 12:02:00.162 GMT>:[1108]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HANDLER = HTTP, EVENT = SentToDevice, DEVICEPIN = xxxxxxxx, USERID = ub, CONNECTIONID = 19254259, HTTPTRANSMISSION =>
<2008-01-23 12:02:00.162 GMT>:[1108]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HANDLER = HTTP, EVENT = SentToDevice, DEVICEPIN = xxxxxxxx, USERID = ub, CONNECTIONID = 19254259, HTTPTRANSMISSION = [Transmission Line Section]:>
<2008-01-23 12:02:00.162 GMT>:[1108]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HANDLER = HTTP, EVENT = SentToDevice, DEVICEPIN = xxxxxxxx, USERID = ub, CONNECTIONID = 19254259, HTTPTRANSMISSION = HTTP/1.1 500 Internal Server Error>
<2008-01-23 12:02:00.162 GMT>:[1108]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HANDLER = HTTP, EVENT = SentToDevice, DEVICEPIN = xxxxxxxx, USERID = ub, CONNECTIONID = 19254259, HTTPTRANSMISSION = [Headers Section]: 5 headers>
<2008-01-23 12:02:00.162 GMT>:[1108]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HANDLER = HTTP, EVENT = SentToDevice, DEVICEPIN = xxxxxxxx, USERID = ub, CONNECTIONID = 19254259, HTTPTRANSMISSION = Content-Type:application/vnd.rim.html>
<2008-01-23 12:02:00.162 GMT>:[1108]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HANDLER = HTTP, EVENT = SentToDevice, DEVICEPIN = xxxxxxxx, USERID = ub, CONNECTIONID = 19254259, HTTPTRANSMISSION = Connection:Keep-Alive>
<2008-01-23 12:02:00.162 GMT>:[1108]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HANDLER = HTTP, EVENT = SentToDevice, DEVICEPIN = xxxxxxxx, USERID = ub, CONNECTIONID = 19254259, HTTPTRANSMISSION = Pragma:no-cache>
<2008-01-23 12:02:00.162 GMT>:[1108]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HANDLER = HTTP, EVENT = SentToDevice, DEVICEPIN = xxxxxxxx, USERID = ub, CONNECTIONID = 19254259, HTTPTRANSMISSION = Cache-Control:no-cache>
<2008-01-23 12:02:00.162 GMT>:[1108]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HANDLER = HTTP, EVENT = SentToDevice, DEVICEPIN = xxxxxxxx, USERID = ub, CONNECTIONID = 19254259, HTTPTRANSMISSION = Proxy-Connection:Keep-Alive>
<2008-01-23 12:02:00.162 GMT>:[1108]:<MDS-CS_KFMEB01P_MDS-CS_1>:<DEBUG>:<LAYER = IPPP, HANDLER = HTTP, EVENT = SentToDevice, DEVICEPIN = xxxxxxxx, USERID = ub, CONNECTIONID = 19254259, HTTPTRANSMISSION = [Parameters Section]: 0 parameters>

The people who look after our proxy server/firewalls do not know why the 500 response is being sent back. I am able to browse from IE on the BES, using the same credentials and the same proxy server, without issue. The same error occurs when trying to browse external or internal pages from the BB. Any ideas or insight would be greatly appreciated.

EDIT: If I make BES use our .PAC script file, internal pages are accessed via DIRECT instead of PROXY, and work fine.

Many thanks in advance,

Adam.

Last edited by ACJones : 01-23-2008 at 06:45 AM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.