BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-25-2008, 09:40 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Jul 2006
Model: 8300
Carrier: O2
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Messages being delivered to device read

Please Login to Remove!

Hi
I've recently upgraded my server from BES2.2 for Domino to BES 4.1.4
My users have started complaining about messages being received on their handhelds marked as read, and then a couple of hours later, they revert to the way that they should be (i.e. unread) .....
Any ideas?
-D
Offline  
Old 01-25-2008, 10:10 AM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Jul 2006
Model: 8300
Carrier: O2
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Log file entries ...

I've just noticed that there are a huge amount of log entries in the MAGT log that say .... "message status updated to <unread>, constructing notification for the device"
Anyone got any ideas at all on this?
Thanks
-D
Offline  
Old 01-25-2008, 02:58 PM   #3 (permalink)
x14
BlackBerry Extraordinaire
 
Join Date: Jul 2005
Location: NYC
Model: 9800
OS: 6.0.0.546
Carrier: AT&T
Posts: 2,344
Post Thanks: 0
Thanked 17 Times in 16 Posts
Default

Do you have clustered mail servers?
__________________
Exchange 2007/BES 5.0.2 MR2
Offline  
Old 01-25-2008, 03:33 PM   #4 (permalink)
CrackBerry Addict
 
amukhey's Avatar
 
Join Date: Sep 2004
Location: Los Angeles
Model: 9700
Carrier: T-Mobile
Posts: 750
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

ON the persons mail file options, Is the maintain unread marks checked for cluster servers?
Offline  
Old 01-28-2008, 04:18 AM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Jul 2006
Model: 8300
Carrier: O2
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Clustered Mail Server

Hi

Yes, there are cluster mail servers, and they are running an old R5 template on them currently. This is the first Domino R703 server in the environment, and as such, not all features have been enabled.

I'll verify what replication options are enabled, and see if the problem gets resolved.

Thanks for the replies.

-D
Offline  
Old 01-28-2008, 12:39 PM   #6 (permalink)
CrackBerry Addict
 
amukhey's Avatar
 
Join Date: Sep 2004
Location: Los Angeles
Model: 9700
Carrier: T-Mobile
Posts: 750
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK cool looking forward to the response. What is weird i must say is that you upgraded the BES to 7.0x first, which I have never heard of. The good thing about it is that it doesnt need any mail templates so you are somewhat safe.

However, this may be the biggest cause of the read marks not replicating from R5 to R7.

Whats your upgrade plan? Mail Servers and clusters or do you have a hub server?

After testing on a vmware env, I go for the admin / hub server as the first one in the environment and everything else next.
Offline  
Old 01-30-2008, 05:17 AM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Jul 2006
Model: 8300
Carrier: O2
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Sorted out ....

Excellent .... it was down to the UnRead Marks not replicating between the servers. Configured this for all the mail files, and it working perfectly.

amukhey - the actual Domino upgrades are not within my scope, so it will be handled by a different team, who do this all the time. The BES was a requirement, and they didn't want to have to upgrade the server again afterwards!

Many thanks for all the help
Offline  
Old 02-05-2008, 10:08 AM   #8 (permalink)
CrackBerry Addict
 
amukhey's Avatar
 
Join Date: Sep 2004
Location: Los Angeles
Model: 9700
Carrier: T-Mobile
Posts: 750
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Nice glad to hear that!
Offline  
Old 02-05-2008, 12:13 PM   #9 (permalink)
BBF War Game Mod
 
Jadey's Avatar
 
Join Date: Oct 2006
Location: Denver CO
Model: Z10
OS: 10010614
PIN: SEEKRIT innit
Carrier: AT&T
Posts: 4,294
Post Thanks: 9
Thanked 29 Times in 23 Posts
Default

I was faced with same problem - wanted R7 APIs on Domino-BES to handle the encrypted mail on handhelds features. However, was told quite definitively by the BES techs at o2 UK that the Domino-BES should NOT be the first server in Domain to move from R6 to R7. I think it was something to do with strange issues that can occur when you admin server is lower than the domino directory design (which replicates with highest template version in a mixed release org).

It's not that having an R7 BES in an R6 domain is a killer, it just might lead to some unpredictable behaviour...
__________________
Jadey : Groupware Infrastructure Architect, Denver CO
If I'm not here, I'm playing World's End on FaceBook. Mob/Mafia Wars are SOO last year
Offline  
Old 02-05-2008, 12:16 PM   #10 (permalink)
CrackBerry Addict
 
amukhey's Avatar
 
Join Date: Sep 2004
Location: Los Angeles
Model: 9700
Carrier: T-Mobile
Posts: 750
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes I agree--- I would always go with the Admin/Hub server being the first one so the Address Book Template is either upgraded or remains the same (if customization is still needed and being worked on so the pubnames.ntf is not replaced with the new one).

I would upgrade the BES Server after the Admin / Hub Server and Mail Servers are done.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.