BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-25-2008, 10:42 PM   #1 (permalink)
New Member
 
Join Date: Jan 2008
Model: 8830
PIN: N/A
Carrier: Sprint
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES_SBS 2003 - Trouble installing MSDE instance

Please Login to Remove!

Guys/Gals,

I am hitting my head on the wall. I am attempting to install BES on a SBS 2003 server and I am hung up on getting the database instance installed. Here is a copy of the last section of the install log.

counter >= 0, shutdown will be denied. Counter after decrement: -1
Action ended 17:50:55: INSTALL. Return value 3.
Property(C): UpgradeCode = {421A321C-2214-4713-B3EB-253F2FBCCE49}
Property(C): ProductName = Microsoft SQL Server Desktop Engine
Property(C): VersionNT = 502
Property(C): ALLUSERS = 1
Property(C): ARPNOMODIFY = 1
Property(C): DefaultUIFont = Tahoma8
Property(C): INSTALLLEVEL = 3
Property(C): LIMITUI = 1
Property(C): Manufacturer = Microsoft Corporation
Property(C): ProductCode = {E09B48B5-E141-427A-AB0C-D3605127224A}
Property(C): ProductLanguage = 1033
Property(C): ProductVersion = 8.00.2039
Property(C): MsiHiddenProperties = SqlSa...
Property(C): SQLVersion.2D02443E_7002_4C0B_ABC9_EAB2C064397B = 8.00.194
Property(C): SQLExitCode.2D02443E_7002_4C0B_ABC9_EAB2C064397B = 1603
Property(C): APPS_TEST = 1
Property(C): SQLMSDESelected = 1
Property(C): CSDVersionNumber = 1024
Property(C): CSDVersion = 8.00.1100
Property(C): ARPNOREPAIR = 1
Property(C): ARPHELPLINK = BUG: You cannot repair SQL Server 2000 Desktop Engine (Windows) by using the Add/Remove Programs tool
Property(C): Patchlevel = 8.4.1100
Property(C): SystemFolder = C:\WINDOWS\system32\
Property(C): PackageCode = {E1D46ED2-771A-460c-B50A-2B606524C011}
Property(C): ProductState = -1
Property(C): PackagecodeChanging = 1
Property(C): INSTANCENAME = BESMgmt
Property(C): SA...
Property(C): DISABLEROLLBACK = 1
Property(C): CURRENTDIRECTORY = C:\Program Files\Microsoft SQL Server SP4\MSDE
Property(C): CLIENTUILEVEL = 0
Property(C): CLIENTPROCESSID = 3548
Property(C): VersionDatabase = 110
Property(C): VersionMsi = 3.01
Property(C): WindowsBuild = 3790
Property(C): ServicePackLevel = 1
Property(C): ServicePackLevelMinor = 0
Property(C): MsiNTProductType = 2
Property(C): MsiNTSuiteSmallBusiness = 1
Property(C): MsiNTSuiteSmallBusinessRestricted = 1
Property(C): WindowsFolder = C:\WINDOWS\
Property(C): WindowsVolume = C:\
Property(C): System16Folder = C:\WINDOWS\system\
Property(C): RemoteAdminTS = 1
Property(C): TempFolder = C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\1\
Property(C): ProgramFilesFolder = C:\Program Files\
Property(C): CommonFilesFolder = C:\Program Files\Common Files\
Property(C): AppDataFolder = C:\Documents and Settings\Administrator\Application Data\
Property(C): FavoritesFolder = C:\Documents and Settings\Administrator\Favorites\
Property(C): NetHoodFolder = C:\Documents and Settings\Administrator\NetHood\
Property(C): PersonalFolder = C:\Documents and Settings\Administrator\My Documents\
Property(C): PrintHoodFolder = C:\Documents and Settings\Administrator\PrintHood\
Property(C): RecentFolder = C:\Documents and Settings\Administrator\Recent\
Property(C): SendToFolder = C:\Documents and Settings\Administrator\SendTo\
Property(C): TemplateFolder = C:\Documents and Settings\All Users\Templates\
Property(C): CommonAppDataFolder = C:\Documents and Settings\All Users\Application Data\
Property(C): LocalAppDataFolder = C:\Documents and Settings\Administrator\Local Settings\Application Data\
Property(C): MyPicturesFolder = C:\Documents and Settings\Administrator\My Documents\My Pictures\
Property(C): AdminToolsFolder = C:\Documents and Settings\All Users\Start Menu\Programs\Administrative Tools\
Property(C): StartupFolder = C:\Documents and Settings\All Users\Start Menu\Programs\Startup\
Property(C): ProgramMenuFolder = C:\Documents and Settings\All Users\Start Menu\Programs\
Property(C): StartMenuFolder = C:\Documents and Settings\All Users\Start Menu\
Property(C): DesktopFolder = C:\Documents and Settings\All Users\Desktop\
Property(C): FontsFolder = C:\WINDOWS\Fonts\
Property(C): GPTSupport = 1
Property(C): OLEAdvtSupport = 1
Property(C): ShellAdvtSupport = 1
Property(C): Intel = 15
Property(C): PhysicalMemory = 3070
Property(C): VirtualMemory = 2815
Property(C): AdminUser = 1
Property(C): LogonUser = administrator
Property(C): UserSID = S-1-5-21-1182399422-1983172697-852752901-500
Property(C): UserLanguageID = 1033
Property(C): ComputerName = SERVER1
Property(C): SystemLanguageID = 1033
Property(C): ScreenX = 1024
Property(C): ScreenY = 768
Property(C): CaptionHeight = 19
Property(C): BorderTop = 1
Property(C): BorderSide = 1
Property(C): TextHeight = 16
Property(C): ColorBits = 8
Property(C): TTCSupport = 1
Property(C): Time = 17:50:56
Property(C): Date = 1/25/2008
Property(C): MsiNetAssemblySupport = 1.1.4322.2300
Property(C): MsiWin32AssemblySupport = 5.2.3790.1830
Property(C): RedirectedDllSupport = 2
Property(C): Privileged = 1
Property(C): USERNAME = hacox
Property(C): COMPANYNAME = Bluestein And Nichols Law
Property(C): DATABASE = C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\1\e589e6.msi
Property(C): OriginalDatabase = C:\Program Files\Microsoft SQL Server SP4\MSDE\Setup\SqlRun01.msi
Property(C): RollbackDisabled = 1
Property(C): UILevel = 3
Property(C): ACTION = INSTALL
=== Logging stopped: 1/25/2008 17:50:56 ===
MSI (c) (DC:9C) [17:50:56:156]: Note: 1: 1708
MSI (c) (DC:9C) [17:50:56:156]: Product: Microsoft SQL Server Desktop Engine -- Installation operation failed.

MSI (c) (DC:9C) [17:50:56:578]: Grabbed execution mutex.
MSI (c) (DC:9C) [17:50:56:578]: Cleaning up uninstalled install packages, if any exist
MSI (c) (DC:9C) [17:50:56:578]: MainEngineThread is returning 1603
=== Verbose logging stopped: 1/25/2008 17:50:56 ===

CMD Line -- setup INSTANCENAME=xxx8221;BESMgmtxxx8221; SAPWD=xxx8221;AStrongSAPwdxxx8221; /L*v C:\MSDELog.log DISABLEROLLBACK=1

The only thing I notice is that the Property(C): USERNAME=hcox is an old user name that no long exists. The install will 'roll back' and not give me the BESMgmt instance that I need to complete the install of BES.

Can anybody help? I have been through at least 5 kb articles with no fix.

Thanks!

Last edited by davenportkurt : 01-26-2008 at 09:29 AM. Reason: Added CMD line
Offline  
Old 01-28-2008, 07:59 AM   #2 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It looks like you got instructions from here: Chris Dalby Blog Blog Archive Installing MSDE on SBS for Blackberry Enterprise Server

... have you tried simply using the already installed instance of MSDE for BES?
Offline  
Old 01-28-2008, 11:37 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2005
Location: LI, NY
Model: 8320
OS: 4.5
Carrier: T-Mobile
Posts: 96
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Try to remove MSDE, if it is installed prior to installing BES, then let BES install it. Before you start the BES install, check the registry to make sure there is no RIM key in the HKEY LOCAL MACHINE.
Offline  
Old 02-25-2008, 02:38 PM   #4 (permalink)
New Member
 
Join Date: Feb 2008
Model: 8310
PIN: N/A
Carrier: Vodafone UK
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

Has anyone been able to fix the MSDE install problem shown here - I'm experiencing the exact same errors as shown by Davenports log file.

I'm trying to install a new instance "BESMgmt" using the existing MSDE 2000 setup files (sp4) but the MSDE installation keeps rolling back.

I have 4 existing MSDE instances: SBSMONITORING, SHAREPOINT, SOPHOS and WSUS.

I can't re-use any of the existing instances (as suggested in some other threads) because they are all installed for a purpose and are working fine.

Removing MSDE is therefore not an option either.

BTW, This is a brand new Dell server (PE2900) with SBS 2003 Std with W2K3 SP2 and R2 technologies installed. The box has been running barely a week - but is now "live" with the client - with all features except Blackberry of course.

Any ideas?
Offline  
Old 02-27-2008, 06:55 AM   #5 (permalink)
Thumbs Must Hurt
 
Join Date: Jun 2006
Location: Dubai
Model: 8700c
PIN: 203A948C
Carrier: Etisalat
Posts: 62
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

On the server, go to Control Panel->Administrative Tools->ODBC Settings.

On the ODBC Settings Window, go to the System DSN tab and try to create a new DB instance. If it works, then make sure you're using the correct account to install the software.

If it doesnt, then its a problem with your MSDE installation.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.