BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-29-2008, 05:57 AM   #1 (permalink)
New Member
 
Join Date: Jan 2008
Model: 8800
PIN: N/A
Carrier: Orange
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default problem upgrading to 4.1 SP4

Please Login to Remove!

I'm currently on BES 4.0.5.6, which I upgraded from my original installation disks of version 4.0.

The BES server is on a Windows 2003 server with Exchange manager installed.

The SQL Server is SQL 2000 sitting on a remote server.

Stepping through the BES 4.1 SP4 install and during the database upgrade, it stops the BES Services and then fails to do the db upgrade with the message

"DB upgrade failed. Unable to open a required file"

I've tried with both Windows authentication and SQL Authentication. I'm logged on as BESAdmin to do the installation (fairly certain that's what i used for the original install and upgrade).

Any ideas?

The prerequisites only fail on Java 5.0 update 11 (I have version 6 installed so ignored the error).

Last edited by aguess : 01-29-2008 at 06:34 AM.
Offline  
Old 01-29-2008, 06:51 AM   #2 (permalink)
New Member
 
Join Date: Jan 2008
Model: 8800
PIN: N/A
Carrier: Orange
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

hmmm, the setup log seems to suggest it fails on creating the following file;

Code:
[20000] (01/29 11:14:50.791):{0xCDC} (Error from CBESDBInstaller::ProcessSqlFile) problem creating C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\BES_SQL_Generated\tablesV080129111450.sql
[30000] (01/29 11:14:54.070):{0xCDC} [PIPTOOL]: Exiting PIPTool from DBInfoDlg.
which is strange, because just a few steps earlier it created (or copied) a script for the backup of the DB in exactly the same folder i.e.

Code:
[30000] (01/29 11:14:47.997):{0xCDC} Executing file [C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\BES_SQL_Generated\backupV080129111447.sql]
Offline  
Old 01-29-2008, 08:17 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2007
Location: SC
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 113
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I would recommend uninstalling all old versions of java, and only have the java 5.0 update 11 installed. Then resetart your server and try upgrading again.
Offline  
Old 01-29-2008, 09:07 AM   #4 (permalink)
New Member
 
Join Date: Jan 2008
Model: 8800
PIN: N/A
Carrier: Orange
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by LovingMyBB View Post
I would recommend uninstalling all old versions of java, and only have the java 5.0 update 11 installed. Then resetart your server and try upgrading again.
done, got rid of my final prerequisite, but still same problem :(
Offline  
Old 01-29-2008, 09:39 AM   #5 (permalink)
New Member
 
Join Date: Jan 2008
Model: 8800
PIN: N/A
Carrier: Orange
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

hmmm, stranger and stranger ...

i've use filemon to see the opening and closing of all files and it shows the setup.exe creating the file but it gives a bad filename

Code:
14:33:13	Setup.exe:5124	CREATE	C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\BES_SQL_Generated\tablesV080129143313.sql
	NAME INVALID	Options: OverwriteIf  Access: 00120196
from the image below, you can see that there's an odd character in the file name.

www.amt-sybex.com/downloads/BESError.jpg

surely i can't be the only person experiencing this issue. i've tried re-downloading the installation again but it hasn't helped.


i got my install files from ftp://ftp2.rim.net/, is there anywhere else to get them from?
Offline  
Old 02-13-2008, 06:43 AM   #6 (permalink)
New Member
 
Join Date: Jan 2008
Model: 8800
PIN: N/A
Carrier: Orange
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

solution just in case anyone googles this and has the same problem.

for whatever reason the download from the RIM ftp i was given appeared to be corrupt even after downloading it a couple of times from different locations.

i finally got an installation CD direct from my carrier and it installed without a hitch.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.