BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-20-2008, 01:10 PM   #1 (permalink)
Knows Where the Search Button Is
 
arronpitman's Avatar
 
Join Date: Nov 2007
Model: 8100
PIN: N/A
Carrier: vodafone
Posts: 30
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Second BES Same BesMgmt DB - Upgrade Error

Please Login to Remove!

Hello Bes Type People,

Well here is my first post: Hope it makes sense.

I currently have a single bes (4.1.3) running with a remote database. I am running Exchange 2007 SP1 (I know not yet supported but wha the hell it works). I want to install a second bes (4.1.3) using the same BESMgmt database. I have two SRP ID's. I am performing the install as an initial 3.6 install then an upgrade to 4.1.3 (becasue vodafone won't give me the software becasue i installed SP1). I have successfully installed 3.6. Now when I go to install 4.1.3 I get the following error in my log.

=== Log started on 2/20/2008 at 17:11:15 ======================================
Log file C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\UserMigration.log creation OK
Initializing database BESMgmt at machine dbgb0100 using trusted authentication
Database connection OK
Loading status from file C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\UserMigrationStatus.bin
Status loaded from C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\UserMigrationStatus.bin
Migrating BES WGB00202 to primary BES WGB00202 using MAPI profile WGB00202
Migration writes status to the registry
BlackBerry Server WGB00202: Needs to be migrated
MAPI: Initialized MAPI with profile WGB00202
MAPI: Opened message store with profile WGB00202
BlackBerry Server WGB00202: Does not exist in the bes admin's mailbox
Migration finished with return code 12001
Writing status to file C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\UserMigrationStatus.bin
Status written to C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\UserMigrationStatus.bin
Uninitializing migration module
Disconnecting the database
Database disconnect OK
Closing the log file
=== Log ended on 2/20/2008 at 17:11:25 ======================================

Please help, alos if you have any tips the architecture i am choosing that would be greatly appreciated.


THANK YOU!
__________________
ADMAPI
Offline  
Old 02-20-2008, 01:59 PM   #2 (permalink)
Wireless Sith Lord
 
DarthBBerry's Avatar
 
Join Date: Jan 2007
Location: Online
Model: iOS 6
Carrier: Verizon x2
Posts: 1,458
Post Thanks: 2
Thanked 27 Times in 22 Posts
Default

I think the error is resulting from the 3.6 and 4.1 database schema not being compatable with eachother. You need to have both BES at the same version pointing to one DB.
__________________
DarthBBerry
6-Time BlackBerry World Champion (2007-2012)
BlackBerry® Certified Support Specialist v5.0
BlackBerry® Certified System Administrator v5.0
Offline  
Old 02-20-2008, 03:15 PM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Jul 2006
Model: Nope
Carrier: Nope
Posts: 151
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Try Cause 4

Also, you are installing 3.6 on a different machine right now correct? It has its own database, correct? What version of 3.6?
Offline  
Old 02-20-2008, 04:08 PM   #4 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

When you install the new server pick a new database name ... something like BESMgmtTemp

Then after you get it upgraded to 4.1.3 (or 4.1.4, or whatever version you want to be at), run the change database wizard and connect to the already existing production database. Then delete the BESMgmtTemp database.
Offline  
Old 02-21-2008, 06:55 AM   #5 (permalink)
Knows Where the Search Button Is
 
arronpitman's Avatar
 
Join Date: Nov 2007
Model: 8100
PIN: N/A
Carrier: vodafone
Posts: 30
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the speedy response guys! Much appreciated.

I was trying to point the 3.6 install installation on my second server at the 4.1 database. Due to schema differences this is clearly not going work.

hdawg: THANK YOU!

I'll temporarily install to a local database to get the version up to 4.1. Then repoint to the remote database. That will reolve my issue I'm sure.

One other point, I am terrified that when point the second BES to the remote database I'll get an SRP clash and get shutdown by RIM.

As I understand it as long as I specify a seperate SRP key on the second BES and then point it to the remote database then I should get no issues.

Can anyone confirm that this is correct? Plus if you have any other pointers regarding this setup they'd be greatly appreciated.
__________________
ADMAPI
Offline  
Old 02-21-2008, 06:58 AM   #6 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
hdawg: THANK YOU!
You're quite welcome.

Quote:
As I understand it as long as I specify a seperate SRP key on the second BES and then point it to the remote database then I should get no issues.

Can anyone confirm that this is correct? Plus if you have any other pointers regarding this setup they'd be greatly appreciated.
That is absolutely correct. Just make sure you don't have two servers online ever at the same time using the same SRP.
Offline  
Old 02-21-2008, 09:16 AM   #7 (permalink)
Knows Where the Search Button Is
 
arronpitman's Avatar
 
Join Date: Nov 2007
Model: 8100
PIN: N/A
Carrier: vodafone
Posts: 30
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK, we're not quite right just yet. I have installed SQL 2000 SP3 on the second BES. Installed 3.6 using the local database. However, when I get the the User Migration section of the 4.1.3 upgrade process I still get the same error; see log below...


=== Log started on 2/21/2008 at 15:11:16 ======================================
Log file C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\UserMigration.log creation OK
Initializing database BESMgmt at machine WGB00202 using trusted authentication
Database connection OK
Loading status from file C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\UserMigrationStatus.bin
Status loaded from C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\UserMigrationStatus.bin
Migrating BES WGB002021 to primary BES WGB002021 using MAPI profile WGB00202
Migration writes status to the registry
BlackBerry Server WGB002021: Needs to be migrated
MAPI: Initialized MAPI with profile WGB00202
MAPI: Opened message store with profile WGB00202
BlackBerry Server WGB002021: Does not exist in the bes admin's mailbox
Migration finished with return code 12001
Writing status to file C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\UserMigrationStatus.bin
Status written to C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\UserMigrationStatus.bin
Uninitializing migration module
Disconnecting the database
Database disconnect OK
Closing the log file
=== Log ended on 2/21/2008 at 15:11:20 ======================================

Any ideas? Need any more info from me?
__________________
ADMAPI
Offline  
Old 02-21-2008, 09:30 AM   #8 (permalink)
Knows Where the Search Button Is
 
arronpitman's Avatar
 
Join Date: Nov 2007
Model: 8100
PIN: N/A
Carrier: vodafone
Posts: 30
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Got it....

PICNIC.

I was attempting the upgrade before I had even defined the new server, configured the SRP ID and other server properties, in the manager for 3.6.

So of course there was no info inthe bes_admin mailbox relating to my new server. The server had not been set up yet...

I have now configured this information, started the upgrade and successfully began the upgrade process.
__________________
ADMAPI
Offline  
Old 02-21-2008, 09:36 AM   #9 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.