BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-25-2008, 06:24 AM   #1 (permalink)
New Member
 
Nephrops Norvegicus's Avatar
 
Join Date: Mar 2008
Model: 8300
PIN: N/A
Carrier: BT
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question BB Contacts Lookup Returns Old Data

Please Login to Remove!

Hi,

I have cascaded a secondry address book on the Domino server (r7.0.2) and I can perform lookups from the BB and find contact names from that address book. Since then, I have made numerous changes to the existing contacts in the secondry address book and I have also added brand new contacts. From the lotus notes client, the lookup is displaying all the new info but the BB lookup is not returning the new info at all... it even has cached info that no longer exists

Does anyone have any ideas what's going on?
[Our BES version is 4.1.2.5.].

Thanks
Offline  
Old 03-25-2008, 07:58 AM   #2 (permalink)
New Member
 
Nephrops Norvegicus's Avatar
 
Join Date: Mar 2008
Model: 8300
PIN: N/A
Carrier: BT
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question Revision

After more testing, I have found that this is only an issue when the name in the secondry address book matches with one in the primary address book. In domino this would be termed an ambiguous name and the system would return all names. On the BB, this is not happening.

For example...

In this scenario, both contacts are returned fine...
(a) Joe Bloggs, Our Company
(b) Jessie Bloggs, External Company

But in this scenario, contact b is not found at all...
(a) Joe Bloggs, Our Company
(b) Joe Bloggs, External Company

Thanks
Offline  
Old 03-25-2008, 08:14 PM   #3 (permalink)
x14
BlackBerry Extraordinaire
 
Join Date: Jul 2005
Location: NYC
Model: 9800
OS: 6.0.0.546
Carrier: AT&T
Posts: 2,344
Post Thanks: 0
Thanked 17 Times in 16 Posts
Default

You really should be using Directory Assistant instead cascaded address books.
__________________
Exchange 2007/BES 5.0.2 MR2
Offline  
Old 03-26-2008, 08:53 AM   #4 (permalink)
New Member
 
Nephrops Norvegicus's Avatar
 
Join Date: Mar 2008
Model: 8300
PIN: N/A
Carrier: BT
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Domino DA

Hi,

I've enabled Directory Assistance this morning and removed the names= line. Domino has been restarted. I've also added this registry setting:

HKEY_LOCAL_MACHINE\software\research in motion\blackberry enterprise server\agents=1

...And restarted the bes contoller service. The problem is still apparent. Any more ideas?

Thanks for you help
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.