BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-28-2008, 01:51 PM   #1 (permalink)
New Member
 
Join Date: Mar 2008
Model: curve
PIN: N/A
Carrier: 02
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Help please - Moved user cannot be activated?

Please Login to Remove!

(firstly, excellent forum. Long time viewing, first time poster)

Ok,

Our setup is a bit confusing so I'll start from the top. One exchange server running Exchange 2003. Firm decided the get a 1 month trial of BlackBerrys so I built a Windows Server 2003 box, installed BES Professional with local MSDE 2000 database. Setup besadmin account, gave it correct permissions according to RIM documentation. Got 4 users running on this absolutely fine.

Month later, firm wants to go ahead with the purchase, so 30 shiney new Blackberrys arrive, new full BES software (with 20 licenses), plus additional 10 licenses. We were given a new SRP for this setup.

Time was tight and the 4 trial users didn't want to experience any downtime so I setup another new W2003 server, installed full BES, applied all 30 licenses, new SRP. Thought it would be fine to use existing Besadmin account as permissions on Exchange server were already set. (Bear in mind that effectively these 2 BES servers don't know about each other). Added 26 new users and everything is working fine.

Now. I wanted to start moving the trial users from one BES to another. I know this can be a bit messy, what with hidden folders etc, so I took caution. I took one user, call him Simon, backed up his device, removed him from the trial BES server and said yes to deleting mailbox information. Waited 20 minutes, and wiped his handheld at the same time. After 20 minutes I went to the new BES, added the user (the pin field was blank as expected), set a wireless activation password, tried a wireless activation from the handheld and after about 20 minutes it popped up with a message about along the lines of wireless activation failed - contact the system administrator. So, I tried a desktop activation, that didn't work - it didn't prompt to create an encryption key or setup the device. Lastly, I tried plugging the device directly into the new BES and assigning it to the user but got a message about the user not being ready and blackberry agent doesn't know about the user yet - try again later. I tried again later and still no luck. It seems I cannot assign this device to this user whichever method I try. Although the new BES reports the user without having device (PIN) associated with it, I think it does somewhere.

I removed the user, wiped the device and tried again. Then I tried with a spare device we have - still no luck. I removed again and again and tried a few more times - still nothing. My last resort was to remove the user, use dbclean against the users mailbox and add the user and try activating but this also didn't work (despite dbclean saying it had found and removed the Blackberry folders).

Then, as a test, I went back to the trial server, added the user and it wirelessly activated first time! Email is now flowing happily. So I'm not sure what's going on. I still have all 4 users working off this trial server which can't go on for long as I want to get rid of it.

Seems I need to do a deep clean on the users mailbox after I remove it from the trial BES. They are using different databases but I wonder if some crap is in the new database against the users name which is stopping it from assigning it to any device.

Anyone got any thoughts? Unfortunately, the 4 trial users are also the 4 top guys at the firm.

Many thanks.

M
Offline  
Old 03-28-2008, 01:56 PM   #2 (permalink)
BlackBerry Extraordinaire
 
gibson_hg's Avatar
 
Join Date: Dec 2007
Model: NA
PIN: 80081ES
Carrier: NA
Posts: 1,006
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

On the "new" BES if you search the MAGT log for that users email address for the day you tried the activations, what errors do you see?

The logs should tell you why the activations failed.
Offline  
Old 03-28-2008, 02:01 PM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

When deleting user from bes select yes on "do you want to delete blackberry information from user mailbox?" Then wait until user account is purged by itself. Then you add it to a new one and obviosly wipe hh before new activation...Can you activate another handheld with same account on the new server?
Offline  
Old 03-28-2008, 02:02 PM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

Quote:
Originally Posted by gibson_hg View Post
On the "new" BES if you search the MAGT log for that users email address for the day you tried the activations, what errors do you see?

The logs should tell you why the activations failed.
Probably you can find entry in app Event log that this device has been activated on the other blackberry server ...
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.