BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-04-2008, 08:11 AM   #1 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8310
PIN: N/A
Carrier: proximus
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default cdo version BES newer than Exchange - is this a problem ?

Please Login to Remove!

calendar items sync from outlook to BB.
notes added to existing calendar item on BB not synced to outlook
location added/changed to existing calendar item on BB not synced to outlook

calendar items added on BB sync to outlook, but when i change them on BB
changes are not synced to outlook. Has this to do with the cdo version or
is this normal.

when creating an appointment on BB its synced to outlook, but an event ID 20216 is logged in event viewer



cdo.dll version 6.5.7974.0 on BES.

cdo.dll version 6.5.7638.2 on exchange 2003 sp2. I can't find an update
for exchange 2003 sp2 with a cdo.dll version the same as BES.



I guess i need an Update for daylight saving time, but where can i find
the latest version for exchange 2003 sp2. The download (kb 926666) has
a Cdo.dll 6.5.7651.61, still lower than on bes.


please help,
thx

Last edited by TTT-BB : 04-04-2008 at 09:20 AM.
Offline  
Old 04-07-2008, 07:53 AM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Jul 2006
Model: 8100
Carrier: 02
Posts: 149
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default microsofts CDO

here you go

Download details: Collaboration Data Objects, version 1.2.1
Offline  
Old 04-07-2008, 08:04 AM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

Quote:
Originally Posted by mattlane View Post
But his exchange version is 2003 not 2007??
Offline  
Old 04-07-2008, 11:17 AM   #4 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8800
PIN: N/A
Carrier: T-Mobile
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same issue... 20216 event id. Every keeps telling me its a permissioning issue. Blackberry service is it running from which logon as? BESADMIN?


This is my post... Check it out...

Hi yesterday we installed a patch for DST on our Exchange server. We upgraded cod as well to 6.5.7651.61 Service pack 2. We upgrade our BES Server as well to 4.0.7.8.

Now for some reason every user is having an issue with there blackberry everytime someone tries to add a new appointment on there BB it will not show up on there Outlook 2003 or 2007. But if they add an appointment on there Outlook it will update on his or her Blackberry. But the other way around won't work. Syn is turned on and this use to work... Any ideas?

Also from the event log i got:

Event ID: 20216

{MYEMAIL@EMAIL.com} Synchronize() failed: ERR_FAIL, Tag=3024864

BES LOG:


[30001] (04/04 08:42:37):{0x1CF8} CDOCalendar::Initialize - Code = 80040705, WCode = 0505, Code meaning = IDispatch error #1285,
[30002] (04/04 08:42:37):{0x1CF8} Server = SERVER, Mailbox = /o=OURSERVER/ou=First Administrative Group/cn=Recipients/cn=jcollazo Description = You do not have permission to log on. [Microsoft Exchange Server Information Store - [MAPI_E_FAILONEPROVIDER(8004011D)]].
[30180] (04/04 08:42:37):{0x1CF8} {jcollazo} CDOCalendar::Initialize - Error in call m_spCalendarFolder = m_spCDOSession->GetDefaultFolder.

[40000] (04/04 08:42:38):{0x1AD8} {me} CDO helper 04385d30 returned error 'CAL_CDO_INIT_FAILED' failed for LongTermEntryId=0 in LaunchCalHelper(1)
[40000] (04/04 08:42:38):{0x1AD8} {me} Unable to launch CDO helper in SynchronizeHelper
[40000] (04/04 08:42:38):{0x1AD8} {me} Unable to process message with LongTermEntryId=0 in SynchronizeHelper
[20216] (04/04 08:42:38):{0x1AD8} {me} Synchronize() failed: ERR_FAIL, Tag=3024864
[40000] (04/04 08:42:38):{0x1AD8} {me}-HandleAppointmentToSynchronize-Exit-rc=Error
[40279] (04/04 08:42:38):{0x1AD8} {me} SubmitToRelaySendQ, Tag=3024864
[40000] (04/04 08:42:37):{0x1CF8} CDO initializing failure in CDO helper 04385d30 (5)

Permission seems to be okay with BES admin account....

---Someone wrote this below:
When you updated the BES, did you perform the install while being logged in as BESAdmin, or were you logged in as a protected account?

1 way calendar sync seems the services are running as a protected account (if permissions are setup fine).

run services.msc, and check to see what the services are logged in as. If most of the services are running as something other than your BES service account, you will need to complete a switch service account procedure.-----

I wrote back...
You are correct, when doing the upgrade i logged in as myself and not BESADMIN. soo i took a look at the services and all Blackberry services logon are under my username..... soo I tried right clicking and properties and changing it to BESADMIN. When doing so and restarting services i was NOT able to send email from the blackberry. Is there something else i am missing????

Let me know what happens with ur issue please
Offline  
Old 04-14-2008, 11:06 AM   #5 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8800
PIN: N/A
Carrier: o2
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm having EXACTLY the same issues with my BES. Have you resolved this yet?
Offline  
Old 04-16-2008, 05:41 AM   #6 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8800
PIN: N/A
Carrier: o2
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Fixed mine - check: BlackBerryForums.com : Your Number One BlackBerry Community

it may be useful?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.