BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-14-2008, 03:17 PM   #1 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8800
PIN: N/A
Carrier: 222
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default User not found in address book - BES 4.1.2 and Domino

Please Login to Remove!

Hi there,

We have a BES server (v. 4.1.2.20) running on Windows 2003 machine along with a Domino 7.0.3 server dedicated for BES. A day ago one of our users complained that he's not getting any emails on his blackberry device (8800).
In the server console and windows event viewer I see the following error:

{Problem User/ORGANISATION} Trying to initialize user (no PIN,noteID:98A)
{Problem User/ORGANISATION} GetUserInfo: User Problem User/ORGANISATION is not found on CN=Main/O=ORGANISATION. Trying to find it by name...
Call to NIFFindByName failed (Entry not found in index 0x0404)
{Problem User/ORGANISATION} Unable to get user information from Address book for user Problem User/ORGANISATION (Entry not found in index 0x0404)
{Problem User/ORGANISATION} User Problem User/ORGANISATION not found in address book (Entry not found in index 0x0404)
{Problem User/ORGANISATION} Unable to initialize BlackBerry Profiles Account (NID=98A) - will retry in 5 minutes

Database permissions seem ok.
There is only one Person document for this user in domino directory. I ran fixup/updall and design refresh to BES user profile database, state databases and names.nsf. This problem occurs for second time. The first time we've deleted the user (clever huh!) and created it again (along with activating the device again) and it worked, but now It's happening again.
I' sorry if it's a stupid case/question, but I'm pretty new to blackberry and I'm stuck into this.

Thanks in advance.
Offline  
Old 04-15-2008, 10:02 AM   #2 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Default

Has the user recently gone thru any name change or recertification in OU? Check the BESMgmt's UserConfig table for the Notes related columns against the user's Person doc to see any discrepencies. Basically BES was not able to initialize the user as it is unable to get the user information from the NAB on the BES.
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Old 04-15-2008, 11:26 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: May 2006
Location: Land of OZ
Model: 9930
Carrier: Verizon
Posts: 126
Post Thanks: 1
Thanked 3 Times in 3 Posts
Default

Is there a replication issue with your NAB on the BES and on the Domino Mail server? (if they are separate servers - I think this is what you said).
Offline  
Old 04-16-2008, 04:19 PM   #4 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8800
PIN: N/A
Carrier: 222
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you for your answers..

@voyager9355:
no, replication goes fine. There are three servers in this domino domain, one of which is the blackberry server. I've changed user's directory server to every one of them (by name and IP address) - just to be sure that the currently used replica of NAB is not corrupted. Every time the same result. Also tried fixup, updall -R on the NAB - no change at all.

@noname:
I've checked the Besmgmt database's table UserConfig - all the fields match what's entered in the person document.

Still no luck with this. I have a feeling that this thing hates me
Offline  
Old 04-17-2008, 10:52 AM   #5 (permalink)
Thumbs Must Hurt
 
m4ilm4n's Avatar
 
Join Date: Oct 2006
Location: Loony bin
Model: 8800
Carrier: T-Mobile
Posts: 111
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does the person doc exist in the NAB on the BES server (in other words, are the NABS consistent)? Have you checked the AdminP database to see if any scheduled actions against that person doc have happened?
Offline  
Old 04-20-2008, 12:54 PM   #6 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8800
PIN: N/A
Carrier: 222
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Unfortunately the address books are consistent and person document exists for that person - that's the first thing I've looked at. No changes are pending in the Adminp database. The person hasn't been changed recently. It's becoming a real mistery
Offline  
Old 04-20-2008, 09:53 PM   #7 (permalink)
Thumbs Must Hurt
 
Join Date: May 2006
Location: Land of OZ
Model: 9930
Carrier: Verizon
Posts: 126
Post Thanks: 1
Thanked 3 Times in 3 Posts
Default

Here's another thought - something you might try...I do this when for whatever reason, I need to regenerate a user ID file.

On the problem user's home server...
Register a "new" person (same name as the problem person) in Domino Admin but set the MAIL SYSTEM field to NONE.
Accept to overwrite the existing person doc with the same name.
Now go into that person's doc in the NAB, and set the MAIL SYSTEM field back to Notes.

This should have no effect on the existing mailfile. Make sure replication happens so the BES NAB is up to date. I'd be curious to know if it works for you.

good luck!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.