BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-18-2008, 07:25 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2008
Model: 7100i
PIN: N/A
Carrier: Sprint/Nextel
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation SP5 Install Process Hung?

Please Login to Remove!

I just started installing SP5 on a 100 user BES install. Everything went smoothly up until the Database Upgrade step and now it just shows five bars for the installing/upgrading database status. It's been this way for about 15-20 minutes with the setup.exe process using about 25% of the cpu usage so it looks like it's doing something.

Is this normal or is my process hung and I should restart... if so how dangerous is it to restart the install now? If it's actually doing something I don't want to stop the install.

I do have some events in my application log that started during the install:

Quote:
SQL Error: 17883, Severity: 1, State: 0
The Scheduler 3 appears to be hung. SPID 53, ECID 0, UMS Context 0x04B96978
Any help is appreciated!
Offline  
Old 04-18-2008, 07:33 AM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

Make sure all connections to a database are closed. (All BB managers should be closed)
Offline  
Old 04-18-2008, 07:35 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2008
Model: 7100i
PIN: N/A
Carrier: Sprint/Nextel
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

We only have the blackberry manager installed on the server and it's not open... it's still at the same point!
Offline  
Old 04-18-2008, 07:36 AM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

How about permissions on SQL database? Is it remote SQL ol local MSDE?
Offline  
Old 04-18-2008, 07:38 AM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2008
Model: 7100i
PIN: N/A
Carrier: Sprint/Nextel
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

We do have the Blackberry BAS (where you can connect the devices through a website) installed on a different computer. Don't know if that could effect it, but I just shut down that computer to see if it'll help. Do I need to restart the install?
Offline  
Old 04-18-2008, 07:39 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2008
Model: 7100i
PIN: N/A
Carrier: Sprint/Nextel
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Running the SQL Server desktop engin. Windows Authentication.
Offline  
Old 04-18-2008, 07:42 AM   #7 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

And you are logged on as besadmin account,right?
Offline  
Old 04-18-2008, 07:43 AM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2008
Model: 7100i
PIN: N/A
Carrier: Sprint/Nextel
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes... I logged in the server with the same account I installed everything with.
Offline  
Old 04-18-2008, 07:43 AM   #9 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

Also I usually stop all BES services before I start upgrade.
Offline  
Old 04-18-2008, 07:44 AM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2008
Model: 7100i
PIN: N/A
Carrier: Sprint/Nextel
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It stopped those automatically. No Blackberry services are running.
Offline  
Old 04-18-2008, 07:50 AM   #11 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2008
Model: 7100i
PIN: N/A
Carrier: Sprint/Nextel
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is the last part in the installer.log file... looks like it was trying to do a backup?

Quote:
[30000] (04/18 07:48:42.534):{0x3F8} SQL being executed:
/************************************************** **************************
backup.sql

This SQL script will backup the BES Mgmt database

(C) 2001-2004 Research In Motion Limited.
************************************************** **************************/
/*
* Backup to database to BACKUPDIR\DATABASENAMEBKUP.bak
*
* Note BACKUPDIR will be defaulted to location of the DATABASENAME files
*/

declare @path varchar(1024)
set @path = (select top 1 filename from sysfiles where name like 'BESMgmt2%')
if @path is null
begin
set @path = (select top 1 filename from sysfiles)
end


declare @indx int,
@lastindx int,
@notdone bit

set @notdone = 1
set @indx = 0
set @lastindx = 0

--find the last . so we can drop everything after it and replace with bak
while (@notdone = 1)
begin
set @indx = (select charindex('.',@path,@indx + 1))
if @indx > 0
begin
set @lastindx = @indx
end
else
begin
Offline  
Old 04-18-2008, 07:55 AM   #12 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

I use remote full sql so it is hard to say what might be different. Is it still at the 5 bars? For me complete upgrade took 10 minutes.
Offline  
Old 04-18-2008, 07:57 AM   #13 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

You upgraded from 4.1.4 or ? Exchange?
Offline  
Old 04-18-2008, 07:57 AM   #14 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2008
Model: 7100i
PIN: N/A
Carrier: Sprint/Nextel
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yep, nothing's changed.... I'm going to try and restart it.
Offline  
Old 04-18-2008, 07:58 AM   #15 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

Good luck and hope you had backup done before you started upgrade.
Offline  
Old 04-18-2008, 08:03 AM   #16 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2008
Model: 7100i
PIN: N/A
Carrier: Sprint/Nextel
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

4.1.4 for Exhange 2003
Offline  
Old 04-18-2008, 08:22 AM   #17 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2008
Model: 7100i
PIN: N/A
Carrier: Sprint/Nextel
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Woohoo... rebooted server... made sure none of the BES services started up automatically. Also, I noticed the sql agent had not been running so I started that up and ran all the optimization jobs and reran the setup and it's flying now! Thanks again!
Offline  
Old 04-18-2008, 08:25 AM   #18 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

Great. Have a good weekend.
Offline  
Old 04-18-2008, 08:26 AM   #19 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2008
Model: 7100i
PIN: N/A
Carrier: Sprint/Nextel
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Also, my server had the one BES database consistency service set to manual and not running. Is this correct?
Offline  
Old 04-18-2008, 08:27 AM   #20 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

That is ok.
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.