BlackBerry Forums Support Community

BlackBerry Forums Support Community (
-   BES Admin Corner (
-   -   BES Newbie needs help (

ergodic 04-25-2008 06:57 PM

BES Newbie needs help
I am trying to do a very simple turn up of BES for a single Blackberry device for a user running on Exchange 2003.There is a firewall out to the Internet.

BES is installed - and so far as I can tell - working. It is on the same server as Exchange I've added the user (state: "initializing), and sent the activation password, which was received. All OK so far.

The problem comes in trying to complete the device activation. I put in the email adddress (, password and public address of the email server for (I've tried it with this, and leaving it blank). But no matter what I put in, the Blackberry simply says it can't complete the activation.

I've tried opening inbound ports 3101, 8080 and 8443 on the firewall, mapped to the server, and I can see the http server page on port 8080, but I'm obviously missing something.

I could try a non-wireless activation, but it seems like this should work and I'd like to understand what I'm doing wrong.

Any help is much appreciated.

kapasaca 04-27-2008 04:54 AM

what error is displayed on the blackberry when trying to activate?
is GPRS or EDGE in capital letters on the blackberry phone?

try to follow the activation email that's sent from the blackberry.
(leave email server address empty)
it's possibly stopped by a spamfilter (corporate or on user's inbox)
it could contain the wrong password (not likely if you're doing it yourself)
it could be that the BESAdmin service account doesn't have the right to access and administer the user's email box. (check for receive as, send as and administer information store right for the BESAdmin on the mailbox store in exchange system manager)
check if you open Exchange System Manager as the BESAdmin and open up the mailbox store to see the mailboxes if you can see that particular user's mailbox.

DavidAdams 04-28-2008 02:42 AM

Are you certain the SIM card has been provisioned for Enterprise?

Are you seeing, all be it briefly, an email in the inbox with an etp.dat attachment, which is then deleted?

nobody7290 04-28-2008 03:27 AM

there is no need to open a port in the firewall.
The only thing which has to be done is to allow outgoing connection.
If you Router is a simple soho-device with NAT, just make sure, that any firewall in the router is turned off.

Check, if the Device shows either GRPS or EDGE in Capital letters. If it does not, talk to your mobile service provider and tell him to provision the device for Blackberry Enterprise Service.
Even, if EDGE or GPRS is on, your provider might block traffic to blackberry. To check this:
in the options Menu of the device, advanced options, look into the HRT table. Open the bold printed entry. If it does not show an APN like, also your mobile operator has to fix this.

If all the above is ok, but activation is still not possible, reboot the machine where the BES runs. Then manually create a simple activation password for the user and again try activation.

gibson_hg 04-28-2008 04:19 AM


Port 3101 needs to be opened on the firewall for Out-bound initiated and bi-directional traffic. But most basic routers usually don't need to be configured, mine didn't when I had my test BES running anyways.


Try using the IEMSTest utility to test permissions. Also, review this article from RIM for troubleshooting EA:

BlackBerry Search Results

Let us know how it goes.

ergodic 05-02-2008 06:44 PM

Thanks for all the suggestions: I'm still working on this. The phone is provisioned correctly and is on EDGE. The IEMStest ran successfully for the user.

There is an etp.dat message sitting in the user's inbox - it just never seems to get processed, at least it isn't getting deleted. Is there something I can check to see why?

ergodic 05-02-2008 07:29 PM

I've restarted all the BES services, and now the etp.dat message seems to be getting picked up and deleted. But nothing happens after that. The phone eventually times out after several minutes with a "Server is not responding" error.

Are there any logs that might provide a clue? The ones in the BES logs folder seem totally cryptic and there's nothing special in the Windows event logs.

hdawg 05-03-2008 05:15 PM

Look at the MAGT, ALRT, and CTRL Logs. Post anything that you'd like explained if you don't understand it.

Give this a review - KB13468 - Server is not responding or an error has occurred

Lastly; close all those ports ... you're swiss-cheesing your firewall and improperly configuring your server.

I'd also recommend getting the documentation from BlackBerry - Manuals and Guides and giving it a review.

ergodic 05-05-2008 02:35 PM

Thank you for the reply.

I closed the firewall ports a long while back - I should have noted that in my last post.

I've already been through the "BlackBerry Wireless Enterprise Activation Technical Overview White Paper" but it doesn't really have much that addresses this situation. I can't find anything in the logs that indicates that anything is wrong, (nor do I see anything in the logs that it is processing the etp.dat message either.) The account is provisioned for enterprise support.

One thing I did note was that this email account had two Exchange SMTP addresses: (eg \"[email and [email address]). The "yyy" was marked as primary, but BES picked up "xxx" as the one it associated - I presume because just because it was first. To make sure this wasn't the problem, I deleted the user, took out the "xxx" - recreated the BES user to associate with "yyy" and then re-entered the "xxx" address in ADCU. It didn't seem to help.

Anyhow I'm tossing in the towel and going to attempt a wired sync to do the activation. I have another client with the exact same setup (even the same carrier: AT&T) and I've had no problems at all getting that one going. There's just something broken here I can't find. If that doesn't work I'll make a fresh post.

All times are GMT -5. The time now is 05:43 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.