BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-30-2008, 09:51 AM   #1 (permalink)
Talking BlackBerry Encyclopedia
 
TreeDude's Avatar
 
Join Date: Apr 2008
Location: Western NY, USA
Model: iPn4S
OS: iOS 7.0.1
PIN: 76E5A626
Carrier: Verizon
Posts: 243
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question Application deployment

Please Login to Remove!

I am trying to push a few apps down to out IT guys. I have not used this function before. I found KB11215. But I am stuck on task 2. When I run the loader /index command it does nothing. The 2 files which as supposed to appear in the applications folder are not there. The command does not give any kind of error. Any ideas?
__________________
Technical Engineer III

BES was decommissioned. Currently using iPhones with Lotus Notes Traveler 9.0.
Offline  
Old 04-30-2008, 11:39 AM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2007
Location: Arizona
Model: 8830
Carrier: Verizon
Posts: 76
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same issue when I was first deploying applications out. My problem was the path etc. The fact the creating a software configuration has to have a UNC path was odd. Anyways this is what I would check.....

1. Make sure your app you want to deploy is in a subfolder in the following path:
- C:\Program Files\Common Files\Research In Motion\Shared\Applications
For example, I deploy sametime this way so mine is C:\Program Files\Common Files\Research In Motion\Shared\Applications\Sametime

2. Make sure you have the .COD and .ALX files in the subfolder. Unless it is sametime which just has the .ALX folder and the .COD files are stored in the proper version folders (i.e. For_4.0.0 & For_4.2.0).

3. Run the loader.exe /index command again. Check for the .XML and .PKG files it is supposed to create.

4. Next create your Software Configuration in BES manager and your off to the races.


Im running BES 4.1.4 for Exchange so it may be different if your on a different platform or version. Sorry if this doesn't help.
Offline  
Old 04-30-2008, 08:45 PM   #3 (permalink)
Ugg
Thumbs Must Hurt
 
Join Date: Dec 2006
Model: 8310
OS: 4.5
Carrier: O2
Posts: 197
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What application is it you're pushing - something that you've written yourself, or something from a third party? If the latter, it may be worth mentioning the application, as someone may have specific experience of it. Sometimes the distributed ALX files are quite complicated for to cope with multiple device OS versions.

Otherwise, what amadru said...
Offline  
Old 05-01-2008, 07:34 AM   #4 (permalink)
Talking BlackBerry Encyclopedia
 
TreeDude's Avatar
 
Join Date: Apr 2008
Location: Western NY, USA
Model: iPn4S
OS: iOS 7.0.1
PIN: 76E5A626
Carrier: Verizon
Posts: 243
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks guys. The KB article made no mention of a sub folder so I did not use one. The command put those 2 files into the folder. However now I am stuck on step 3. When I create the device software config I can see the device firmware I have installed, however the application software is empty. Any more ideas?

EDIT - NVM guys, I got everything working great now.
__________________
Technical Engineer III

BES was decommissioned. Currently using iPhones with Lotus Notes Traveler 9.0.

Last edited by TreeDude : 05-01-2008 at 08:19 AM. Reason: Fixed it
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.