BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-05-2008, 12:49 PM   #1 (permalink)
Talking BlackBerry Encyclopedia
 
sniffs's Avatar
 
Join Date: May 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 230
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default BES not using Sp2

Please Login to Remove!

If my company upgrades our BES to Sp2, will we need to reapply any patches/updates? either XP or BES updates?
__________________
Your lack of planning is not my emergency.
Offline  
Old 05-05-2008, 12:59 PM   #2 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,565
Post Thanks: 256
Thanked 260 Times in 246 Posts
Default

version 4.1.2?
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Online  
Old 05-05-2008, 01:10 PM   #3 (permalink)
Talking BlackBerry Encyclopedia
 
sniffs's Avatar
 
Join Date: May 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 230
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Sorry, forgot to say, we're on version 4.1.5 latest release..

We were on 4.0.7 for a loooong time, everything worked fine then all of the sudden our calendars stopped syncing.. so we updated and now the calendars still aren't syncing, and we're getting 20 minute delay's in email sent to the handhelds.. all the permissions are set correctly and deligating correctly..

just wondering if we install sp2, if we're going to have to reinstall the BES software.. we didnt use the BES admin account when we updated, we used a domain admin account, so I'm wondering if we should have used the bes admin account..
__________________
Your lack of planning is not my emergency.

Last edited by sniffs : 05-05-2008 at 01:12 PM.
Offline  
Old 05-05-2008, 01:19 PM   #4 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,565
Post Thanks: 256
Thanked 260 Times in 246 Posts
Default

Are you talking about BES server running on XP and apply SP 2?

That could be a tough one.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Online  
Old 05-05-2008, 03:30 PM   #5 (permalink)
Talking BlackBerry Encyclopedia
 
sniffs's Avatar
 
Join Date: May 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 230
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

No, it's running in Windows 2003 server..
__________________
Your lack of planning is not my emergency.
Offline  
Old 05-05-2008, 03:48 PM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

oh, you want to upgrade your windows server 2003 install to SP2? Or are you talking about upgrading all of your workstations to XP SP2? I think we're all confused as to what you're asking here. Can you please clarify what SP2 you want to install.
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 05-05-2008, 04:00 PM   #7 (permalink)
Talking BlackBerry Encyclopedia
 
sniffs's Avatar
 
Join Date: May 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 230
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

My BES box is running w2k3 server and it's on SP1.. all the exchange boxes are on win2k3 sp2 and exchange sp2.. if we upgrade the BES to win2k3 sp2, will we need to reinstall anything?
__________________
Your lack of planning is not my emergency.
Offline  
Old 05-05-2008, 04:02 PM   #8 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by sniffs View Post
if we upgrade the BES to win2k3 sp2, will we need to reinstall anything?
no.

regarding your 20 minute delay thing ... might want to look at how your Exchange server is doing.
Offline  
Old 05-05-2008, 04:07 PM   #9 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

ah, you shoudlnt' have an issue upgrading the BES box to SP2. You should actually be running your exhcange server and your BES server at the exact same Windows patch level, when you apply a patch to one, you should also be applying it to the other. the BES has been known to stop working if the patch level is not the same.
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 05-05-2008, 04:17 PM   #10 (permalink)
Talking BlackBerry Encyclopedia
 
sniffs's Avatar
 
Join Date: May 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 230
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hdawg View Post
no.

regarding your 20 minute delay thing ... might want to look at how your Exchange server is doing.

from what I've read, the exchange server sends out like a udp packet or something to the bes which sends the email and if that udp packet doesnt go through, a delay happens

the bes then at set intervals rescans the mailbox which then delivers mail if new mail found(every 20 minutes).. I think this is how I took what I read.. I may be way off..

we have 4 Virtual Exchange boxes, and outlook mail seems to be happening normally.. My WinMo device gets email instanteous..
__________________
Your lack of planning is not my emergency.
Offline  
Old 05-05-2008, 05:12 PM   #11 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by wunderbar View Post
ah, you shoudlnt' have an issue upgrading the BES box to SP2. You should actually be running your exhcange server and your BES server at the exact same Windows patch level, when you apply a patch to one, you should also be applying it to the other. the BES has been known to stop working if the patch level is not the same.
its not a hard and fast rule ... the patches that you need to be concerned with are ones that address components on the BES; specifically Exchange MAPI / CDO
Offline  
Old 05-05-2008, 05:14 PM   #12 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by sniffs View Post
from what I've read, the exchange server sends out like a udp packet or something to the bes which sends the email and if that udp packet doesnt go through, a delay happens

the bes then at set intervals rescans the mailbox which then delivers mail if new mail found(every 20 minutes).. I think this is how I took what I read.. I may be way off..

we have 4 Virtual Exchange boxes, and outlook mail seems to be happening normally.. My WinMo device gets email instanteous..
You might be way off ... but you're not (you're right on); Exchange sends out a NOTIFY to any registered clients to a given mailbox (if it has the resources to do so) ... sometimes these don't get sent as the server doesn't have the resource to do it ... and then you'll see mail delivered in bulk. Other things could cause this; but this typically is the issue.
Offline  
Old 05-05-2008, 05:24 PM   #13 (permalink)
Talking BlackBerry Encyclopedia
 
sniffs's Avatar
 
Join Date: May 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 230
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

So the most common issue is that the exchange server doesnt have the resources to send out that NOTIFY.. We have 4 virtual exchange servers so it would have to be something that is affecting all 4.. We only have about 6500 mailbox's with 550 blackberrys..

I see alot of "Warning" events on the event log, alot of MAPIinitialize warnings, a few random Errors happening every 6 hours or so on the Blackberry Router.. I did check the MAGT log and see "[3] (04/04 15:50:55):{0x182} Server = server01, Mailbox = /o=org/ou=org_unit/cn=recipient/cn=user Description = You do not have permission to log on. [Microsoft Exchange Server Information Store - [MAPI_E_FAILONEPROVIDER(8004011D)]]"

yet ALL the correct permissions (sendas/receiveas/administer information store)are propagating at the org level, yet it's still throwing that error out.. This most certainly is what is causing the calendar sync.. I dunno what to do at this point.
__________________
Your lack of planning is not my emergency.
Offline  
Old 05-05-2008, 06:33 PM   #14 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

If you're getting that error there are indeed permissions issues.

How are these virtual servers configured? 2003 SCC? How are the disk arrays configured? mailbox sizes / retention? estimate of # of items in major folders (inbox / sent / deleted) ?
Offline  
Old 05-05-2008, 06:39 PM   #15 (permalink)
BlackBerry Extraordinaire
 
gibson_hg's Avatar
 
Join Date: Dec 2007
Model: NA
PIN: 80081ES
Carrier: NA
Posts: 1,006
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

If permissions and CDO are all fine then it's usually the account that's the issue. One way Calendar is always one of the above. Have you checked the mailbox store and public folder store levels for Send As/Receive As?

Check all levels, not just the org level.

As for UDP Notifications, it can be the Exchange Server being to busy, or the network, or it could be a patch from Microsoft( Yes, there's another one). KB902400 is known to block the BES from receiving the UDP packets, but this affects all users on the BES.

If you want to remove KB902400 you will also need to disable and stop the Distributed Transaction Coordinator service after the uninstall and then reboot the BES.

Other things that cause mail delays are: Mismatched MAPI32.dll versions, blocked worker threads, busy Exchange Server, ridiculous mailbox sizes, etc...

Essentially, anything that can cause MAPI to have issues will screw up mail delivery. I would check for the KB902400 first.

Let us know what you find.
Offline  
Old 05-06-2008, 12:39 AM   #16 (permalink)
Talking BlackBerry Encyclopedia
 
sniffs's Avatar
 
Join Date: May 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 230
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Ok, so we removed that 902400 patch and email appears to be processing instanteous..which is a good thing.. now were bringing our bes and attachment server to win2k3 sp2.. we'll verify the dll files afterwards... here's to hoping!
__________________
Your lack of planning is not my emergency.

Last edited by sniffs : 05-06-2008 at 12:54 AM.
Offline  
Old 05-06-2008, 09:18 AM   #17 (permalink)
Talking BlackBerry Encyclopedia
 
sniffs's Avatar
 
Join Date: May 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 230
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Didn't seem to fix the calendars.. all signs point to a permission issue yet we verified multiple times that they are all set at every level.. are there any other permissions other than those 3 that need to be set??

I checked the MAGT logs and see that permission issue with all 4 of my Exchange virtual servers..

hdawg, not sure about the 2003 scc, or the arrays, but there is a 90 day retention policy and a 500mb ost size limit, this was RECENTLY instituted as of april 1st.

I work for the biggest sales&marketing company in America and up until recently, there were no retention/size limits.. we had endless emails. At one point, Microsoft said that my company had the biggest archive vault they've ever seen.. We had about 15-16tb's worth of stored emails.
__________________
Your lack of planning is not my emergency.

Last edited by sniffs : 05-06-2008 at 10:29 AM.
Offline  
Old 05-06-2008, 10:52 AM   #18 (permalink)
BlackBerry Extraordinaire
 
gibson_hg's Avatar
 
Join Date: Dec 2007
Model: NA
PIN: 80081ES
Carrier: NA
Posts: 1,006
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is the BESAdmin part of any admin groups? Not sure if this was mentioned earlier, I'm too lazy to read them all right now

If the BESAdmin is not an admin of any kind then the issue might be the account itself. If permissions are set and the Calendar is not working then they are not being recognized for that account.

You can create a new BESAdmin and perform a switch service account, here is RIM's KB for it:

BlackBerry Search Results

Let us know what you find.
Offline  
Old 05-06-2008, 05:22 PM   #19 (permalink)
Talking BlackBerry Encyclopedia
 
sniffs's Avatar
 
Join Date: May 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 230
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Ok.. so what we've concluded was that the BES account was added to an exchange group that was giving it "extra" priveledges.. once we removed it from that group, calendars started syncing fine!!!!!! WOOOOOT!!!!!!!!!

So PS, we removed patch 902400, and removed that group and everything is good to go!!!
__________________
Your lack of planning is not my emergency.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.