BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-06-2008, 06:50 AM   #1 (permalink)
New Member
 
Join Date: May 2008
Model: 8100
PIN: N/A
Carrier: O2 IRL
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Blackberry Professional Software and cdo.dll

Please Login to Remove!

I recently installed the latest version of Blackberry Professional Software, got my licenses and everything is working fine except the calender sync function from the devices back to the server.

The software was installed on MS Small Business Server 2003, so it is on the same server as Exchange. According to the blurb, this should not pose a problem and indeed, it went very smoothly except for the issue outlines above. I can update any item in Outlook for any user, calender, tasks, contacts, etc and it goes to the phone almost instantly. Similarly, any update entered on the phone syncs back almost as quickly, bar the calender.

I read a number of forum posts on the topic but all were to do with having BES on a separate server to Exchange, none were for Blackberry Professional Software. Still, I followed the instructions on some of them. I installed an Exchange update from MS and then copied cdo.dll from the Exchange directory to system32 and registered it. Then I restarted all Exchange and BB services and tried again to no avail. Calender items inputted in the device won't sync wirelessly to the users Outlook.

Has anyone else encountered this problem?
Offline  
Old 05-06-2008, 09:04 AM   #2 (permalink)
BlackBerry Extraordinaire
 
gibson_hg's Avatar
 
Join Date: Dec 2007
Model: NA
PIN: 80081ES
Carrier: NA
Posts: 1,006
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What account did you install the BES as? What groups is that account in? Seeing as this is the same box as Exchange it's a permissions issue. Either the account is an admin or you missed a permission along the way.

Check this article:

BlackBerry Search Results

Let us know what you find.
Offline  
Old 05-06-2008, 02:53 PM   #3 (permalink)
New Member
 
Join Date: May 2008
Model: 8100
PIN: N/A
Carrier: O2 IRL
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Right, some of that worked fine but I had a bit of trouble, either down to the peculiarities of SBS or the new blackberry professional software, I don't know.

I followed the link and quickly realised where I went wrong, I had installed the software as the domain admin, I forgot to create a blackberry admin account. I followed the instructions on how to set up a besadmin user and gave it all the necessary permissions. The instructions were flawless up until near the end but I didn't realise this until later on, when I went to restart the services and got a pile of events in the log (event ids 20659, 20641, 20642) which all related to the software interacting with SQL Server. I had to log on to the server as the besadmin user and run the BlackBerry Server Configuration wizard again to point it to the database.
I now have the services running as the besadmin user instead of the domain admin but all the users have gone home so I don't know if the calender sync problem is fixed or not!

Thanks for you help so far, I'll report back on whether the sync problem is fixed but I suspect it is.
Offline  
Old 05-06-2008, 03:06 PM   #4 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,724
Post Thanks: 272
Thanked 288 Times in 272 Posts
Default

Let me guess, you dont have a BB with a data plan to test it with.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 05-06-2008, 03:10 PM   #5 (permalink)
New Member
 
Join Date: May 2008
Model: 8100
PIN: N/A
Carrier: O2 IRL
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Heh, I do but I work for a company that provides third party IT support to lots of SMBs. My bb is tied to my own BES, not to this customer's network.
Offline  
Old 05-06-2008, 03:25 PM   #6 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,724
Post Thanks: 272
Thanked 288 Times in 272 Posts
Default

OIC

Good luck. Hope it works
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.