BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-20-2008, 07:06 AM   #1 (permalink)
New Member
 
Join Date: May 2008
Location: Antrim
Model: 8310
PIN: N/A
Carrier: 02
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Blackberry and Outlook Read Message Status out of sync

Please Login to Remove!

Hello

I have a problem with a blackberry phone which is connected to a BES Server. This particular site has several blackberry phones which are working fine, but the problem is present on only one.

When the user reads a message in outlook, it does not change the read status of the message on the blackberry and vise versa.

The odd thing is that this is only for users that are sending mail internally on the network via the exchange 2003 server. Any mail received from external email addresses works fine between outlook and the Blackberry.


I have already recreated the users profile on the laptop, deleted the old .pst and .ost files that were in the users profile. Then allowed outlook to rebuiild the offline file.

Has anyone seen this before. Many thanks for your help.

Outsource

Last edited by Outsource : 05-20-2008 at 07:14 AM.
Offline  
Old 05-20-2008, 08:48 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Model: 8310
Carrier: AT&T
Posts: 43
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is the user online with Exchange when the message is changed to "Read"?
Have you checked to be sure the user's Outlook is not in "cache" mode?

Laptops that frequently use offline stores have these issues, mainly because Exchange doesn't see the changes until it synchs up with the Outlook.

the other issue I see often (as it happens in my case, I just live with it), is that the email comes in to Exchange and is sent to my Blackberry immediately. But, Outlook has a rule that moves the email to a different folder. A folder that I don't synch with. Now these emails are copies, but have no relationship.

My best friend in that case is to move to the Date line on the blackberry, press the trackball, and select Mark Prior Opened.

Good luck...

Being a BES Administrator can be tough, I know. I've had this BES for over 2 years now, and I still learn something new every time a problem appears....

Spydertech
Offline  
Old 05-21-2008, 11:53 AM   #3 (permalink)
New Member
 
Join Date: May 2008
Location: Antrim
Model: 8310
PIN: N/A
Carrier: 02
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes it is cache mode on outlook, but it needs to be as its a laptop user. I deleted the profile and allowed outlook to recreate the offline file (2gig) office 2007.


Problem still there, although for some reason i have to goto mail options and set the mail to check every 1 minute. I'm starting to suspect that it is outlook on the laptop that may be causing the problem. Perhaps an uninstall and reinstall of office 2007 may be required.
Offline  
Old 05-21-2008, 12:24 PM   #4 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,637
Post Thanks: 264
Thanked 269 Times in 255 Posts
Default

set the mail to check every 1 minute, whoa there.

No need for that. just make sure they are connected or online.
Remove all those check for whatever minutes, those are not really for exchange accounts. Clients must be hammering exchange with that.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 05-21-2008, 06:58 PM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Model: 8310
Carrier: AT&T
Posts: 43
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

knottyrope is right!

What setup are you using in Outlook? That surely isn't a MAPI connection. If you create the account using the Microsoft Exchange choice, then you won't set a "Check every" timeout. But MAPI in cache mode does check every 2 minutes or so - it doesn't maintain a connection like the non-cache MAPI.

Also, depending on what protocol you are using - you are downloading the mail to the laptop. The Exchange server doesn't change the state of the mail on the Exchange just because you downloaded it. Also, changes you make locally won't be sent to the Exchange server until the next check - and even then it may not send read/unread status.

It sounds like Exchange and Blackberry are working properly, but the laptop is configured wrong.

Spydertech
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.