BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-13-2008, 09:26 AM   #1 (permalink)
Thumbs Must Hurt
 
MrTelephoneMan13's Avatar
 
Join Date: Jan 2008
Location: Home of the Masters
Model: 9630
PIN: N/A
Carrier: Verizon
Posts: 53
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question Upgrading from 4.1.3 to 4.1.5

Please Login to Remove!

I'm fairly new to administering the BES. Just inquiring as to how simple it may be to move from 4.1.3 to 4.1.5. Do I have to move to 4.1.4 before going 4.1.5?
Offline  
Old 06-13-2008, 09:48 AM   #2 (permalink)
BlackBerry God
 
penguin3107's Avatar
 
Join Date: Jan 2005
Model: iOS 5
Carrier: VZW
Posts: 11,701
Post Thanks: 1
Thanked 237 Times in 219 Posts
Default

You can go directly to 4.1.5 using the upgrader package.

Service packs are cumulative, so 4.1.5 contains all of the fixes that were in 4.1.4 and 4.1.4 MRs & HFs.
__________________
BCSA
BES 5.0.3 MR4 :-: Exchange 2007 SP3 RU3
http://port3101.org
Offline  
Old 06-13-2008, 09:52 AM   #3 (permalink)
Thumbs Must Hurt
 
MrTelephoneMan13's Avatar
 
Join Date: Jan 2008
Location: Home of the Masters
Model: 9630
PIN: N/A
Carrier: Verizon
Posts: 53
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Upgrader package? I was hoping it was a matter of just downloading the software from RIM, popping it into the CD-ROM and running it.
Offline  
Old 06-13-2008, 09:54 AM   #4 (permalink)
BlackBerry God
 
penguin3107's Avatar
 
Join Date: Jan 2005
Model: iOS 5
Carrier: VZW
Posts: 11,701
Post Thanks: 1
Thanked 237 Times in 219 Posts
Default

Quote:
Originally Posted by MrTelephoneMan13 View Post
I was hoping it was a matter of just downloading the software from RIM, popping it into the CD-ROM and running it.
It is that simple.
Since you already have BES 4.1.3, you just need to download Service Pack 5 for BES 4.1

You don't need to download the full version of BES 4.1.5... you just need the service pack to do the upgrade.
__________________
BCSA
BES 5.0.3 MR4 :-: Exchange 2007 SP3 RU3
http://port3101.org

Last edited by penguin3107 : 06-13-2008 at 09:55 AM.
Offline  
Old 06-13-2008, 09:58 AM   #5 (permalink)
Thumbs Must Hurt
 
MrTelephoneMan13's Avatar
 
Join Date: Jan 2008
Location: Home of the Masters
Model: 9630
PIN: N/A
Carrier: Verizon
Posts: 53
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok great. I'll be doing that. Thanks for the insight. I'll let you know how it turns out.
Offline  
Old 06-13-2008, 10:02 AM   #6 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Passp
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,756
Post Thanks: 274
Thanked 296 Times in 280 Posts
Default

Just make sure you back up your DB and server for that "just in case"

My Upgrade was flawless but I did make a backup first.
You just never know.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Passport, Z30, Z10 and Q10
Offline  
Old 06-13-2008, 10:05 AM   #7 (permalink)
BlackBerry God
 
penguin3107's Avatar
 
Join Date: Jan 2005
Model: iOS 5
Carrier: VZW
Posts: 11,701
Post Thanks: 1
Thanked 237 Times in 219 Posts
Default

^^ Excellent advice right there.
__________________
BCSA
BES 5.0.3 MR4 :-: Exchange 2007 SP3 RU3
http://port3101.org
Offline  
Old 06-14-2008, 10:53 AM   #8 (permalink)
Thumbs Must Hurt
 
MrTelephoneMan13's Avatar
 
Join Date: Jan 2008
Location: Home of the Masters
Model: 9630
PIN: N/A
Carrier: Verizon
Posts: 53
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did the backup but now when i'm running the installer pack, i get to the point where it wants to upgrade the database. When trying to do so, i receive error message stating "An attempt to upgrade the database was unsuccessful. An error occured while executing an SQL statement."
Offline  
Old 06-15-2008, 10:46 AM   #9 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2006
Model: 9000
Carrier: att
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What does your log say?

C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Logs\Installer\setup<TimeAndDateStamp>.log
Offline  
Old 06-16-2008, 10:09 AM   #10 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2005
Model: Torch
Carrier: ATT
Posts: 179
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I recommend removing all the Roles during the upgrade, just in case someone has the BB Manager Console open on their PC
Offline  
Old 06-16-2008, 02:28 PM   #11 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Oy!

1) Restore the database from your backup
2) Make sure the user object connecting to SQL has the 'sysadmin' role within the SQL Server. Having dbo on the BESMgmt database IS NOT SUFFICIENT.
3) Start upgrade again

If it fails again either post the upgrade installation log file or call T-Support ... I'd recommend the latter if BES is critical for you at all ... it'll be the best $ you spend. If you can wait for a response; well then post here.
Offline  
Old 12-06-2008, 12:06 AM   #12 (permalink)
New Member
 
Join Date: Dec 2008
Model: ver
PIN: N/A
Carrier: verizon
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

just want to add...
i'm doing an upgrade from 4.1 to 4.1.6 and got the same error. the problem was that the db log file could not growth. once set to auto growth everything worked.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.