BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-02-2008, 09:16 AM   #1 (permalink)
New Member
 
Join Date: Mar 2007
Model: 7100t
Carrier: Vodafone
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Upgrading to 4.1.4 and updating version of Exchange tools

Please Login to Remove!

Dear All,

I am faced with the following scenario, and would appreciate any advice you can offer.

We are currently running BES 4.0.7.11 on Windows Server 2000 with the Exchange 5.5 management tools, its been this way since the BES was deployed some years ago, our Exchange Server version is 2003 SP2

We have just received the latest version of the Blackberry software, and the priority is to upgrade BES

However, we also need to move the BES to a Windows 2003 server with the 2003 management tools at some point in the near future, but not for a while yet

To further complicate matters, we will over the coming month be upgrading to Exchange Server 2007

So I'm trying to formulate a plan to achieve all of the above, and my initial plan is as follows;
  • upgrade the BES server in place to 4.1.4 on the existing Windows 2000 server with the exchange Server 5.5 management tools
  • apply any new patches/service packs
  • in a few weeks, install a new Windows 2003 server with the Exchange 2003 management tools
  • move the BES services to the new 2003 server
  • upgrade to Exchange Server 2007
  • upgrade the Exchange Server tools on the BES server from 2003 to 2007

Any advice on the above would be gratefully received

Thanks
Nick

Last edited by nblowfield : 07-02-2008 at 09:18 AM.
Offline  
Old 07-02-2008, 11:01 AM   #2 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Nick -

First off, welcome to BBF!

Second, boy do you have a series of tasks / upgrades on your plate.

The thing I see first is you're using Exchange 5.5 management components with Exchange 2003 ... are you having any message / calendar sync problems? You're supposed to have the version on the BES be at or above the version on Exchange.

I guess I would go to ESM 2003 + service packs / patches on BES first and then go to BES 4.1 SP4 (or SP5 which is newest) ... I would normally go to Exchange 2007 MAPI / CDO components but I don't think they're supported on Windows 2000 Server.

When moving BES to Windows Server 2003 I would upgrade the MAPI / CDO Components to the Exchange 2007 version so that you don't need to deal with that when you start your upgrades to Exchange 2007.

Personally, I'd take this just 1 step at a time:

1) Upgrade MAPI / CDO to Exchange 2003 SP2 compatible on the BES
2) Upgrade BES to 4.1 SP4 (or SP5)
3) Migrate BES to Windows Server 2003 server
4) Migrate to Exchange 2007 (SP1 I'm assuming)

If you've got questions about each individual step post em ... but from a process perspective this is what I'd do.
Offline  
Old 07-03-2008, 04:16 AM   #3 (permalink)
New Member
 
Join Date: Mar 2007
Model: 7100t
Carrier: Vodafone
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi hdawg,

Thanks very much for the response. I was under some pressure to get the new version of BES loaded yesterday for the audio attachment support, so unfortunately have got items 1 and 2 on your list the other way around.

4.1.4 is loaded fine and seems to be functioning without issue, so the next step will be to apply SP5 which is currently downloading. In relation to the 5.5 to 2003 Exchange tools switch, I think Ixxx8217;ve found a document on Blackberry support for this, and it seems to be suggesting I simply remove 5.5 and then install 2003 management tools and then SP2.

It appears no configuration of BES is required, is that correct?

Getting these tasks out of the way will put us in a better position, Ixxx8217;ve got a 2003 server built ready to migrate to, but wexxx8217;ll deal with this in a week or two. Exchange 2007 upgrade is at our discretion, but we should be ready in a month to do this.

Upgrading to Exchange 2007 tools on Windows 2003 server with Exchange 2003 back-end sounds ideal for us if we can do this ahead of time, but will this work ok before we have Exchange 2007 server in place?

Thanks for your continued assistance
Nick
Offline  
Old 07-03-2008, 06:13 AM   #4 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Hi hdawg,

Thanks very much for the response. I was under some pressure to get the new version of BES loaded yesterday for the audio attachment support, so unfortunately have got items 1 and 2 on your list the other way around.

4.1.4 is loaded fine and seems to be functioning without issue, so the next step will be to apply SP5 which is currently downloading. In relation to the 5.5 to 2003 Exchange tools switch, I think Iíve found a document on Blackberry support for this, and it seems to be suggesting I simply remove 5.5 and then install 2003 management tools and then SP2.

It appears no configuration of BES is required, is that correct?
You'll want to launch the BlackBerry Server Configuration application on the BES and verify the MAPI profile after you make these changes; but that is it.

Quote:
Getting these tasks out of the way will put us in a better position, Iíve got a 2003 server built ready to migrate to, but weíll deal with this in a week or two. Exchange 2007 upgrade is at our discretion, but we should be ready in a month to do this.

Upgrading to Exchange 2007 tools on Windows 2003 server with Exchange 2003 back-end sounds ideal for us if we can do this ahead of time, but will this work ok before we have Exchange 2007 server in place?
Yes, you can absolutely update them prior to upgrading to Exchange 2007. Personally I'm a fan of waiting until the actual upgrade to 2007 is scheduled, but it'll work ahead of time.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.