BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-04-2008, 10:27 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2008
Model: 8800
PIN: N/A
Carrier: Vodaphone
Posts: 52
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default Cant add new users after server crash

Please Login to Remove!

Hi All,

Earlier in the week one of our offices had a power cut and the BES server hasnt worked since. The last contact time you all the BBs was around the time before the power outage.

1. Re-Started the BB router service
2. Re-Started the whole server
3. Have done the bat out, sim out, sim in, bat in, re-start phone and no joy.
4. Deleted user (yes to databases) and when I now try and re-add the same user I get the following message: "The number of users selected exceeds the number of available licences. Please select a fewer number for users to add"

We only have 3 BBs and all three licences are installed and present. All were working until the power outage.

The SRP is connected.

Any suggetions and help would be greatly appreciated!

Kind regards,
Dave.
Offline  
Old 07-04-2008, 11:06 AM   #2 (permalink)
Thumbs Must Hurt
 
Keyscan's Avatar
 
Join Date: Aug 2007
Model: 8800
PIN: N/A
Carrier: Rogers
Posts: 140
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Are you running BPS for Exchange?

It sounds like the user account is stuck in users pending delete at the moment, as the information from the database/mailbox has not been successfully cleared. I'd try re-creating the BlackBerryServer mapi profile, and then restart services. Also, when you restart services, check for errors from the BlackBerry Messaging Agent in the application log.

Also, run IEMSTEST.exe from the BES' utility directory. This utility will test to see if the BES has permissions to the user's mailbox if you are on exchange. Try to run the test against the user that is not deleting correctly, and ensure there were no errors. If there were, report back to us.

To re-create the mapi profile, reference the following:
BlackBerry Search Results

EDIT: I see your name is dominodongle, so I may have been jumping ahead of myself with my response
__________________
BES 4.1.4 - Exchange 2003
8800 and my trusty 8700r.
To change your PIN to FFFFFFFF, drop the BB in a lake.

Last edited by Keyscan : 07-04-2008 at 11:07 AM.
Offline  
Old 07-07-2008, 07:15 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2008
Model: 8800
PIN: N/A
Carrier: Vodaphone
Posts: 52
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default

Hi,
Thanks for your help. I really appreciate it. There was indeed a user stuck in the Users Pending for Deletion, so I purged them and I could then add the user back. I have wiped her handheld and re-activating. When I can the IEMSTEST.exe in the log afterwards was the following message (actually there are loads!) :

"The description of Event ID (20406) in Source (Blackberry Controller) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event 'server' agent 1: will not re-start - reached the maximum of 10 restarts per 24 hours."

The BB hasnít failed yet, but looking at that message I think it will! Your help is really appreciated. Thanks.

...I normally deal with Domino, funnily enough I never seem to have any issues with it once it is installed and configured. In this case it is Exchange on an SBS 2003 box.

Many thanks,
Offline  
Old 07-07-2008, 11:39 AM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2008
Model: 8800
PIN: N/A
Carrier: Vodaphone
Posts: 52
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default

The last activation I try failed. So as suggested I recreated the MAPI profile. Shall report back.
Offline  
Old 07-07-2008, 07:13 PM   #5 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Restart your BES (restart Windows, not just the BES services) and THEN try to activate ...
Offline  
Old 07-16-2008, 11:15 AM   #6 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2008
Model: 8800
PIN: N/A
Carrier: Vodaphone
Posts: 52
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default

ok done that...

I have taken BES off that server and put it on an entirely different one. Gone through all the installation documentation (and I have installed BES without issue on at least 10 occasions) and still I get the 20406 error.

I have done all the permissions, I can send as the user logged in at BesAdmin etc.

anyone?!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.