BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-14-2008, 01:41 PM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2005
Model: 8800
Carrier: T-Mobile UK
Posts: 50
Post Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs down BES Upgrade to latest SP - now Agents will not start

Please Login to Remove!

My colleague upgraded our BES today to the latest support pack (4.1.5)

Essentially now our BES isn't working, the last contact time for our handhelds is shown as 1.30 this afternoon (roughly the time of the update).

I've been googling and delving around on the net all evening in an attempt to fix it, and I've come up with the following.

Basically, I think the problem is related to the MAPI profile. The two agents in our BES environment won't start, each gives a 5302 error.

I've looked on the server, and going into control panel>mail shows two profiles... cleck-sql and blackberrymanager

Looking at the MAGT logs, I see the following ;

[30055] (07/14 19:15:13.514):{0x1AE0} Using MAPI profile BlackBerryServer
[30035] (07/14 19:15:13.546):{0x1AE0} MailboxManager::SubsystemInitialize - AdminServices (0x80040111)
[40206] (07/14 19:15:13.546):{0x1AE0} MailboxManager::SubsystemInitialize - Using MAPI profile 'BlackBerryServer'
[20134] (07/14 19:15:13.561):{0x1AE0} MailboxManager::SubsystemInitialize - MAPILogonEx (0x80040111)
[10277] (07/14 19:15:13.561):{0x1AE0} BlackBerry Messaging Agent CLECK-SQL Agent 1 failed to start. Error code 5302
[50106] (07/14 19:15:13.561):{0x1AE0} Stopping BlackBerry Mailbox Agent 1 for Server CLECK-SQL
[50000] (07/14 19:15:13.577):{0x1A24} Controller: This BES Agent is under control of BlackBerry Agent Controller

...this tells me that the BES is looking for a MAPI profile called BlackBerryServer, which isnt listed in the Mail applet in Control Panel.

Does this sound right, and if so any ideas how we can fix it?
Offline  
Old 07-14-2008, 02:38 PM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2008
Location: Oconomowoc, Wi
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 54
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had that same issue the other day the mapi profiles had to be the same on each server to work right then mine popped up and started working once i did that. Configure it in the bb config manger. In our case we use the besadmin's mapi profile for the servers. We had 2 bes admin accounts now eliminated it to one. We had 2 because one was in a child domain and it was the first bes setup i had nothing to do with that one.

Last edited by cavy : 07-14-2008 at 02:59 PM.
Offline  
Old 07-14-2008, 03:47 PM   #3 (permalink)
BlackBerry Extraordinaire
 
gibson_hg's Avatar
 
Join Date: Dec 2007
Model: NA
PIN: 80081ES
Carrier: NA
Posts: 1,006
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Give this a read:

BlackBerry Search Results

Essentially, there are 2 reg keys. 1 key points to a MAPI profile and the other key is the mapi profile. So, either the key pointing to the profile is missing or the mapi key is named wrong/doesn't exist.

Follow the KB, it should get ya working again.

Feel free to ask any questions.
Offline  
Old 07-15-2008, 02:48 AM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2005
Model: 8800
Carrier: T-Mobile UK
Posts: 50
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by gibson_hg View Post
Give this a read:

BlackBerry Search Results

Essentially, there are 2 reg keys. 1 key points to a MAPI profile and the other key is the mapi profile. So, either the key pointing to the profile is missing or the mapi key is named wrong/doesn't exist.

Follow the KB, it should get ya working again.

Feel free to ask any questions.
...thanks for the info, I'd already found that article and tried using it. Eventually I found the registry keys under HKEY_USER that pointed to the old MAPI profile, did a bit of tinkering and the 5302 errors went away, but now I get all new errors about missed heartbeats. We'll give it an hour this morning to take a look again but it looks like it will be a re-install after that..
Offline  
Old 07-15-2008, 07:34 AM   #5 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Reboot the server.
Offline  
Old 07-15-2008, 03:48 PM   #6 (permalink)
CrackBerry Addict
 
ashworth's Avatar
 
Join Date: Jun 2006
Location: Ontario, Canada
Model: 9000
OS: 4.6
Carrier: Rogers
Posts: 625
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

If the reboot does not work then I would stop all of the BES services.
Backup the MAPI profile via registry.
delete the mapi profile.
re-create the mapi profile within the server configuration utility.
Restart the services starting with: Router, Disp, Controller then the rest in any order.
__________________
Cheers,
Ash


My BlackBerry GPS Golf Application | Mileage Calculator
Offline  
Old 07-15-2008, 04:03 PM   #7 (permalink)
Thumbs Must Hurt
 
scorpius's Avatar
 
Join Date: Oct 2007
Location: Amsterdam
Model: 9000
OS: 4.6.0.228
PIN: The Donkey
Carrier: Vodafone
Posts: 94
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I find it strange that your mapi profile has gone. Which user account are you using? The Besadmin or the Administrator?

For the rest i agree with ashworth! Recreating the mapi profile should solve it.
__________________
Thumbs are the most important organs man has. Not those "others" like one might think.
Offline  
Old 07-28-2008, 08:59 AM   #8 (permalink)
New Member
 
Join Date: Jul 2008
Location: Desborough, Northants, UK
Model: Curve
PIN: N/A
Carrier: O2
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Reset service log on accounts

I have just had this same problem when upgrading to v4.1.6.

The problem was caused in my case because during the upgrade the account used to log on the Backberry services had been changed from BESAdmin to Administrator.

In Control Panel - Services, change "Log On As" to BESAdmin for all Blackberry services except Blackberry Attachment Service (remains as Administrator account).
Restart all Blackberry services.

Devices should start registering again and email delivery will resume.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.