BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-14-2008, 07:23 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: Aliant
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default My database is gone

Please Login to Remove!

I'm using BES express and it is installed on the same machine as the backup software.

One of the admin guys was fixing some backup problems and re-installed the backup software. During the install he got an error with the database so he removed it and installed a newer version, desktop sql 2005 I believe. Unfortunately that was the database BES was using.

What do I do now? How do I go about getting BES to use the new database?

Thanks
Offline  
Old 08-14-2008, 07:26 AM   #2 (permalink)
BlackBerry God
 
penguin3107's Avatar
 
Join Date: Jan 2005
Model: iOS 5
Carrier: VZW
Posts: 11,701
Post Thanks: 1
Thanked 237 Times in 219 Posts
Default

Please tell me you have a backup of your database that you can restore.
If not, then please tell me you only have a few handhelds and it won't be a big deal to wipe and reactivate them all.

If your database is truly gone, then you're basically going to need to start over from scratch.
__________________
BCSA
BES 5.0.3 MR4 :-: Exchange 2007 SP3 RU3
http://port3101.org
Offline  
Old 08-14-2008, 07:30 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: Aliant
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Unfortunately the database wasn't being backed up. It will be now obviously. but its only 10 devices so not too big a deal on that end.

Do I need to uninstall and re-install or can I install over top? Or is there a way I can connect the BES to the new database and then add the users again?

I appreciate the help
Offline  
Old 08-14-2008, 08:34 AM   #4 (permalink)
Talking BlackBerry Encyclopedia
 
RadHaz75's Avatar
 
Join Date: Feb 2006
Location: Philadelphia
Model: 9650
OS: 6.0.0.524
PIN: BALL
Carrier: Verizon Wireless
Posts: 456
Post Thanks: 2
Thanked 4 Times in 4 Posts
Default

haha holy cow if this happened to me i'd be screwed. i have 10k users.
__________________
Two months ago, I saw a provocative movie on cable TV. It was called The Net, with that girl from the bus.
Offline  
Old 08-14-2008, 08:36 AM   #5 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

Quote:
Originally Posted by JD_AJNS View Post
Unfortunately the database wasn't being backed up. It will be now obviously. but its only 10 devices so not too big a deal on that end.

Do I need to uninstall and re-install or can I install over top? Or is there a way I can connect the BES to the new database and then add the users again?

I appreciate the help
It might be big deal if you don't have licence keys,SRP info etc...It's all stored in DB.
Offline  
Old 08-14-2008, 09:12 AM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
DavidAdams's Avatar
 
Join Date: Sep 2007
Location: Belfast
Model: NotYe
PIN: N/A
Carrier: O2
Posts: 470
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by fadmin View Post
It might be big deal if you don't have licence keys,SRP info etc...It's all stored in DB.
That's why I print any licensing details to PDF and then save somewhere twice.
__________________
BES, 4.1.7, was SBE now full BES
Domino v7.0.2
Windows Server 2003, standalone
Offline  
Old 08-14-2008, 09:26 AM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: Aliant
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by fadmin View Post
It might be big deal if you don't have licence keys,SRP info etc...It's all stored in DB.
That info I have. What I don't have is information on how to resolve this.

Do I have to uninstall and re-install or can I run the install over top of what I have and just provide license info?

Or can I use the database tool to "move" the database and create a new one?

If anybody can help with that I would appreciate it.
Offline  
Old 08-14-2008, 09:54 AM   #8 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,697
Post Thanks: 270
Thanked 286 Times in 270 Posts
Default

Hope fully the data base file is still there.
Look in here
C:\Program Files\Microsoft SQL Server\MSSQL\Data

If its there then you may be able to restore it to the new SQL server.

Then read up on MSDE to SQL
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 08-14-2008, 09:54 AM   #9 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: Aliant
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

And a more specific question.

If I'm reinstalling is there a separate download for Express or is it the license key that makes it "express"?

And I have installed the 4.1.5 upgrade so would I use the original 4.1 download or could I just run the 4.1.5 install again?
Offline  
Old 08-14-2008, 09:54 AM   #10 (permalink)
BlackBerry Extraordinaire
 
gibson_hg's Avatar
 
Join Date: Dec 2007
Model: NA
PIN: 80081ES
Carrier: NA
Posts: 1,006
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What you can do is use the BlackBerry Server Configuration utility to create a new DB on the SQL 2005 Express installation.

There is a change DB Wizard built in to it. Just follow the steps and ask any questions if need be.

There is no need to reinstall the BES or anything also.
Offline  
Old 08-14-2008, 10:15 AM   #11 (permalink)
Talking BlackBerry Encyclopedia
 
DavidAdams's Avatar
 
Join Date: Sep 2007
Location: Belfast
Model: NotYe
PIN: N/A
Carrier: O2
Posts: 470
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by JD_AJNS View Post
And a more specific question.

If I'm reinstalling is there a separate download for Express or is it the license key that makes it "express"?

And I have installed the 4.1.5 upgrade so would I use the original 4.1 download or could I just run the 4.1.5 install again?
If I remember correctly it is the license key that makes a full enterprise install into an Express/Small Business version limited to 15 users.
__________________
BES, 4.1.7, was SBE now full BES
Domino v7.0.2
Windows Server 2003, standalone
Offline  
Old 08-14-2008, 11:07 AM   #12 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: Aliant
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by gibson_hg View Post
What you can do is use the BlackBerry Server Configuration utility to create a new DB on the SQL 2005 Express installation.

There is a change DB Wizard built in to it. Just follow the steps and ask any questions if need be.

There is no need to reinstall the BES or anything also.
Thanks for the info. I followed that advice and it seems to be fine except it is not validating my SRP ID and Key. I'm getting:

"Invalid SRP Key or ID
Warning error occurred while receiving server ID from Wireless network"

I've double checked it like a dozen times and it matches my key.

Not sure what to do from here.
Offline  
Old 08-14-2008, 11:18 AM   #13 (permalink)
BlackBerry Extraordinaire
 
gibson_hg's Avatar
 
Join Date: Dec 2007
Model: NA
PIN: 80081ES
Carrier: NA
Posts: 1,006
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can you browse the internet from that machine? Are there any network issues going on right now?

Are you entering the SRP ID with an 's' or an 'S'?
Offline  
Old 08-14-2008, 11:24 AM   #14 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: Aliant
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by gibson_hg View Post
Can you browse the internet from that machine? Are there any network issues going on right now?

Are you entering the SRP ID with an 's' or an 'S'?
Thanks for this! Your question about the "s" reminded me that when we first got this the supplier messed up the numbers and gave us invalid SRP info. I dug a bit deeper into my file and found the proper SRP info.

So far everything is good,I'm going to activate a couple as tests and then do the rest.
Offline  
Old 08-14-2008, 11:31 AM   #15 (permalink)
BlackBerry Extraordinaire
 
gibson_hg's Avatar
 
Join Date: Dec 2007
Model: NA
PIN: 80081ES
Carrier: NA
Posts: 1,006
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Check your PM's
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.