BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-19-2008, 11:00 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2008
Model: 8100
PIN: N/A
Carrier: Nextel
Posts: 35
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Two BES Servers, Same Database, In SYNC.

Please Login to Remove!

Ok, I was winging a knife-edge cutover for my first time. Overall I'm still a n00b when it comes to BES so please stick with me.

Both BES servers have the local MS SQL database and are on Exchange 2003. I exported the database on server "BESTEST" and copied the .bak file to our new ESX virtual environment with a hostname of "BLACKBERRY". Both servers have the exact same version of BES installed. I stopped all the services for "BLACKBERRY" manually and disconnected BES from the database. I imported the .bak file from the command line and rebooted the server. At this point this is how everything looks:

BESTEST is started and BLACKBERRY is stopped within Blackberry Manager.

I actually had BLACKBERRY halted weeks before this event, so it has never been on.

On the BLACKBERRY server inside BB Manager, it now states the Host Name is BESTEST instead of BLACKBERRY

When I clicked on "Stop Blackberry Server" on BESTEST and clicked on "Start Blackberry Server" on BLACKBERRY, both servers started. So I clicked "Stop Blackberry Server" and both servers stopped. This can be performed in any combination on any server, stop stops both and start starts both. So I freaked out, started the server on BESTEST and manually stopped all the services on BLACKBERRY.

At this point it has caused no problems, all messages are forwarding properly.

Can anyone explain what happened?
__________________
BES 4.1.4.2 / Exchange 2003 SP2 / Sprint / 22 users on 7100's & 8830's
Offline  
Old 09-22-2008, 09:40 AM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2008
Model: 8100
PIN: N/A
Carrier: Nextel
Posts: 35
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Well...

Has no one ever encountered this?
__________________
BES 4.1.4.2 / Exchange 2003 SP2 / Sprint / 22 users on 7100's & 8830's
Offline  
Old 09-24-2008, 11:30 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2008
Model: 8100
PIN: N/A
Carrier: Nextel
Posts: 35
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I guess I'm just insane and imagined the problem. Am I really going loopy here?
__________________
BES 4.1.4.2 / Exchange 2003 SP2 / Sprint / 22 users on 7100's & 8830's
Offline  
Old 10-01-2008, 04:36 PM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2008
Model: 8100
PIN: N/A
Carrier: Nextel
Posts: 35
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Solved.

I am totally loopy. It was a DNS replication issue, two different host names were pointing to the same IP address.
__________________
BES 4.1.4.2 / Exchange 2003 SP2 / Sprint / 22 users on 7100's & 8830's
Offline  
Old 10-01-2008, 04:43 PM   #5 (permalink)
BlackBerry Extraordinaire
 
holden's Avatar
 
Join Date: May 2007
Location: Florida Sunshine
Model: 9700
OS: 5.0.0.296
PIN: TOFJAGER
Carrier: Cingular-AT&T-Verizon-Nextel
Posts: 1,046
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Glad you found a solution. We don't have this kind of setup... So I did not have anything of value to contribute... After your DNS adjustment are you going to test again?

H.
__________________
hmeister...
nettech
Offline  
Old 10-02-2008, 10:33 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2008
Model: 8100
PIN: N/A
Carrier: Nextel
Posts: 35
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by holden View Post
After your DNS adjustment are you going to test again?

I tried the knife edge cutover. For some reason when I imported the database on the new server it caused problems. I turned off all the services on the old server and started all the services on the new server (just as the KB instructs), but none of the users were present. RIM apparently locked our SRP out because according to them, "the new server was not authorized". We are fighting with them right now because they don't have any of our IT department on the account.
__________________
BES 4.1.4.2 / Exchange 2003 SP2 / Sprint / 22 users on 7100's & 8830's
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.