BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-25-2008, 11:56 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2008
Model: Bold
PIN: N/A
Carrier: Vodafone
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 4.1.6 upgrade failed - fresh install?

Please Login to Remove!

Hi,
I'm reasonably new to administering a BES server. I recently tried to upgrade our BES to 4.1.6 (Exchange) from 4.1.4.

After the upgrade, all the BlackBerries stopped communicating with the server. All the services seemed to be running fine, I rebooted the box a few times to make sure afterwards too. Event Viewer was full of errors, which I couldn't find any information on, so I ended up rolling back.

So now I've decided to build a new server and start from scratch, and migrate across (which the doco says can be done).

I'm stuck at the first stage though, as the doco doesn't seem to be the best (refers to SP 5 a lot even though it's for SP6) and just says to run setup.exe on the new server. The SP6 files say it's only an upgrade and needs BlackBerry already installed.

Do I need to get the original 4.1.0 install, run that, then install 4.1.6 over the top?

Or now that MR1 is out, should I attempt an upgrade again, then run MR1 to see if that fixes the original issue I had?

Thanks
Offline  
Old 09-26-2008, 12:00 AM   #2 (permalink)
x14
BlackBerry Extraordinaire
 
Join Date: Jul 2005
Location: NYC
Model: 9800
OS: 6.0.0.546
Carrier: AT&T
Posts: 2,344
Post Thanks: 0
Thanked 17 Times in 16 Posts
Default

Quote:
Originally Posted by GiantGuineaPig View Post
Do I need to get the original 4.1.0 install, run that, then install 4.1.6 over the top?
You can get a 4.1.6 full install from RIM. If not you will have to install 4.1.0 then apply SP6.
__________________
Exchange 2007/BES 5.0.2 MR2
Offline  
Old 09-26-2008, 12:03 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2008
Model: Bold
PIN: N/A
Carrier: Vodafone
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by x14 View Post
You can get a 4.1.6 full install from RIM. If not you will have to install 4.1.0 then apply SP6.
Do you have to contact them for this? I can't find it on their download pages anywhere
Offline  
Old 09-26-2008, 12:21 AM   #4 (permalink)
Thumbs Must Hurt
 
trancemaasta's Avatar
 
Join Date: Nov 2005
Location: NSW, Australia
Model: 8700
Carrier: Optus Australia
Posts: 65
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by GiantGuineaPig View Post
Do you have to contact them for this? I can't find it on their download pages anywhere
4.1.0 (full install) will be either from Tsupport or your WirelessProvider. Not available to the general public.

I would be going service pack 2 then 4 then 6, rather than jumping straight to 6 from a progression perspective and error minimisation.
Offline  
Old 09-26-2008, 12:35 AM   #5 (permalink)
BlackBerry God
 
jibi's Avatar
 
Join Date: Oct 2004
Location: Jibi's Secret Place
Model: 8900
OS: 4.6.1.174
Carrier: AT&T
Posts: 11,310
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

WHAAA?! You need to have a valid support contract either with your carrier or RIM and then you will likely be able to request the full installation of 4.1 SP6. If you do not have a support contract, it may still be worth contacting them to see if they can provide. If all else fails, you can install whatever full version you have (if that's 4.1.0, then that is fine - you would have a full installation somewhere, most likely). You can jump straight from 4.1.0 to 4.1.6, as service pack upgrades are cumulative. You do not have to jump from one version to another - in fact, I'd highly recommend NOT doing something like that.
__________________
In the beginning the Universe was created. This has made a lot of people very angry and is widely regarded as a bad move.
Offline  
Old 09-26-2008, 12:43 AM   #6 (permalink)
Thumbs Must Hurt
 
trancemaasta's Avatar
 
Join Date: Nov 2005
Location: NSW, Australia
Model: 8700
Carrier: Optus Australia
Posts: 65
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jibi View Post
WHAAA?! You need to have a valid support contract either with your carrier or RIM and then you will likely be able to request the full installation of 4.1 SP6. If you do not have a support contract, it may still be worth contacting them to see if they can provide. If all else fails, you can install whatever full version you have (if that's 4.1.0, then that is fine - you would have a full installation somewhere, most likely). You can jump straight from 4.1.0 to 4.1.6, as service pack upgrades are cumulative. You do not have to jump from one version to another - in fact, I'd highly recommend NOT doing something like that.
The jury's out on that one Jibi. So all of a sudden it's ok to jump straight to SP6? When in 4.0 you had install sp2 before going to 7, not to mention upgrading to SP4 before a 4.1 upgrade. It's commonpractice to follow the upgrade path, I would still not be going straight to SP6 in a mission critical production environment.
Offline  
Old 09-30-2008, 11:23 AM   #7 (permalink)
Thumbs Must Hurt
 
Join Date: May 2007
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 117
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

are you sure you did the install/upgrade with the BESadmin account?
Offline  
Old 09-30-2008, 11:38 AM   #8 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Passp
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,788
Post Thanks: 279
Thanked 297 Times in 281 Posts
Talking

Just download the trial which is 4.1.6 and add your srp key to it.
I got it to install remote manager.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Passport, Z30, Z10 and Q10

Last edited by knottyrope : 09-30-2008 at 11:38 AM. Reason: farted
Offline  
Old 10-01-2008, 09:50 PM   #9 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2008
Model: Bold
PIN: N/A
Carrier: Vodafone
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by wren View Post
are you sure you did the install/upgrade with the BESadmin account?
yep definitely did, thanks for checking.

Quote:
Originally Posted by knottyrope View Post
Just download the trial which is 4.1.6 and add your srp key to it.
I got it to install remote manager.
Finally found that out from RIM yesterday - download just says 4.1 but is actually 4.1.6

So I'm half way through the install now.

I've got the SQL database on a SQL server, but the doco says to use a seperate database. Is that what you've done? Or just specified the existing one?
Offline  
Old 03-10-2009, 07:38 AM   #10 (permalink)
SEP
Thumbs Must Hurt
 
Join Date: Nov 2007
Model: 9000
Carrier: -
Posts: 152
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does it download or is it sent to you? It sent off an online order form but no download
Offline  
Old 03-10-2009, 07:46 AM   #11 (permalink)
Feeling Blue, Bigly ;->
 
stuwhite's Avatar
 
Join Date: Jan 2007
Location: U to the K
Model: 9000
PIN: 3, it's the magic number
Carrier: Most of them, it's a Global Village man!
Posts: 1,273
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by SEP View Post
Does it download or is it sent to you? It sent off an online order form but no download
The trial you mean? IIRC once you through the form you get sent a standard RIM fullfillment email (like when you buys CALs etc) and that links to the store page where you can dl the file.
__________________
I was a BES and Exchange admin once.
Then my world turned Blue.
Offline  
Old 03-11-2009, 04:15 PM   #12 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Passp
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,788
Post Thanks: 279
Thanked 297 Times in 281 Posts
Default

Once in a while SPAM filters will stomp on it.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Passport, Z30, Z10 and Q10
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.