BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   Failed to Create Folder - Exchange 2k7 (http://www.blackberryforums.com/bes-admin-corner/173852-failed-create-folder-exchange-2k7.html)

MoGeN 02-02-2009 04:19 PM

Failed to Create Folder - Exchange 2k7
 
I'm running SBS 2008 w/ Exchange SP1 and on a Hyper-V I have a Server 2k3 R2 w/ SP2 running BPS 4.1.4.

This is the error message I am getting:

Quote:

C:\Blackberry\BPS 4.1.4\tools>iemstest
BlackBerry Enterprise Server Utility - IEMSTest.exe (IExchangeManageStore), Version 1.0
Copyright (c) Research In Motion, Ltd. 1999. All rights reserved.
Opening Default Message Store Mailbox - BESAdmin.
Opening message store for Jon A. Hinden using /o=First Organization/ou=Exchange
Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=JHinden /o=First Organiz
ation/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Ser
vers/cn=SBSFS1/cn=Microsoft Private MDB.
Jon A. Hinden's Mailbox opened successfully.
Root Folder opened successfully.
Failed to create a folder in Jon A. Hinden's mailbox.
.


I have folowed all the commands listed in the http://www.blackberryforums.com/bes-admin-corner/75890-exchange-2007-bes-install-guide-100-fully-functional.html but I continue to get this error.

Any help would be appreciated. Thanks.

*** EDIT ***

When I run IEMSTest on the BESAdmin I still get "Failed to create Folder". I, once again, ran through the instructions on the Exchange 2007 Server install instructions and still I get the same error.

Has anyone gotten BPS or BES to work with SBS 2008 yet?

knottyrope 02-02-2009 04:39 PM

Recheck your permissions again.

MoGeN 02-02-2009 04:47 PM

Quote:

Originally Posted by knottyrope (Post 1268722)
Recheck your permissions again.

There are only two commands to in the Exchange Management Shell and when I run each command the second time I get the error message that the permissions already exist.

My only question is this: When they are run it asks for the Identity? I have put in BESAdmin along with the user and after the second time it shows that the permissions are already there. Send and Recieve As are already on the user in AD Users and Computers.

What else could it be? I've never had this issue with Windows 2k3 SBS.

desmondch 03-16-2009 10:50 AM

HELP! Did you ever resolve this?
 
I have *exactly* the same problem

(weird on the shell commands that it keeps requesting the username eh?)
Also, I find I have to drop the "get-mailboxserver" part or the command fails

PLLEEEEEASE Let me know if you fixed this!

knottyrope 03-16-2009 10:58 AM

Look here

View Document

desmondch 03-16-2009 11:00 AM

thanks!

Believe me, I've done them many times over. Actually, you have to modify the shell commands somewhat for SBS 2008, but using the get-adpermissions you can check that everything set correctly.


Identity User Deny Inherited Rights
-------- ---- ---- --------- ------
goodbusiness.loca... GOODBUSINESS\BESA... False False Self, WritePropert...
goodbusiness.loca... GOODBUSINESS\BESA... False False ms-Exch-Store-Admin
goodbusiness.loca... GOODBUSINESS\BESA... False False Receive-As
goodbusiness.loca... GOODBUSINESS\BESA... False False Send-As

That looks correct doesnt it?

desmondch 03-16-2009 11:04 AM

BPS ver
 
By the way, I'm using BPS 4.1.4.15

Is there a way to patch that to 4.1.6? Or do I have to download 4.1.6? Can I even do that?

Thanks for switf response :)


All times are GMT -5. The time now is 11:27 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.