BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-02-2009, 04:19 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2006
Location: South Florida
Model: 9700
OS: 6.0.0.418
Carrier: AT&T
Posts: 34
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Failed to Create Folder - Exchange 2k7

Please Login to Remove!

I'm running SBS 2008 w/ Exchange SP1 and on a Hyper-V I have a Server 2k3 R2 w/ SP2 running BPS 4.1.4.

This is the error message I am getting:

Quote:
C:\Blackberry\BPS 4.1.4\tools>iemstest
BlackBerry Enterprise Server Utility - IEMSTest.exe (IExchangeManageStore), Version 1.0
Copyright (c) Research In Motion, Ltd. 1999. All rights reserved.
Opening Default Message Store Mailbox - BESAdmin.
Opening message store for Jon A. Hinden using /o=First Organization/ou=Exchange
Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=JHinden /o=First Organiz
ation/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Ser
vers/cn=SBSFS1/cn=Microsoft Private MDB.
Jon A. Hinden's Mailbox opened successfully.
Root Folder opened successfully.
Failed to create a folder in Jon A. Hinden's mailbox.
.


I have folowed all the commands listed in the http://www.blackberryforums.com/bes-admin-corner/75890-exchange-2007-bes-install-guide-100-fully-functional.html but I continue to get this error.

Any help would be appreciated. Thanks.

*** EDIT ***

When I run IEMSTest on the BESAdmin I still get "Failed to create Folder". I, once again, ran through the instructions on the Exchange 2007 Server install instructions and still I get the same error.

Has anyone gotten BPS or BES to work with SBS 2008 yet?
__________________
Jebus Jones™

16 BES/BESX/BPSX Servers on Windows 2k3 (SBS)/2k8 (SBS)
40+ Users

Last edited by MoGeN : 02-02-2009 at 04:39 PM. Reason: Add more info
Offline  
Old 02-02-2009, 04:39 PM   #2 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Passp
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,817
Post Thanks: 287
Thanked 305 Times in 287 Posts
Default

Recheck your permissions again.
__________________
unlock you phone here http://cellunlocker.net/blackberry-unlock.php
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Passport, Z30, Z10 and Q10
Offline  
Old 02-02-2009, 04:47 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2006
Location: South Florida
Model: 9700
OS: 6.0.0.418
Carrier: AT&T
Posts: 34
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by knottyrope View Post
Recheck your permissions again.
There are only two commands to in the Exchange Management Shell and when I run each command the second time I get the error message that the permissions already exist.

My only question is this: When they are run it asks for the Identity? I have put in BESAdmin along with the user and after the second time it shows that the permissions are already there. Send and Recieve As are already on the user in AD Users and Computers.

What else could it be? I've never had this issue with Windows 2k3 SBS.
__________________
Jebus Jones™

16 BES/BESX/BPSX Servers on Windows 2k3 (SBS)/2k8 (SBS)
40+ Users
Offline  
Old 03-16-2009, 10:50 AM   #4 (permalink)
New Member
 
Join Date: Sep 2008
Model: 8310
PIN: N/A
Carrier: O2
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default HELP! Did you ever resolve this?

I have *exactly* the same problem

(weird on the shell commands that it keeps requesting the username eh?)
Also, I find I have to drop the "get-mailboxserver" part or the command fails

PLLEEEEEASE Let me know if you fixed this!
Offline  
Old 03-16-2009, 10:58 AM   #5 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Passp
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,817
Post Thanks: 287
Thanked 305 Times in 287 Posts
Default

Look here

View Document
__________________
unlock you phone here http://cellunlocker.net/blackberry-unlock.php
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Passport, Z30, Z10 and Q10
Offline  
Old 03-16-2009, 11:00 AM   #6 (permalink)
New Member
 
Join Date: Sep 2008
Model: 8310
PIN: N/A
Carrier: O2
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks!

Believe me, I've done them many times over. Actually, you have to modify the shell commands somewhat for SBS 2008, but using the get-adpermissions you can check that everything set correctly.


Identity User Deny Inherited Rights
-------- ---- ---- --------- ------
goodbusiness.loca... GOODBUSINESS\BESA... False False Self, WritePropert...
goodbusiness.loca... GOODBUSINESS\BESA... False False ms-Exch-Store-Admin
goodbusiness.loca... GOODBUSINESS\BESA... False False Receive-As
goodbusiness.loca... GOODBUSINESS\BESA... False False Send-As

That looks correct doesnt it?
Offline  
Old 03-16-2009, 11:04 AM   #7 (permalink)
New Member
 
Join Date: Sep 2008
Model: 8310
PIN: N/A
Carrier: O2
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BPS ver

By the way, I'm using BPS 4.1.4.15

Is there a way to patch that to 4.1.6? Or do I have to download 4.1.6? Can I even do that?

Thanks for switf response
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.