BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-06-2009, 08:40 AM   #1 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8703
PIN: N/A
Carrier: Alltel and At&t
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Upgrade BEs 3.6 to 4.1 on new Hardware

Please Login to Remove!

Good morning,

This is my first time posting here so I am sure I will leave out some information that is needed but here go's.

I want to take our BES environment to 4.1. We currently have a 3.6 server in production. I have a new 4.1 server that I want to add to the 3.6 environment. I have found the Database Connectivity area in the 4.1 server. I have read that I will need to redirect my 4.1 server to the DB the 3.6 server is using. My main question is when I do that what can I expect to happen? Also, are there things I need to do before that happens to prepare the 3.6 DB?

FYI - I have the 4.1 server up and working with a few test users. That information can be wiped so its not a DB merge it's just an upgrade. I want to do this to make the migration of users easier since they would be listed in the same Blackberry domain.

Thanks in advance.
Offline  
Old 02-06-2009, 09:03 AM   #2 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,691
Post Thanks: 270
Thanked 284 Times in 269 Posts
Default

The database are not compatable.

you have to upgrade the 3.6 server to 4.0.7 first and then upgrade it to 4.1.

Are you using remote SQL or MSDE?
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 02-06-2009, 09:14 AM   #3 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8703
PIN: N/A
Carrier: Alltel and At&t
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

SQL.

So should I just take the old 3.6 to 4.1 then add the new server to the envrionment afterwards? Or is there something special about 4.0.7?
Offline  
Old 02-06-2009, 09:33 AM   #4 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,691
Post Thanks: 270
Thanked 284 Times in 269 Posts
Default

I have heard people have better luck doing it that way.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 02-06-2009, 09:47 AM   #5 (permalink)
BlackBerry Extraordinaire
 
Frank Castle's Avatar
 
Join Date: Jul 2005
Location: MA
Model: 9930
PIN: PM Me!
Carrier: VZW
Posts: 1,073
Post Thanks: 0
Thanked 4 Times in 3 Posts
Default

I lived through this and after weighing the options I just removed the user and then added and issued a EAP via email.

The hardest part at the time was I first had a # of devices (as in hundreds) that didn't have OS 4.0+. If most of your devices are newer I would do what I outlined having the user wipe their device and then activate against the new server.
Offline  
Old 02-06-2009, 09:59 AM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
dodgydane's Avatar
 
Join Date: Aug 2005
Location: London
Model: 9800
OS: 6.0.0.246
Carrier: Vodafone
Posts: 362
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

I've done this before and I did the following:
Made sure 3.6 had the latest service pack
Upgraded to 4.1
(must admit I can't remember if I brought it up to 4.0 first)
Then installed 4.1 on new box.....connected to the same SQL database
Then in BB manager just moved the user.
I was surprised at how beautiful it worked moving users between the BES

Just make sure that if you have 2 live BES you need 2 different SRP ID's....can't use the same.....!!!!
Offline  
Old 02-06-2009, 10:10 AM   #7 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8703
PIN: N/A
Carrier: Alltel and At&t
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, I caught that I needed two SRPs and was able to get what I needed.

How difficult was the 3.6 to 4.1 inplace upgrade? What kind of gotchas came up?
Offline  
Old 02-06-2009, 10:14 AM   #8 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,691
Post Thanks: 270
Thanked 284 Times in 269 Posts
Default

SQL reboot will happen IIRC.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 02-06-2009, 10:15 AM   #9 (permalink)
Talking BlackBerry Encyclopedia
 
dodgydane's Avatar
 
Join Date: Aug 2005
Location: London
Model: 9800
OS: 6.0.0.246
Carrier: Vodafone
Posts: 362
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Yeah I saw afterwards that you said that you had already installed the 4.1
I seem to not be reading the posts properly today...oops....

I had no problems with the upgrade...luckily.....
But I know people who have upgraded with the administrator account instead of the BESadmin account and then it stopped working.
Or they have upgraded to a new version without bringing the old version up to the latest service pack....and that messed it up...
Offline  
Old 02-06-2009, 12:13 PM   #10 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8703
PIN: N/A
Carrier: Alltel and At&t
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does anyone know what the lowest BB OS version is that will work with BES 4.1.6? I've not been able to find a document that states that.

I think we may have a couple older devices. If I do an inplace upgrade of the current server I would hate to knock them offline.
Offline  
Old 02-06-2009, 12:30 PM   #11 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,691
Post Thanks: 270
Thanked 284 Times in 269 Posts
Default

Almost any will, but some functionality will be lost.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 02-06-2009, 12:42 PM   #12 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8703
PIN: N/A
Carrier: Alltel and At&t
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

We can deal with that. Just as long as email keeps rolling we'll be good.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.