BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   SMSDOM ERROR: Unable to load nnem.dll! (http://www.blackberryforums.com/bes-admin-corner/176659-smsdom-error-unable-load-nnem-dll.html)

noname 02-17-2009 12:37 AM

SMSDOM ERROR: Unable to load nnem.dll!
 
Hi all,

Firstly my apologies for parking the post here. No choice, urgently need some guidance on Symantec Mail Security for Domino (SMSDOM). Symantec Support sucks big time, kept putting me on hold and listen to music; sent email also no quick response.

My BES Domino is a mail server too and it has installed SMSDOM. After a server restart, the SMSDOM task ntask failed to load. Tried unloading the router and restart it, no result:-

{
16/02/2009 11:00:13 AM > l nntask
16/02/2009 11:00:14 AM 22:3D: nnem.dll
...
16/02/2009 11:00:16 AM SMSDOM ERROR: Unable to load nnem.dll!
16/02/2009 11:00:16 AM SMSDOM: Service shutdown completed.
...
16/02/2009 01:19:02 PM > tell router q
16/02/2009 01:19:03 PM Router: Shutdown is in progress
16/02/2009 01:19:05 PM Mail Router shutdown
...
16/02/2009 01:19:22 PM > l ntask
16/02/2009 01:19:23 PM 22:3D: nnem.dll
...
16/02/2009 01:19:25 PM SMSDOM ERROR: Unable to load nnem.dll!
16/02/2009 01:19:25 PM SMSDOM: Service shutdown completed.
}

Can someone advise me here?

Thanks!

m4ilm4n 02-17-2009 06:03 AM

Look in c:\lotus\domino for nnem.dll and make sure it's there. Mine's dated 2/4/2008 and is 133K. If not you may be looking at an SMSDOM reinstall.

noname 02-17-2009 11:09 AM

Thanks for responding m4ilm4n. I'm looking at minimum disruption to the users i.e. no server restart. The DLL file is there in the \lotus\domino folder. I'm looking at trying to regsvr it or replacing it from another server that works. Is there a sequence of loading the ntask and Domino's nrouter? Which one should be loaded first?

m4ilm4n 02-18-2009 06:02 AM

If I read my INI right, router first, then ntask. Are you running npas as well (premium anti-spam)?
Code:

ServerTasks=Replica,Router,Update,AMgr,Adminp,Sched,CalConn,RnRMgr,ntask,npas,HTTP,LDAP
And don't get me started on Symantec's "support" - I constantly get Domino crashes whenever npas loads new definition sets (roughly once a week) and they don't even recognize it as an issue.

noname 02-18-2009 09:44 AM

Thanks again, m4ilm4n. A regsvr32.exe nnem.dll does not help. However, I can only bounce the box in next maintenance. On the support, I'm just wordless.

m4ilm4n 02-18-2009 01:59 PM

From the look of it, a reinstall may be the best bet.

noname 02-19-2009 03:17 AM

Yeah, looks like it.


All times are GMT -5. The time now is 05:56 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.