BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-17-2009, 11:04 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2008
Model: 9000
PIN: N/A
Carrier: Telstra
Posts: 20
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES has suddenly stopped working - please help!

Please Login to Remove!

Hi

Our BES (Blackberry Professional Software) just stopped working this morning, ie no devices can contact the server. We have Exchange 2003 Enterprise.

These are the errors we are getting in the Application Event Log:

Event Type: Error
Event Source: BlackBerry Messaging Agent BES01 Agent 1
Event Category: None
Event ID: 10275
Date: 18/02/2009
Time: 1:42:39 PM
User: N/A
Computer: BES01
Description:
Failed to retrieve the Server DN, shutting down


...followed by...


Event Type: Error
Event Source: BlackBerry Messaging Agent BES01 Agent 1
Event Category: None
Event ID: 10277
Date: 18/02/2009
Time: 1:42:39 PM
User: N/A
Computer: BES01
Description:
BlackBerry Messaging Agent BES01 Agent 1 failed to start. Error code 5305



I have reinstalled Exchange 2003 Enterprise System Manager plus ESM SP2 and rebooted - still no luck.

Stopping and starting the services manually after the server has been restarted gives the same errors.

I think the issue is this - when I click on on Edit Mapi Profile, I get the following error:

"Invalid properties in MsgSvcTable (00000000)"

I came across a Blackberry article (can't post it though as I don't have 10 posts).

Under KEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\BlackBerryServer, I don't have a MAPI Profile value to export or delete.

Please help!!

Last edited by Stix : 02-17-2009 at 11:07 PM.
Offline  
Old 02-18-2009, 02:59 AM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2008
Model: 9000
PIN: N/A
Carrier: Telstra
Posts: 20
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Never mind - solved!

Our service account (BESAdmin) must have been corrupt.

Can't post links but to solve it, search for error 5305 on Blackberry support...use the cause 4 resolution to create a new service account (I named the new account BESAdmin2)

That almost fixed it...got an error 5302. Searching Blackberry support again found the fix.

Thanks
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.