BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   Moved information store (http://www.blackberryforums.com/bes-admin-corner/178129-moved-information-store.html)

dketterer1 02-24-2009 09:43 PM

Moved information store
 
Hi everyone. We just moved our information store to a different drive for size reasons. Now for some reason when we try to start the MDS service it says that the system could not find the environment option that was specified. I've looked through some of the forums and could not find anything that fits. The ImagePath at HKLM\System\CurrentControlSet\Services\Blackberry MDS Connection Service is ""D:\Program Files\Research In Motion\BlackBerry Enterprise Server\MDS\bin\bmds.exe" -s jvmpath="C:\Program Files\Java\jre1.5.0_11\bin\client\jvm.dll" -XX:+DisableExplicitGC -Xss64K -Xmx768M -Xms128M classpathdir="D:\Program Files\Research In Motion\BlackBerry Enterprise Server\MDS\classpath\\" wrkdir="D:\Program Files\Research In Motion\BlackBerry Enterprise Server\MDS\Servers\OURSERVERNAME\\" webserverdir="D:\Program Files\Research In Motion\BlackBerry Enterprise Server\MDS\webserver\\" -rbes "OURSERVERNAME_MDS-CS_1" "

Any assistance would be appreciated

stuwhite 02-25-2009 04:48 AM

I am not 100% but this sounds like you are running the wrong version of the JRE as I got something similar once when I was on 4.0 and our security guys updated the JRE :cry:. If you are on 4.0, uninstall the JRE you have, get back to the correct version (1.4.2 I think) and IIRC you need to do a reg hack to fix the keys but that error is definitly on this forum somewhere as this is where I found the fix.

If you are 4.1 it could still apply but with 4.1 you need to to be on the JRE which ships with the last SP/MR you are using.

stuwhite 02-25-2009 04:55 AM

Did a quick search for you and although this isn't the actual answer, it does show how to set your reg keys back to match the correct installation of JRE if you wiped out 1.4.2 on a 4.0 BES and need to reinstall 1.4.2.

http://www.blackberryforums.com/bes-...7-greater.html

dketterer1 02-25-2009 08:34 AM

Reinstalled JRE and it's working. Thanks.


All times are GMT -5. The time now is 07:15 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.