BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-26-2009, 10:16 AM   #1 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8130
PIN: N/A
Carrier: Verizon
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Desktop Email Program Unable to Submit Message

Please Login to Remove!

Here is the situation:

I am using a Blackberry 8130 through Verizon Wireless with the BlackBerry® Nationwide Email for Business SharePlan 1350.

I have installed Blackberry Professional Software Express on a Windows 2003 Server that is seperate from our Exchange 2003 Server. I have completed the setup and finally got the 8130 to finish the Enterprise Activation over the air.

Everything seems to download and initialize properly. The server is forwarding the received emails correctly and I can view them on the 8130.

The issue is when I go to send a message from the 8130 I receive the error "Desktop Email Program Unable to Submit Message." When I look at the Application Event Viewer I have the two errors below:

Code:
2/26/2009	
10:52:53 AM	
BlackBerry Messaging Agent AQUILA Agent 1	
Warning	
None	
20472	
N/A	
AQUILA	
{User@domain.com} Send() failed: ERR_SUBMIT_MAIL, Tag=122

2/26/2009	
10:52:51 AM	
BlackBerry Messaging Agent AQUILA Agent 1	
Warning	
None	
20265	
N/A	
AQUILA	
{User@domain.com} MAPIMailbox::Send(ppMAPIMessage) - SubmitMessage (0x80070005) failed
It seems like a permission issue but after reading the forums I have triple checked the permissions. I used the Account BESAdmin to install and run the BPSE software and I have given it Send As rights to my account. I was listed as a Domain Admin and have since removed myself from that group. I then shutdown the BPSE Server for 3 hours to let the cache refresh on the Exchange box. I then did a master reset on the 8130, sent a new activation code to myself and redid the Enterprise Activation on the 8130. Still to no avail.

Can anyone provide me (a n00b BES Admin) some guidance on what I need to check and where else I need to look for problems that could fix this issue?

Thanks.
Offline  
Old 02-26-2009, 10:33 AM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
DavidAdams's Avatar
 
Join Date: Sep 2007
Location: Belfast
Model: NotYe
PIN: N/A
Carrier: O2
Posts: 470
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default

Are you in any of the other special protected groups? Not sure which as we are a Domino shop.
__________________
BES, 4.1.7, was SBE now full BES
Domino v7.0.2
Windows Server 2003, standalone
Offline  
Old 02-26-2009, 10:41 AM   #3 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8130
PIN: N/A
Carrier: Verizon
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I ran GPRESULT to get the list below. I am not sure if any of the other groups are part of the Protected ones. I found that Domain Admins was so I removed it and waited the 3 hours but still nothing.

Code:
    The user is a part of the following security groups
    ---------------------------------------------------
        Domain Users
        Everyone
        Debugger Users
        BUILTIN\Users
        BUILTIN\Administrators
        NT AUTHORITY\INTERACTIVE
        NT AUTHORITY\Authenticated Users
        This Organization
        LOCAL
        All COMPANY1 Associates
        SW_CF_Execs_IT
        IT
        IT Staff
        Columbus
        Corporate Associates
        New Hire Group
        MobilityXE
        All COMPANY2 Associates
        All CORP Associates
        PasswordPropDeny
        High Mandatory Level
Offline  
Old 02-26-2009, 11:12 AM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2006
Model: 8330
Carrier: Verizon
Posts: 142
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The other thing that causes this is you need to allow inheritable permissions for the user. That's what I always need to fix - for some reason when any rights are changed on a mailbox, that inheritable permissions check gets removed.
__________________
8330 4.5.0.77 OS - PIN: 303297df
BES Admin:
5x4.1.6 Exchange - 700 Users
"Sink or Swim" Educated
Offline  
Old 02-26-2009, 11:27 AM   #5 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8130
PIN: N/A
Carrier: Verizon
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

How do I allow it to be inherited? I see the read permission is inherited from the top of the domain all the way down but not the Send As permission.

I did check my user account though through the Advanced Security Settings and it does show that I did Allow the BESAdmin the right to Send As. It just wasn't inherited.
Offline  
Old 02-26-2009, 09:31 PM   #6 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2008
Location: Indonesia
Model: 9700
PIN: N/A
Carrier: Indosat
Posts: 189
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

check too on active directory of user BES, make sure that user join BESAdmin.
__________________
------------------------------------
http://2blackberry.blogspot.com
Offline  
Old 02-27-2009, 05:43 PM   #7 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8130
PIN: N/A
Carrier: Verizon
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, so I have made some head way with this issue. It seems the BESAdmin account that I setup on the top level of the domain was not being inherited down. I finally figured out how to set this and now it is being inherited by every other user in the domain except the domain admins. For some reason I am part of the Domain Admins. Every hour my account gets the Inherit check removed from it. I have moved myself out of the OU I am was in to another OU. I let an hour go by and again my sending email stopped as the system removed my Inheritance checkmark.

Can anyone look at my list of groups and see if one of the other groups is a protected group?

When I look at the security tab it shows:
Type: Allow
Name: Domain Admins
Permission: Special
Inherited: <not inherited>
Apply To: This Object Only

Any help???
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.