BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   BES and SQL on SBS 2003 (http://www.blackberryforums.com/bes-admin-corner/178826-bes-sql-sbs-2003-a.html)

Just Guessing 02-28-2009 09:13 PM

BES and SQL on SBS 2003
 
I've installed a couple of BES's on Windows Small Business Server 2003 and have had the same issue. When the BES install gets to the database phase, it assumes you're going to use the SQL Express install that Small Business Server uses for server reports. It won't offer to install SQL Express at all -which is what I think needs to happen. So I download SQL Express from Microsoft and install it, point the installation at it, and then proceed with the BES install. Is this standard procedure when installing on SBS 2003, or is there something I'm missing? Is there an easier way to do this? Thanks!

knottyrope 02-28-2009 10:05 PM

might help

View Document

Just Guessing 03-01-2009 10:29 PM

KB 11232 seems to describe what I'm already doing - install a new instance of SQL Express and point BES at it. This seems to be a common situation with SBS 2003. Unlike Backup Exec software, The BES installer isn't clever enough to recognize you already have SQL Express installed and want to make a new named instance for it. If Backup Exec does this, I'm sure it can be done. Considering most of my clients only have ten phones or less and no apps, it seems a waste to install SQL a second time just for BES.

fadmin 03-02-2009 08:48 AM

http://www.blackberryforums.com/bes-...using-sql.html

knottyrope 03-02-2009 09:32 AM

Thats too funny.

fadmin 03-02-2009 10:53 AM

what?

Just Guessing 03-02-2009 12:13 PM

Interestingly enough, SQL Express 2005 is in the Tools folder of the installation folder. I used this rather than download from Microsoft on my last install. Use the default settings and it works.

knottyrope 03-02-2009 12:25 PM

Quote:

Originally Posted by fadmin (Post 1305035)
what?

the thread you linked, OP was the same user that started this thread.
At first look I almost thought you linked this thread, since it was so similar.

Hannah814 04-05-2009 03:07 PM

I have had a simlar issue where I have had to download express sql 2005 but once it has all gone through and the database is installed if you ad a new user on and then delete them off it just constantly says pending delete? Any ideas?

Just Guessing 04-05-2009 07:38 PM

It's hard to tell when BES isn't communicating with the database. You can look in the computer's Application log for Blackbery errors, but I have had to uninstall SQL 2005 Express and reinstall to get things to work. If you only have one license, BES doesn't like it when you delete and add a single user. I would do a complete restart of the server computer just to be on the safe side. Sometimes shutting down and restarting all the Blackberry services and the SQL database by hand works. Turn on SQL first, then all the Blackberry services - no particular order if you're using the latest version of BES. Sometimes only voodoo can get BES to work.

knottyrope 04-06-2009 10:31 AM

try this Just Guessing
View Document

Just Guessing 04-06-2009 12:41 PM

Thanks, Knotty -

I need to check the SQL logs.


All times are GMT -5. The time now is 06:30 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.