BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-02-2009, 03:50 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Mar 2007
Model: 7100T
Carrier: verizon
Posts: 39
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy adminSDHolder account to resolve e-mail sending problem

Please Login to Remove!

I installed Blackberry Pro on a Windows 2003 Small Business Server. Everything works, but I am unable to send e-mail from the phones. The error on the phone is that the desktop could not send the mail. This is the error I get on the server:

{joe@xxxx.com} MAPIMailbox::Send(ppMAPIMessage) - SubmitMessage (0x80070005) failed

I spent quite a bit of time with Blackberry support. They checked the usual stuff and determined the problem is that the first two users belonged to the administrators group. Even though they were removed, Active directory still "remembers" they're admins. I've never heard of this and I have not been able to corroborate this on the Internet.

They directed me to a 15 page Microsoft KB Article 912918. This recommends creating an adminSDHolder account to resolve the issue. I've been fussing with this for some time and have not been able to resolve the problem. I'm afraid BB support has sent me on a wild goose chase.

Can anyone out there tell me if they've heard of this adminSDHolder account?

Thanks!
Offline  
Old 03-02-2009, 06:03 PM   #2 (permalink)
rsk
Thumbs Must Hurt
 
Join Date: Jan 2007
Model: 9630
Carrier: Sprint
Posts: 134
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

in the article you list it states:
Quote:
Originally Posted by http://support.microsoft.com/kb/912918
Special rules for adminSDHolder Protected Accounts
[snip]
If you change the rights or the permissions on the adminSDHolder object for a protected account, a background task will undo the change within several minutes. For example, if you grant the Send As permission on a domain administrator object for an application service account, the background task will automatically revoke the permission.
does this happen to the account you are trying to send from ? if so then it probably is still being treated like a domain administrator. if not then you probably just need to make sure the correct send-as permissions apply to those mailboxes.

Last edited by rsk : 03-02-2009 at 06:04 PM.
Offline  
Old 03-03-2009, 07:56 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Mar 2007
Model: 7100T
Carrier: verizon
Posts: 39
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

You hit the nail on the head. I removed the users from the administrators group. How can I tell if they're still being treated like admins? They can't log in at the server anymore, so I'm assuming revoking their admin rights worked. BB support checked my rights after I went over them several times. Is there any other way to verify rights are configured and functioning properly?
Offline  
Old 03-03-2009, 05:41 PM   #4 (permalink)
rsk
Thumbs Must Hurt
 
Join Date: Jan 2007
Model: 9630
Carrier: Sprint
Posts: 134
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

just check that the send-as permission is not removed I guess..

can you now send from the handheld ?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.