BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-19-2009, 06:02 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Model: 9700
Carrier: Rogers
Posts: 39
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default OCS 2007 R2 and MR4

Please Login to Remove!

We have OCS 2007 R2 running with BES 4.1.6 MR3 and I find that the bcol.exe service uses a lot of virtual memory (1.2GB) and restarting it fixed the problem, at least for now.

I wanted to know if anyone had the same issue and does MR4 fix it?

*SDR 181128: In BlackBerry Enterprise Server version 4.1 SP4 or later, in certain circumstances, when using the BlackBerry® Client for use with Microsoft® Live Office Communications Server 2005, the BlackBerry Collaboration Service might log out sessions unexpectedly.

This symtom is what we were seeing when the virtual memory was maxed out at 1.2GB. This isn't for OCS R2 but I imagine it's related?

I'm not worried about upgrading to MR4, just want to see if people have seen this before.

Thanks.
Offline  
Old 03-26-2009, 12:04 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Model: 9700
Carrier: Rogers
Posts: 39
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I upgraded to 4.1.6 MR4 last night and it went well, no surprise there.

This morning, I checked the bcol.exe service and it's only using 200MB of virtual memory. It is less than 24 hours after the upgrade so I'll check again this time next week and report if it's still baloons and drops connections.

Cheers.
Offline  
Old 03-27-2009, 11:05 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Model: 9700
Carrier: Rogers
Posts: 39
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, over 24 hours has passed and I can say that MR4 does in fact fix memory issues with OCS 2007 and the bcol.exe service. The virtual memory for this service has never gone past 200 MB (give or a take 4-8 MB) and our users are no longer getting disconnected.

Offline  
Old 03-27-2009, 11:46 AM   #4 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,679
Post Thanks: 270
Thanked 281 Times in 266 Posts
Default

Congrats on your fix.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 05-09-2009, 10:15 AM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Model: 9700
Carrier: Rogers
Posts: 39
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem returned

The patch didn't last very long. At least not long enough.

The bcol.exe service is still hitting 100% CPU. I must restart to correct the issue but it will come back.

Hopefully RIM releases a new version / update to resolve this.

EDIT: MR6 came out so I'll see if that helps by patching the BES next week.

Last edited by Oderus : 05-09-2009 at 10:32 AM. Reason: update to mention MR6
Offline  
Old 05-14-2009, 08:38 AM   #6 (permalink)
Thumbs Must Hurt
 
blueshockeynut's Avatar
 
Join Date: Jan 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 53
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Oderus View Post
We have OCS 2007 R2 running with BES 4.1.6 MR3 and I find that the bcol.exe service uses a lot of virtual memory (1.2GB) and restarting it fixed the problem, at least for now.

I wanted to know if anyone had the same issue and does MR4 fix it?

*SDR 181128: In BlackBerry Enterprise Server version 4.1 SP4 or later, in certain circumstances, when using the BlackBerry® Client for use with Microsoft® Live Office Communications Server 2005, the BlackBerry Collaboration Service might log out sessions unexpectedly.

This symtom is what we were seeing when the virtual memory was maxed out at 1.2GB. This isn't for OCS R2 but I imagine it's related?

I'm not worried about upgrading to MR4, just want to see if people have seen this before.

Thanks.
Just a quick question for ya, how did you get OCS 2007 R2 running with the BES, as it doesnt work and isnt supported, am curious if you meant R1 instead of R2, since R2 requires an R1 CWA box to work with BES.

Thanks.

JB
__________________
Never Quit.
Never do the expected.
Never rest on your laurels.
Never think great is good enough.
NEVER FOLLOW.
Offline  
Old 06-19-2009, 06:04 AM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2007
Model: 9800
PIN: N/A
Carrier: T-Mobile Germany
Posts: 34
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Yeah I'm curious too how you got ocs2007 r2 working.
I'm going to upgrade to 5.0 next month and I hope it will work out of the box.
__________________
BES 5 SP3 for Exchange 2010 SP1 Rollup3v3
Offline  
Old 06-22-2009, 03:30 PM   #8 (permalink)
New Member
 
Join Date: Oct 2008
Model: 8820
PIN: N/A
Carrier: AT&T
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by seppi View Post
Yeah I'm curious too how you got ocs2007 r2 working.
I'm going to upgrade to 5.0 next month and I hope it will work out of the box.
it does not. Still need WSC 2007 R1 running for it to work
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.