BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-26-2009, 03:31 PM   #1 (permalink)
New Member
 
Join Date: Mar 2009
Model: 7100T
PIN: N/A
Carrier: Verizon
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Angry BES Agent keeps shutting down. Probable MAPI problem

Please Login to Remove!

I have inherited some problems, it seems.

BES server that has been running well had recently had its Exchange Mailbox stores restored, and since then I get the following error in the Agent log:
Code:
[30055] (03/26 15:58:16.882):{0x1AC8} Using MAPI profile BlackBerryServer
[40000] (03/26 15:58:16.882):{0x1AC8} Setting PR_PROFILE_CONNECT_FLAGS CONNECT_IGNORE_NO_PF false
[40206] (03/26 15:58:16.882):{0x1AC8} MailboxManager::SubsystemInitialize - Using MAPI profile 'BlackBerryServer'
[50000] (03/26 15:58:16.913):{0x1D44} Controller: This BES Agent is under control of BlackBerry Agent Controller
[20137] (03/26 15:58:16.976):{0x1AC8} MailboxManager::SubsystemInitialize - g_pSession->OpenMsgStore (0x80070005)
[40000] (03/26 15:58:16.976):{0x1AC8} Setting PR_PROFILE_CONNECT_FLAGS CONNECT_IGNORE_NO_PF true
[40206] (03/26 15:58:16.976):{0x1AC8} MailboxManager::SubsystemInitialize - Using MAPI profile 'BlackBerryServer'
[20137] (03/26 15:58:17.007):{0x1AC8} MailboxManager::SubsystemInitialize - g_pSession->OpenMsgStore (0x80040111)
[10277] (03/26 15:58:17.007):{0x1AC8} BlackBerry Messaging Agent <SERVERNAME> Agent 1 failed to start. Error code 5305
[50106] (03/26 15:58:17.007):{0x1AC8} Stopping BlackBerry Mailbox Agent 1 for Server <SERVERNAME>
While reading through forums, I found a hint to try the IEMSTest.exe to check for MAPI errors. Sure enough, when I run it, and Select the "BlackBerryServer" profile (which is listed in the error above), I get an error stating:

OpenMsgStore() for this profile failed (80070005)

However, I noticed that there were two other profiles in the list, "BlackBerryManager" and "BlackBerry Server Management". Both of those seem to run fine! After choosing a mailbox, i get:

Code:
<snip>
Opening Default Message Store Mailbox - BESAdmin.
...
...
Test completed successfully for <user>
</snip>
So, my first impression is that if I could set my BES user, BESAdmin to use one of those other profiles as its default, my Agent might start up again and start allowing me to send and receive mails on the my Blackberries.

Anyone have any idea how to do that?
Thanks for your input....

Last edited by meat1oaf : 03-26-2009 at 03:36 PM.
Offline  
Old 03-27-2009, 12:22 AM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2007
Model: 9700
PIN: N/A
Carrier: 122
Posts: 25
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Login to your BES server as the BESAdmin user and start the BlackBerry Server Configuration.

There will be a BlackBerry Server tab where you can select the MAPI Profile
Offline  
Old 03-27-2009, 09:23 AM   #3 (permalink)
New Member
 
Join Date: Mar 2009
Model: 7100T
PIN: N/A
Carrier: Verizon
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.