BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-08-2005, 09:17 PM   #1 (permalink)
CrackBerry Addict
 
qc_metal's Avatar
 
Join Date: Mar 2005
Location: Rockford, IL
Model: 9530
OS: 4.7.x
Carrier: Verizon
Posts: 590
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES 3.6.6 to 4.0 upgrade - what can I expect?

Please Login to Remove!

I am going to perform a 3.6.6 update to 4.0 (we are on Exchange 5.5 - - - still, but that's another story).

Our server is Windows 2000, we are running it on the builtin MSDE instance.

I have updated to SP6 (we were at SP2) and updated MDAC to 2.8. The last thing I need to do is update MSDE to 2000a.

Our clients are a mixture of 7280/7290's, and most of the 80's are BB OS 3.6.x. The 7290's are all 4.0.

What can my users expect once the update is complete? I understand that they should start to receive a flurry of new contacts (if they aren't synchronized as of late), tasks, etc. - what has been the typical result of a 3.6 update to 4.0 from the user standpoint?

Rob

Last edited by qc_metal : 11-09-2005 at 03:40 PM.
Offline  
Old 11-08-2005, 09:20 PM   #2 (permalink)
dev
CrackBerry Addict
 
dev's Avatar
 
Join Date: Apr 2005
Location: Toronto
Model: 8800
Carrier: Rogers
Posts: 571
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default

What to expect....
•Unavailability of BES related services (mail redirection, PIM data synchronization) during migration and device initialization process
•Expected delay of 2hrs-3hrs before complete resumption of services. Some devices may complete the initialization process quicker than others, and may be able to send/receive mail. Time may be much less..all depends on the number of users.
•Some devices may experience prolonged initialization activity due to limited device resources, user mailbox size or quantity of PIM data to be synchronized
Appearance of the enterprise activation icon during the initialization process...goes away when process is completed.
There should be no problems with the devices you mentioned. The 7290s together with the 4.0 BES server will now be able to participate in wireless activations or enterprise activations. Which means no need for the DTM to synchronize.
Offline  
Old 11-08-2005, 09:43 PM   #3 (permalink)
New Member
 
Join Date: Nov 2005
Model: 7250
Carrier: Verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did a similar upgrade except running Exchange 2000, it's pretty straight forward. Make sure you have a backup of user list & srp #, just in case.

Also don't forget to upgrade software on Blackberry's to 4.0, if not already done.
Offline  
Old 11-09-2005, 12:40 PM   #4 (permalink)
Thumbs Must Hurt
 
jrbes's Avatar
 
Join Date: Jun 2005
Location: Here
Model: 8700
Carrier: Cingular
Posts: 161
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Have you seen the movie "Chicken Little"....
Offline  
Old 11-09-2005, 03:51 PM   #5 (permalink)
CrackBerry Addict
 
qc_metal's Avatar
 
Join Date: Mar 2005
Location: Rockford, IL
Model: 9530
OS: 4.7.x
Carrier: Verizon
Posts: 590
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is within the realm of what I was expecting. So I might be safe (relatively speaking) by telling our users that they should expect a 5 hour downtime in order to fully perform the update...?

As for our 7280's, they should be able to operate as they have been, correct (by using the DTM to synchronize). I don't suppose there is an easy way to tell from the BES server who has the 4.0 OS, eh? That might be stretching my luck, right?

Thanks for the responses,
Rob
Offline  
Old 11-09-2005, 04:54 PM   #6 (permalink)
New Member
 
Join Date: Jul 2005
Location: Charlotte
Model: 8800
Carrier: Cingular
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

How many devices do you have on your server? I recently upgraded 9 Exchange 5.5 Win 2000 BES 3.6 servers to 4.0.1. The server users ranged from 9 users to 1,000. The 1,000 user system took approximately 36 hours to complete the enterprise activation process. The HW was a single CPU server with on GB of RAM.
Offline  
Old 11-09-2005, 06:50 PM   #7 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: May 2005
Model: 7100
Carrier: T-Mobile
Posts: 299
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by qc_metal

As for our 7280's, they should be able to operate as they have been, correct (by using the DTM to synchronize). I don't suppose there is an easy way to tell from the BES server who has the 4.0 OS, eh? That might be stretching my luck, right?

Thanks for the responses,
Rob
There sure is. The BlackBerry Handheld Manager.
Offline  
Old 11-10-2005, 04:43 PM   #8 (permalink)
CrackBerry Addict
 
qc_metal's Avatar
 
Join Date: Mar 2005
Location: Rockford, IL
Model: 9530
OS: 4.7.x
Carrier: Verizon
Posts: 590
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by bbarnes
How many devices do you have on your server? I recently upgraded 9 Exchange 5.5 Win 2000 BES 3.6 servers to 4.0.1. The server users ranged from 9 users to 1,000. The 1,000 user system took approximately 36 hours to complete the enterprise activation process. The HW was a single CPU server with on GB of RAM.
yikes - 36 hours? Holy cripes...!

We have 290 users on a single server, but not all of them (probably around 1/4 of them) are 4.0 OS users.

Rob
Offline  
Old 11-13-2005, 07:29 PM   #9 (permalink)
New Member
 
Join Date: Jul 2005
Location: Charlotte
Model: 8800
Carrier: Cingular
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Approx 60% of our users had 4.0 devices at the time of the upgrade. We were at the minimum hardware requirements, which I am in the process of upgrading now. I would plan on a 4 hour outage to make sure that you are covered for the full upgrade and activation completion.
Offline  
Old 11-21-2005, 09:03 AM   #10 (permalink)
CrackBerry Addict
 
qc_metal's Avatar
 
Join Date: Mar 2005
Location: Rockford, IL
Model: 9530
OS: 4.7.x
Carrier: Verizon
Posts: 590
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK - I have completed the upgrade over the weekend. BB's appear to be working fine, but now the 4.0 devices have the Enterprise Activation icon showing up. My thought was this icon would disappear after the device had fully synchronized over the air (or through the Desktop Manager), but this does not seem to be the case.

We are using the same SRP identifier and authentication code - - it was an in-place upgrade - - I guess I wasn't expecting to see this icon after the upgrade.

Will this icon eventually go away, or is it something the users will have to live with now?

Thank you!
Rob
Offline  
Old 11-21-2005, 02:04 PM   #11 (permalink)
CrackBerry Addict
 
qc_metal's Avatar
 
Join Date: Mar 2005
Location: Rockford, IL
Model: 9530
OS: 4.7.x
Carrier: Verizon
Posts: 590
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Got it - after a call to RIM, it turns out the Blackberry Synchronization Service had crashed (or did not start).

Once it was restarted, my Enterprise Activation appears to be working on my 4.0 devices.

Funny thing was we were still receiving emails on our 4.0 devices even though the EA process did not complete.
Offline  
Old 11-21-2005, 05:21 PM   #12 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: May 2005
Model: 7100
Carrier: T-Mobile
Posts: 299
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The e-mail activation part completes fairly early in the overall process.
Offline  
Old 11-29-2005, 11:11 AM   #13 (permalink)
CrackBerry Addict
 
qc_metal's Avatar
 
Join Date: Mar 2005
Location: Rockford, IL
Model: 9530
OS: 4.7.x
Carrier: Verizon
Posts: 590
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

We did have some residual problems with some devices that day, and some activations were not occuring, while I myself had some serious issues getting my device after I had removed and re-added myself to the server.

I installed SP3 that night, and it appears that any outstanding issues with synchronization, EA, etc. went away. After the update installed, anyone with an EA issue saw their activation process kick off without a hitch.

Thanks for the feedback!

Rob
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.