BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-06-2009, 08:20 AM   #1 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,376
Post Thanks: 11
Thanked 72 Times in 69 Posts
Default BES 4.1.x on w2k, upgrade in place to 2003 Server ?

Please Login to Remove!

I plan to upgrade to BES 5.0
5.0 requires at least 2003 Server,

My plan:
First make an in place upgrade to 2003 Server then an in place upgrade of the BES to 5.0
The Server does not host exchange, only BES + AD is running on it connected to a MSDE database.

I know, most people might recommend a clean install, but I only have a few users, and, my life does not depend on the system - if its offline for 2 days, this is not a problem.

So:
I make an image of the current 2000 Server to be able to go back,
upgrade Active Directory to 2003 R2 requirements,
eventually dcpromo the 2000 server down to a member server,
deactivate all BES services,
perform the in place upgrade to 2003

I have experience with this procedure, however, I do not have experience what happens to the BES server installation.
If someone has done this, and knows if the BES ist still functional after the update to 2k3, i would like to know about.

Thanks.
Offline  
Old 06-06-2009, 09:24 AM   #2 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: PRIV
OS: 5.1.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 7,156
Post Thanks: 355
Thanked 365 Times in 340 Posts
Default

My idea for a few users.

backup the Database
Wipe the server after dcpromo
Do a clean install of 2003
move database back
install BES 5.0
__________________
unlock your phone here http://freemyblackberry.com/
I am on http://supportforums.blackberry.com
BES 12 running sweet for my DTEK60
Online  
Old 06-07-2009, 04:36 PM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,376
Post Thanks: 11
Thanked 72 Times in 69 Posts
Default

I tried the direct upgrade.
The first step completed without problems. The BES 4.1.x was still alive and happy after the upgrade - I even skipped demoting down the Server.
The next step however brought problems. I thought after reading the upgrade Manual, it might be better to update MSDE 2000sp3 to sp4. However, after the update to MSDE sp4, Windows refused to start - It stayed in an endless loop displaying the windows logo with the (indetermined) progress bar.
I coiuld start in safe mode, but this update is impossible to revert. I had to go back to the last backup.

Interesting next questions: will BES 5.0 run with my EXchange 2000 ? The Manual tells, that you need 2003.
Offline  
Old 06-08-2009, 08:53 PM   #4 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It should run with Exchange 2000 ... I wouldn't do it unless I absolutely had to.
Offline  
Old 06-08-2009, 09:24 PM   #5 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,376
Post Thanks: 11
Thanked 72 Times in 69 Posts
Default

Indeed, it does - I havent seen a problem until now, most things work well.

One thing that does not:
"Calendar Attachment support". Well, I can see an attachment which I put in using outlook. But I cannot add an attachment using the BB - looks like a limitation of the device Software. I beg this will be possible, because this is the main reason I bought the thing.
Offline  
Old 06-11-2009, 02:40 AM   #6 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,376
Post Thanks: 11
Thanked 72 Times in 69 Posts
Default

Finally everything works smooth.
If I had used a Server 2003 compatible hardware in the first place, upgrade would have been easy.

But, as I now read here:
http://na.blackberry.com/eng/support...er_april09.pdf

It should not be neccessary to upgrade to windows 2003 for a BES 5.0 installation. Had I known this before, I had installed 5.0 in windows 2000 Server, no need to upgrade to 2003 !

My information about the upgrade to 5.0 and the system requirements are from here:
http://na.blackberry.com/eng/deliver...rade_Guide.pdf

There is NOT A SINGLE WORD about Windows 2000 Server (with the exeption of the Clients for Web Desktop Manager). Everything here tells me: Minimum requirements 2003 Server, Exchange 2003
I double checked this by searching the pdf for the word "2000".

Documentation about a product should be consistent across different documents. You cannot expect I read all availible papers before deciding what to do.

Last edited by nobody7290 : 06-11-2009 at 02:41 AM.
Offline  
Old 06-11-2009, 05:57 AM   #7 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

... it'd be nice if the documentation was consistent ... keep its fun though, right? :p
Offline  
Old 06-11-2009, 06:02 AM   #8 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,376
Post Thanks: 11
Thanked 72 Times in 69 Posts
Default

Right. Also, it keeps you up to date with current IT technology problems (the result of this is, I now have 2 of my servers now running under a vmware virtual machine - something, which I wanted to do anyway, but I had no real need to do it).
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.