BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-10-2009, 10:25 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: May 2009
Model: 8700g
PIN: N/A
Carrier: T-Mobile
Posts: 86
Post Thanks: 7
Thanked 1 Time in 1 Post
Default Restarting DCs / GCs while keeping the BES happy

Please Login to Remove!

Good morning, everyone!

BES 4.1.6 MR5 for Exchange (2007 SP1) here.

One of the problems we've been fighting here with our BES is that every month when we patch and reboot our domain controllers, we inevitably see problems with our BES. Even with LDAPSearch (but not LDAPDomain) enabled, it appears to love to bind to one DC / GC and freak out when it goes down.

Our current solution is to patch the BES with the DCs, but that's not the cleanest method to guarantee uptime.

I read this post (Edit: I only have one post, can't link it) and see that I'm not the first, but I was wondering if anyone had come upon any better suggestions to make sure that it can always find a DC/GC.

Thanks!
Offline  
Old 06-10-2009, 10:36 AM   #2 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Turn on Golbal Catalog Referrals

KB16118 - Turn on global catalog referrals in a Microsoft Exchange 2007 environment
Offline  
Old 06-10-2009, 11:15 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: May 2009
Model: 8700g
PIN: N/A
Carrier: T-Mobile
Posts: 86
Post Thanks: 7
Thanked 1 Time in 1 Post
Default

Thanks a lot, hdawg. I've also subscribed to the RSS feed of your blog.
Offline  
Old 06-10-2009, 01:06 PM   #4 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

You're welcome; and thank you!
Offline  
Old 06-11-2009, 06:46 AM   #5 (permalink)
Thumbs Must Hurt
 
Join Date: Sep 2006
Location: Woodbridge, VA
Model: 9530
Carrier: VZW
Posts: 89
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a question about this...I applied this reg hack on one of our test servers and tried to test by creating a host file entry to the DC that the BES was talking to and then I changed the IP address. When I pinged the name of the DC, it came up with the modified IP and "no response"; however, I never lost the ability to send/receive email and the BES never flipped over to another DC. Is there something else I have to do to force that?
__________________
Exchange 2007/BES 4.1.6
Offline  
Old 06-11-2009, 06:55 PM   #6 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

uhh ... I think maybe I'm just being dense. I read this 5 times and still can't piece it together. Can you say this again in idiot speak with pictures and sounds?
Offline  
Old 08-19-2009, 11:16 AM   #7 (permalink)
Thumbs Must Hurt
 
Join Date: Sep 2006
Location: Woodbridge, VA
Model: 9530
Carrier: VZW
Posts: 89
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yielding to the experts on this one...

So, I applied the registry fix mentioned in KB16118 and its not working. Each month when the Domain Controllers are patched and rebooted, we experience mail disruption. I've reviewed the logs myself and also had RIM review the logs and the Domain Controller never changes. In fact, after we reboot the BES, it picks up the same Domain Controller it used before. We're running Exchange 2007 and I have the MAPI/CDO 1.2.1 installed on the BES.

That being said, is this fix more for when a DC goes down unexpectedly? I'm thinking that the DC comes up quicker than it takes for the BES to act on the new referral. It looks like it takes no more than 5min for the DC to come back up.

Any insight you can provide would be greatly appreciated. I'm getting hammered by my gov't leads on this. Thanks!
__________________
Exchange 2007/BES 4.1.6

Last edited by dmbascfan : 08-19-2009 at 11:22 AM.
Offline  
Old 08-19-2009, 02:35 PM   #8 (permalink)
Thumbs Must Hurt
 
Join Date: May 2009
Model: 8700g
PIN: N/A
Carrier: T-Mobile
Posts: 86
Post Thanks: 7
Thanked 1 Time in 1 Post
Default

Right there with you, still seeing the issue even after that above fix. There's a hotfix for BES+DCs that may help a little (basically returns a different status code while the DC is shutting down - support.microsoft.com/?id=942636), but that's still not ideal.
Offline  
Old 08-20-2009, 05:12 AM   #9 (permalink)
Thumbs Must Hurt
 
Join Date: Sep 2006
Location: Woodbridge, VA
Model: 9530
Carrier: VZW
Posts: 89
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I talked with RIM yesterday and there is a MS KB article that talks about another registry change that is needed. The MS KB (929439) talks about Exchange 2003 but RIM says that it is also needed for Exchange 2007. I told RIM that they need to update their KB article as it is unclear as to the MS requirement...I'll let you know how it goes.
__________________
Exchange 2007/BES 4.1.6
Offline  
Old 08-20-2009, 10:50 AM   #10 (permalink)
Thumbs Must Hurt
 
Join Date: May 2009
Model: 8700g
PIN: N/A
Carrier: T-Mobile
Posts: 86
Post Thanks: 7
Thanked 1 Time in 1 Post
Default

That KB article references a hotfix for the Exchange servers. I don't know any sysadmin who would install a 2003 hotfix on a 2007 server without Microsoft sign off. So that's out, sadly.
Offline  
Old 08-20-2009, 01:14 PM   #11 (permalink)
Thumbs Must Hurt
 
Join Date: Sep 2006
Location: Woodbridge, VA
Model: 9530
Carrier: VZW
Posts: 89
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Its not the hotfix...there is a registry change in there...RIM says it is required as well for Exchange 2007. the hotfix is already incorporated into the MAPI/CDO 1.2.1 utility.

I can let you know how it works for us if you'd like.
__________________
Exchange 2007/BES 4.1.6
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.