BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   Help with strange error log (http://www.blackberryforums.com/bes-admin-corner/193977-help-strange-error-log.html)

wbeers 06-17-2009 10:12 AM

Help with strange error log
 
Hi folks,

Been over every thread, forums and KB article I can find. I've administered BES 4.x in Exchange 2003 environments before, but this is the first time I've worked with 5.0. I have caught up on everything and pored over plenty of material and figured out plenty of smaller problems, but I am stuck trying to get the Blackberry Agent to start.

Environment:

BES 5.0 installed on Windows Server 2008 x64 SP1 which also hosts Exchange 2007 SP1
SQL Server 2005 hosting the database on Windows Server 2003 SP1

Gone through all the necessary procedures, permissions, settings, configurations, etc. to set up BES correctly. I can add users via the web management tool and SRP is working correctly, and MAPI appears to be working as well. However, I am getting error 5305 in the log. I have been through KB01018 multiple times but nothing seems to apply. IEMStest reports no problems. The BESadmin account is visible in the GAL. I have Public Folders and OAB working to the best of my knowledge. I am sure there are more things on the "checklist" that I've covered, but that's a good start. The troubling bit is the MAGT error log:

Code:

UTF-8 encoded
[30000] (06/17 09:57:49.938):{0x364} Current Date: 2009/06/17
[30000] (06/17 09:57:49.938):{0x364} [DIAG] EVENT=Thread_report, THREADID=0x364, THREADNAME="DebugLogger"
[30000] (06/17 09:57:49.939):{0x364} [ENV] Current Process: c:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BlackBerryAgent.exe
[30000] (06/17 09:57:49.939):{0x364} [ENV] Current Process logged on as: CPMFCU\besadmin, Start Time: Jun 17 2009 09:57:49, Uptime (seconds): 0
[30000] (06/17 09:57:49.939):{0x364} [ENV] Current Process id: 8804
[30000] (06/17 09:57:49.939):{0x364} [ENV] Computer Host Name: EXCHANGE, OS Version: 6.0, Build number 6001, ServicePack Major 1, ServicePack Minor 0
[30000] (06/17 09:57:49.939):{0x364} [ENV] Processor Identifier: Intel64 Family 6 Model 23 Stepping 6
[30000] (06/17 09:57:49.939):{0x364} [ENV] Processor Vendor Identifier: GenuineIntel
[30000] (06/17 09:57:49.939):{0x364} [ENV] Processor Name String: Intel(R) Xeon(R) CPU          E5450  @ 3.00GHz
[30000] (06/17 09:57:49.939):{0x364} [ENV] Number of Processors: 8
[30000] (06/17 09:57:49.939):{0x364} [ENV] 94 percent of memory in use.
[30000] (06/17 09:57:49.939):{0x364} [ENV] Total size of physical memory: 16770052 KB
[30000] (06/17 09:57:49.939):{0x364} [ENV] Size of physical memory available: 950896 KB
[30000] (06/17 09:57:49.939):{0x364} [ENV] Size of the committed memory limit: 33776664 KB
[30000] (06/17 09:57:49.939):{0x364} [ENV] Size of available memory to commit: 16644104 KB
[30000] (06/17 09:57:49.939):{0x364} [ENV] Total size of the user mode portion of the virtual address space of the BES process: 2097024 KB
[30000] (06/17 09:57:49.940):{0x364} [ENV] Size of unreserved and uncommitted memory in the user mode portion of the virtual address space of the BES process: 2011992 KB
[30000] (06/17 09:57:49.940):{0x364} [ENV] Total HD bytes: 597996597248, Total free bytes = 446417817600
[30000] (06/17 09:57:49.969):{0x364} [ENV] System up time: 0 days 07 hrs 55 mins 56 secs
[30000] (06/17 09:57:49.969):{0x364} [ENV] Local Time Zone: Eastern Daylight Time (GMT-05:00)
[30000] (06/17 09:57:49.970):{0x364} [ENV] TCP/IP provider (Winsock) File Version: 6.0.6001.18000 (C:\Windows\System32\wsock32.dll)
[30000] (06/17 09:57:49.970):{0x364} [ENV] Local machine IP Address = 10.131.16.80
[30000] (06/17 09:57:49.971):{0x364} [ENV] Winsock2 file: @%SystemRoot%\system32\wshtcpip.dll,-60103, Version: 6.0.6001.18000 (C:\Windows\System32\mswsock.dll)
[30000] (06/17 09:57:49.971):{0x364} [ENV] Winsock2 file: NTDS, Version: 6.0.6000.16386 (C:\Windows\System32\winrnr.dll)
[30000] (06/17 09:57:49.971):{0x364} [ENV] Winsock2 file: @%SystemRoot%\system32\nlasvc.dll,-1000, Version: 6.0.6001.18000 (C:\Windows\system32\NLAapi.dll)
[30000] (06/17 09:57:49.972):{0x364} [ENV] Winsock2 file: @%SystemRoot%\system32\napinsp.dll,-1000, Version: 6.0.6001.18000 (C:\Windows\system32\napinsp.dll)
[30000] (06/17 09:57:49.972):{0x364} [ENV] Microsoft XML Parser 6.0: C:\Windows\System32\msxml6.dll, Version: 6.20.1099.0
[30000] (06/17 09:57:50.261):{0x364} [ENV] MSSQL OLEDB provider is available: [SQLOLEDB]
[30000] (06/17 09:57:50.261):{0x364} [ENV] SQLCLI provider is available: [SQLNCLI]
[30000] (06/17 09:57:50.261):{0x364} [ENV] MDAC version: 6.0.6001.18000
[30000] (06/17 09:57:50.261):{0x364} [ENV] MSADO15.DLL: C:\Program Files (x86)\Common Files\System\ado\msado15.dll, Version: 6.0.6001.18000
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: System, ID: 4
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: smss.exe, ID: 456
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: csrss.exe, ID: 524
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: wininit.exe, ID: 576
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: csrss.exe, ID: 584
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: services.exe, ID: 620
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: winlogon.exe, ID: 644
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: lsass.exe, ID: 672
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: lsm.exe, ID: 680
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: svchost.exe, ID: 836
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: svchost.exe, ID: 896
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: LogonUI.exe, ID: 972
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: svchost.exe, ID: 980
[30000] (06/17 09:57:50.266):{0x364} [ENV] Running Process: svchost.exe, ID: 244
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: svchost.exe, ID: 348
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: SLsvc.exe, ID: 336
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: svchost.exe, ID: 504
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: svchost.exe, ID: 740
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: svchost.exe, ID: 880
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: svchost.exe, ID: 1128
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: spoolsv.exe, ID: 1392
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: svchost.exe, ID: 1420
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: taskeng.exe, ID: 1496
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: BAS-NCC.exe, ID: 1596
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: BBAttachServer.exe, ID: 1616
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: BBAttachMonitor.exe, ID: 1636
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: BlackberryRouter.exe, ID: 1704
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: BESAlert.exe, ID: 1812
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: inetinfo.exe, ID: 2180
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: MSExchangeADTopologyService.exe, ID: 2284
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: msftesql.exe, ID: 2344
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: sqlservr.exe, ID: 2400
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: svchost.exe, ID: 2484
[30000] (06/17 09:57:50.267):{0x364} [ENV] Running Process: svchost.exe, ID: 2496
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: sqlbrowser.exe, ID: 2524
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: sqlwriter.exe, ID: 2620
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: vialogsv.exe, ID: 2660
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: svchost.exe, ID: 2740
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: svchost.exe, ID: 2752
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: BAS-AS.exe, ID: 2876
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: Microsoft.Exchange.AntispamUpdateSvc.exe, ID: 2932
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: WmiPrvSE.exe, ID: 3952
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: Microsoft.Exchange.EdgeSyncSvc.exe, ID: 4108
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: MsExchangeFDS.exe, ID: 4212
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: MSExchangeMailboxAssistants.exe, ID: 4260
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: MSExchangeMailSubmission.exe, ID: 4304
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: Microsoft.Exchange.Cluster.ReplayService.exe, ID: 4348
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: Microsoft.Exchange.Search.ExSearch.exe, ID: 4424
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: Microsoft.Exchange.ServiceHost.exe, ID: 4480
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: MSExchangeTransport.exe, ID: 4596
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: MSExchangeTransportLogSearch.exe, ID: 4676
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: EdgeTransport.exe, ID: 4824
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: pvlsvr.exe, ID: 5024
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: beremote.exe, ID: 5244
[30000] (06/17 09:57:50.268):{0x364} [ENV] Running Process: store.exe, ID: 5264
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: mad.exe, ID: 5332
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: w3wp.exe, ID: 5340
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: beserver.exe, ID: 5828
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: benetns.exe, ID: 6284
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: bengine.exe, ID: 6312
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: w3wp.exe, ID: 7716
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: csrss.exe, ID: 8592
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: winlogon.exe, ID: 8616
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: msdtc.exe, ID: 8812
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: taskeng.exe, ID: 9072
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: rdpclip.exe, ID: 9208
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: dwm.exe, ID: 7884
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: explorer.exe, ID: 7484
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: jusched.exe, ID: 6784
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: iexplore.exe, ID: 4324
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: svchost.exe, ID: 7420
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: RIMDeviceManager.exe, ID: 6172
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: BbDevMgr.exe, ID: 6864
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: cmd.exe, ID: 8940
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: mmc.exe, ID: 5700
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: BlackBerryController.exe, ID: 3620
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: BlackBerryDispatcher.exe, ID: 9180
[30000] (06/17 09:57:50.269):{0x364} [ENV] Running Process: msftefd.exe, ID: 5496
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: w3wp.exe, ID: 6720
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: TranscodingService.exe, ID: 6484
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: wuauclt.exe, ID: 7952
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: BlackBerrySyncServer.exe, ID: 6168
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: BlackBerryMailStoreSrvr.exe, ID: 3540
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: BlackBerryPolicyServer.exe, ID: 3496
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: csrss.exe, ID: 6236
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: winlogon.exe, ID: 1584
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: taskeng.exe, ID: 7156
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: rdpclip.exe, ID: 8552
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: dwm.exe, ID: 1844
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: explorer.exe, ID: 6304
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: jusched.exe, ID: 9320
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: cmd.exe, ID: 10032
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: BBConvert.exe, ID: 9560
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: BBConvert.exe, ID: 9536
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: BBConvert.exe, ID: 9492
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: BBConvert.exe, ID: 6436
[30000] (06/17 09:57:50.270):{0x364} [ENV] Running Process: BlackBerryAgent.exe, ID: 8804
[40000] (06/17 09:57:50.272):{0x364} [DIAG] EVENT=Syslog_connected, EVENTMSG="Connected to 127.0.0.1"
[50076] (06/17 09:57:50.348):{0x1D4C} Starting BlackBerry Mailbox Agent 1 for Server CPM-BES - Version 5.0.0.110
[30221] (06/17 09:57:50.388):{0x1D4C} BES Cryptographic Kernel module is initialized and working properly
[30000] (06/17 09:57:50.388):{0xF7C} [DIAG] EVENT=Register_thread, THREADID=0xF7C, THREADNAME="ExtUDPLogThread"
[50049] (06/17 09:57:50.389):{0xF7C} Waiting for external UDP log messages on port 4085
[45009] (06/17 09:57:50.389):{0x1D4C} More cache hit rate: 0.0%, requests: 0, adds: 0, size: 0.0/30.0 Mb
[45014] (06/17 09:57:50.389):{0x1D4C} ExtMore cache hit rate: 0.0%, requests: 0, adds: 0, size: 0/20000
[45079] (06/17 09:57:50.389):{0x1D4C} Attachment cache hit rate: 0.0%, requests: 0, adds: 0, size: 0.0/30.0 Mb
[40212] (06/17 09:57:50.389):{0x1D4C} Address cache hit rate: 0.0%, requests: 0, adds: 0, size: 0
[40328] (06/17 09:57:50.389):{0x1D4C} Failed cache hit rate: 0.0%, requests: 0, adds: 0, size: 2
[30054] (06/17 09:57:50.389):{0x1D4C} Starting Message System
[30055] (06/17 09:57:50.391):{0x1D4C} Using MAPI profile BlackBerryServer
[40206] (06/17 09:57:50.401):{0x1D4C} MailboxManager::SubsystemInitialize - Using MAPI profile 'BlackBerryServer'
[40113] (06/17 09:57:50.404):{0x1D4C} MailboxManager::InitializeProfile - HrSetOneProp(BlackBerryServer_Agent1,PR_PROFILE_UI_STATE) Value=16384
[40113] (06/17 09:57:50.404):{0x1D4C} MailboxManager::InitializeProfile - HrSetOneProp(BlackBerryServer_Agent1,PR_PROFILE_CONNECT_FLAGS) Value=4
[40113] (06/17 09:57:50.404):{0x1D4C} MailboxManager::InitializeProfile - HrSetOneProp(BlackBerryServer_Agent1,PR_PROFILE_AUTH_PACKAGE) Value=9
[40113] (06/17 09:57:50.404):{0x1D4C} MailboxManager::InitializeProfile - HrSetOneProp(BlackBerryServer_Agent1,PR_PROFILE_ABP_ALLOW_RECONNECT) Value=1
[40113] (06/17 09:57:50.407):{0x1D4C} MailboxManager::InitializeProfile - HrSetOneProp(BlackBerryServer_Agent1,PR_PROFILE_CONNECT_FLAGS) Value=32772
[20137] (06/17 09:57:50.408):{0x1D4C} MailboxManager::InitializeProfile - OpenMsgStore (0x80040111)
[40113] (06/17 09:57:50.408):{0x1D4C} MailboxManager::InitializeProfile - HrSetOneProp(BlackBerryServer_Agent1,PR_PROFILE_CONNECT_FLAGS) Value=4
[20137] (06/17 09:57:50.408):{0x1D4C} MailboxManager::SubsystemInitialize - OpenMsgStore (0x80040111)
[30000] (06/17 09:57:50.409):{0x1D4C} [ENV] MAPI32.DLL: C:\Windows\system32\MAPI32.dll, Version: 1.0.2536.0
[30000] (06/17 09:57:50.409):{0x1D4C} [ENV] CDO.DLL: C:\Program Files (x86)\ExchangeMapi\cdo.dll, Version: 6.5.8069.0
[30000] (06/17 09:57:50.409):{0x1D4C} [ENV] Microsoft Management Console (MMC): C:\Windows\system32\mmc.exe, Version: 6.0.6001.18000
[30000] (06/17 09:57:50.410):{0x1D4C} [ENV] Failed to read 001e6602 reg value from the BlackBerry MAPI profile.
[30000] (06/17 09:57:50.410):{0x1D4C} [ENV] BlackBerry Mailbox Agent 1 - BESX Version 5.0.0.110
[30000] (06/17 09:57:50.410):{0x1D4C} [ENV] BES Service Name: BlackBerry Mailbox Agent
[30000] (06/17 09:57:50.410):{0x1D4C} [ENV] BlackBerry Dispatcher: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BlackBerryDispatcher.exe, Version: 5.0.0.103
[30000] (06/17 09:57:50.411):{0x1D4C} [ENV] BlackBerry User Administration Service: NOT FOUND
[30000] (06/17 09:57:50.411):{0x1D4C} [ENV] BlackBerry MDS Connection Service: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\MDS\bin\bmds.exe, Version: 5.0.0.86
[30000] (06/17 09:57:50.411):{0x1D4C} [ENV] BlackBerry Database Consistency Service: NOT FOUND
[30000] (06/17 09:57:50.412):{0x1D4C} [ENV] BlackBerry Policy Service: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BlackBerryPolicyServer.exe, Version: 5.0.0.97
[30000] (06/17 09:57:50.413):{0x1D4C} [ENV] BlackBerry Synchronization Service: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\SyncServer\BlackBerrySyncServer.exe, Version: 5.0.0.100
[30000] (06/17 09:57:50.413):{0x1D4C} [ENV] BlackBerry Router: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BypassRouter\BlackberryRouter.exe, Version: 5.0.0.103
[30000] (06/17 09:57:50.414):{0x1D4C} [ENV] BlackBerry Controller: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BlackBerryController.exe, Version: 5.0.0.110
[30000] (06/17 09:57:50.414):{0x1D4C} [ENV] BlackBerry Alert: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BESAlert.exe, Version: 5.0.0.94
[30000] (06/17 09:57:50.415):{0x1D4C} [ENV] BlackBerry Attachment Service: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\AttachServer\BBAttachServer.exe, Version: 5.0.0.46
[45060] (06/17 09:57:50.415):{0x1D4C} {ConnectionPool::ValidatePool}: Pool is not initialized
[30000] (06/17 09:57:50.415):{0x1D4C} [ENV] [DB] SQLServer hostname: CPM-DBSRV, Database name: BESMgmt
[30480] (06/17 09:57:50.415):{0x1D4C} [CFG] BES failover mode is ACTIVE
[41120] (06/17 09:57:50.415):{0x1D4C} [CFG] Address Lookup is enabled
[41122] (06/17 09:57:50.415):{0x1D4C} [CFG] LDAP search is disabled, LDAP PIM search is disabled, LDAP ALP search is disabled
[41123] (06/17 09:57:50.415):{0x1D4C} [CFG] Using up to 10 external CDO Helpers in keep-alive mode
[41124] (06/17 09:57:50.415):{0x1D4C} [CFG] AddOwnerApptID is disabled
[41125] (06/17 09:57:50.415):{0x1D4C} [CFG] SetLocaleIDs is disabled
[40532] (06/17 09:57:50.415):{0x1D4C} [CFG] vCard conversion support has been enabled
[40892] (06/17 09:57:50.415):{0x1D4C} [CFG] GlobalRescan config: messaging:O, calendar:O, pim:O
[40000] (06/17 09:57:50.415):{0x1D4C} [CFG] MAPI Encoding is 1
[10277] (06/17 09:57:50.415):{0x1D4C} BlackBerry Messaging Agent CPM-BES Agent 1 failed to start. Error code 5305
[50106] (06/17 09:57:50.415):{0x1D4C} Stopping BlackBerry Mailbox Agent 1 for Server CPM-BES
[30000] (06/17 09:57:50.417):{0x10E0} [DIAG] EVENT=Register_thread, THREADID=0x10E0, THREADNAME="TimerThread"
[40000] (06/17 09:57:50.417):{0x10E0} [DEBUG] EVENTMSG="TimerThread thread started"
[40507] (06/17 09:57:51.389):{0xF7C} ExtUDPLogThread: Code on closing = 0
[30000] (06/17 09:57:51.389):{0xF7C} [DIAG] EVENT=Unregister_thread, THREADID=0xF7C, THREADNAME="ExtUDPLogThread"
[30065] (06/17 09:57:51.397):{0x1D4C} BlackBerry Mailbox Agent 1 for Server CPM-BES shutdown complete
====== END OF LOG ======

Specifically you can see the error code 5305, the odd bit about "Failed to read 001e6602 reg value from the BlackBerry MAPI profile" and the one that really worries me, "{ConnectionPool::ValidatePool}: Pool is not initialized". I can't find any info on that last error and it seems to be the breaking point between where my log stops and other people's logs keep going.

Any and all suggestions are welcome at this point.

mikehogan 06-18-2009 04:50 AM

BES 5.0 is not supported when installed on an Exchange 2007 server.

I would install the BES 5.0 software on its own server or the SQL server before I tried to get it working on the exchange server.

wbeers 06-18-2009 09:52 AM

"not supported" and "doesn't work" are two different things (though in my case they may as well be since it does not work currently). From what I've read it's "not recommended" and according to Blackberry's own installation tutorial there are theoretical performance issues but it should work up to a certain number of users. Since BES 5 works on x64 OSes, again this should theoretically resolve the issue.

We are looking into virtualization and installing onto other servers but for the time being this is what we are trying to do. I would appreciate some insight into the nature of the error so I can at least go about working towards a resolution.

kpoland 06-18-2009 10:40 AM

When you launch that profile, can you see the GAL? Also, can you start all the services manually?

hdawg 06-18-2009 10:47 AM

Check this out: KB17325 - BES may encounter issues in a Windows Server 2008 based AD environment

wbeers 06-18-2009 01:56 PM

Quote:

Originally Posted by hdawg (Post 1409110)
Check this out:

The only Windows Server 2008 server in the domain is hosting Exchange 2007 and this BES installation, it is not a domain controller. Both of our domain controllers/global catalog servers are running Windows Server 2003 Standard (32-bit). If I made that registry change, would I need to reboot the DCs or any services before being able to see the logs or the changes?

I also checked through the registry for the "001e6602" key, it is the computer name of the Exchange server. We were having an issue with MAPI resolution when I first installed, but that turned out to be because the server was resolving itself as "::1" (IPv6) when attempting to ping its own name. Disabling IPv6 didn't work, but a HOSTS entry took care of that. I know this is the sort of thing they mean when they suggest installing on another server...and if it's a red herring I apologize in advance.

hdawg 06-18-2009 02:11 PM

If you implemented the change everything would need a reboot.

Have you tried a new MAPI profile? Perhaps a new BESAdmin mailbox.

wbeers 06-18-2009 02:48 PM

Will try the reboot after hours and if that doesn't work, a new service account / mailbox with appropriate permissions. Can I just change the MAPI profile, or will I need to reinstall the software from scratch since I am changing the user? IEMSTest works fine and says I have all necessary permissions as my current BESAdmin.

All services are running by the way, it is just the Blackberry Mailbox Agent that won't start.

hdawg 06-18-2009 02:50 PM

KB10285 - How to re-create the BlackBerry Enterprise Server MAPI profile

KB04293 - How to switch BlackBerry Enterprise Server service accounts

Start with the first step. Usually you don't need to swap out accounts, just rebuild the MAPI profile.

wbeers 06-18-2009 02:56 PM

Thanks. I have done the first step a few times before to see if that was the issue with the current MAPI profile. If the reboot tonight doesn't fix it (which is probable) I'll go about trying a new service account per the instructions in those KB articles.

wbeers 06-18-2009 10:41 PM

Rebooted both DCs to no effect. the clue seems to be "openmsgstore (0x80040111)" which is an Exchange/MAPI error, "MAPI_E_LOGON_FAILED"...

Going to look into it more tomorrow, probably going to try a new service account. Thanks again for all your assistance.

hdawg 06-18-2009 10:47 PM

Can you zip up a day of the logs and email them to me? [email address] I'll be up for a few hours.

wbeers 06-18-2009 11:08 PM

Logs are in your inbox, thanks again!

hdawg 06-18-2009 11:10 PM

reading through them now ... If you launch the MAPI profile editor and delete the information in there and then re-enter it and hit Check Name (without hitting Apply/OK) does it properly resolve?

wbeers 06-18-2009 11:15 PM

Yes it does.

As I mentioned earlier, when I very first attempted the BES install about a week ago, it did not, and I was able to trace that to DNS queries to the server name resolving to ::1 on the local machine (something to do with Server 2008/IPv6). I set up a manual HOSTS entry with the hostname and the LAN IP address and was able to create the MAPI profile no problem from that point on, including after subsequent reinstalls.

hdawg 06-18-2009 11:26 PM

I think it may still be related to IPv6 ...

can you take a look at this? KB04646 - BlackBerry Controller cannot start Agents for Exchange or GroupWise

Can you disable IPv6 totally?

wbeers 06-18-2009 11:51 PM

Attempting to remove IPv6 (I'd like nothing better!) but it's getting late and doesn't seem to be removing correctly. I will attempt again in the morning. To test it, I took out the HOSTS entries, and still got a result of ::1 on pinging the server name and FQDN.

Will report back tomorrow morning. Thanks for finding those two articles for me!

hdawg 06-18-2009 11:52 PM

Hopefully it works :) Thanks for not giving up!

wbeers 06-19-2009 09:23 AM

IPv6 is gone. I took out the HOSTS entries and everything is resolving okay without them now.

I'm still getting the 5305 error, though. Been trying a bunch of different things this morning, my current lead is the lack of an [ENV] entry for EMSMDB32.DLL as listed in KB15779. Still trying to figure out why the 0x80040111 error keeps coming up. I enabled that logging on our domain controllers and didn't find that issue you mentioned earlier, but I do see a trio of NTDS events happening in rapid succession - event 1172 by ANONYMOUS LOGON, a N/A event 2041, and then event 1138 from user besadmin. The IP listed in the 1172 event is the LAN IP of the server. Why would it be using ANONYMOUS LOGON...?

hdawg 06-19-2009 10:10 AM

Had you rebooted after removing IPv6?

Can you reboot and then send over another set of logs to me?


All times are GMT -5. The time now is 01:38 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.