BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-26-2009, 05:40 AM   #1 (permalink)
New Member
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: Telstra
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Unable to delete/readd user

Please Login to Remove!

I'm running BES 4.1.6 Express for GroupWise and have deleted a user. I now need to re-add the user but it keeps complaining that the user still exists.

I can see that the user still appears to be using a license, but doesnt appear in the users list.

Some posts have suggested purging the user, which I cant see in the express version at all!

I tried a SQL script to remove the user as follows -

1>use BESMgmt
2>delete from UserConfig where DisplayName="xxxx"
3>go
1>exit

This spits an error -

Msg 8646, Level 21, State 1, Server xxx, Line 1
The index entry for row ID was not found in index ID 3, of table 827149992,
in database 'BESMgmt'.

I'm now stuck, any ideas on how I can kill this user so they can be re-added without having to reinstall the entire BES server and DB?
Offline  
Old 06-26-2009, 07:12 AM   #2 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

You deleted the user through the BlackBerry Manager console and then you ran the SQL script?
Offline  
Old 06-26-2009, 08:02 AM   #3 (permalink)
New Member
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: Telstra
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah, i deleted the user, waited a good 6 hours and now need to re-add the user...

Basically the user shouldnt have been deleted to start with..
Offline  
Old 06-26-2009, 08:04 AM   #4 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

If you do: SELECT * from UserConfig is the user listed still?
Offline  
Old 06-26-2009, 07:34 PM   #5 (permalink)
New Member
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: Telstra
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

yep, still appears in the userconfig database.

think i may have to reinstall....great
Offline  
Old 06-26-2009, 09:03 PM   #6 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

before doing that I'd spend the money and call T-Support.
Offline  
Old 06-29-2009, 10:47 AM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2006
Location: Los Angeles
Model: 9000
Carrier: AT&T
Posts: 30
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've see this happen before especially if the account on the BES was created a long time ago. It can sometimes take several hours to delete the user completely but to speed up the process I restart all the services, wait a couple minutes and try adding the user again.
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.