BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-16-2009, 05:25 PM   #1 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,360
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default S/MIME signed messages appear empty

Please Login to Remove!

I know, to use S/MIME encryption, I need to turn on support for this on the server ( 5.0 ), and, eventually even need other CALs.

But,
When I receive a S/MIME signed message, where the body is in clear text, I would assume, this should work.
But, it does not.
I only get the messages with the subject,
the body of the message on the device is empty.

Question:
Is it safe to turn on S/MIME processing on the server, and, will this help ?
I do not want to encrypt all emails going through this server.

What is the current situation regarding licensing for S/MIME messages ? Someone here wrote it is free, but, you need different CALs ?
Offline  
Old 08-07-2009, 01:40 AM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,360
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

Ok - I think its free, no different CALs are neccessary.

I enabled s/mime processing on the server, and, since in the (Beta) Device os 5.0.x.y is s/mime support included, I hoped that emails should be readable now.
But it is not.
Now, when a mail is received, The senders certificate is displayed and accepted as valid. The certificate chain is ok.
Still, the body of the email seems to be empty - which is not, because outlook will display it properly.
The mail is not encrypted, only signed.

I even cannot reply to the email. If I try this, I get the error message that an unknown type of attachment is inside the message after a short time, and, the mail is marked with a red X.


This looks like a problem with the server, not with the Beta software on the Device.

Is ther anything I can do ? I have BES 5.0 MR1.
Offline  
Old 08-07-2009, 06:18 AM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Jan 2006
Model: LEZ10
OS: 10.0.10
Carrier: Rogers CA
Posts: 1,704
Post Thanks: 20
Thanked 77 Times in 68 Posts
Default

Have you loaded S/MIME support into the blackberry?
__________________
My other Blackberry is a PlayBook.
Offline  
Old 08-07-2009, 01:37 PM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,360
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

i would say yes, because otherwise, I should not be able to check the certificate.
But now, when you are asking this question, I must admit, I have not checked if the option was selected during the OS upgrade procedure.

Thank you, I post again when I have verified this.
Offline  
Old 08-08-2009, 07:45 AM   #5 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,360
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

The "s/mime" support package, version 5.0.0 is installed. And it is listed in the Applications list of the device.

Of course, using a unfinished beta OS can produce strange things.

However, I would be interested, If anyone else sucessful can read/reply to s/mime signed messages using a Handheld with a released OS (4.x) connected to a BES 5.0 server
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.